#ansible-docs: Documentation Working Group Supplemental

Meeting started by samccann at 15:30:43 UTC (full logs).

Meeting summary

  1. openning chatter (samccann, 15:30:56)
  2. Personas (samccann, 15:34:36)
    1. first thoughts on personas - https://etherpad.opendev.org/p/ansible-documentation-split (samccann, 15:35:27)
    2. not a clear boundary between 'users' and 'creators' in this sense. some places will hand a user a playbook and tell them to write their own inventory. Other places the user is the creator as well. (samccann, 15:51:12)
    3. one option for 'release independent' developer guides - put all the version-specific information in one guide. So 'in ansible-base...do this... in ansible-core.2.11, do this other thing, etc. (samccann, 15:57:20)
    4. Community guide and much of the developer guide content could be release-independent (samccann, 16:00:45)
    5. testing info in the dev guide might be core-specific and we'd need a separate testing section for collection developers etc (samccann, 16:01:40)

  3. release dependent vs independent docs (samccann, 16:02:21)
    1. we have started maintaining some pages only in devel and stubbing out the info in older versions. release and maintenance, porting guides.. (samccann, 16:08:05)
    2. https://docs.ansible.com/ansible/devel/dev_guide/ (https://github.com/ansible/ansible/tree/devel/docs/docsite/rst/dev_guide) (gundalow, 16:10:43)
    3. https://docs.ansible.com/ansible/latest/community/ (felixfontein, 16:17:12)
    4. consider one dev guide, with separate 'chapters' for Ansible developer vs ansible-core developer. Same with user-creater personas - not separate books, but separate sections within a book for example (samccann, 16:22:18)

  4. Next Steps (samccann, 16:24:26)
    1. our goal for the ansible vs ansible-core split is to have a non-versioned docs-set for developers alongside existing versioned docs, with content that starts to explain the differences (samccann, 16:31:28)
    2. next steps - create a proposed TOC etc for next week's discussion (samccann, 16:39:07)
    3. ACTION: gwmngilfen and acozine to work on the docs survey (samccann, 16:40:23)
    4. Tentative schedule for 2.11: https://hackmd.io/y7BBcweNR3aRVLuMbKkDxw (samccann, 16:43:24)


Meeting ended at 16:43:49 UTC (full logs).

Action items

  1. gwmngilfen and acozine to work on the docs survey


Action items, by person

  1. acozine
    1. gwmngilfen and acozine to work on the docs survey
  2. gwmngilfen
    1. gwmngilfen and acozine to work on the docs survey


People present (lines said)

  1. samccann (102)
  2. acozine (53)
  3. felixfontein (32)
  4. abadger1999 (26)
  5. gundalow (21)
  6. dmsimard (20)
  7. gwmngilfen (14)
  8. zodbot (12)
  9. bcoca (5)
  10. dericcrago (5)
  11. geerlingguy (4)
  12. cyberpear (2)
  13. lmodemal (1)
  14. cybette (1)


Generated by MeetBot 0.1.4.