14:32:06 <acozine> #startmeeting Docs Working Group aka DaWGs
14:32:06 <zodbot> Meeting started Tue Nov 17 14:32:06 2020 UTC.
14:32:06 <zodbot> This meeting is logged and archived in a public location.
14:32:06 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:32:06 <zodbot> The meeting name has been set to 'docs_working_group_aka_dawgs'
14:32:12 <felixfontein> hi :)
14:32:14 <acozine> #topic opening chatter
14:32:19 <acozine> hi felixfontein!
14:32:20 <felixfontein> I was wondering a bit what happened to the announcement :)
14:32:23 <samccann> o/
14:32:27 <acozine> #chair lmodemal samccann felixfontein
14:32:27 <zodbot> Current chairs: acozine felixfontein lmodemal samccann
14:32:34 * tadeboro misses the DINGs ;)
14:32:42 <acozine> we haven't adapted to the time change quite yet
14:32:47 <samccann> heh. Tues. is grocery day so I don't get logged in now until right before the meeting
14:32:48 <dmsimard> \o
14:33:01 <acozine> tadeboro: just for you: DING DING DING
14:33:07 <tadeboro> \o/
14:33:09 <acozine> #chair tadeboro dmsimard
14:33:09 <zodbot> Current chairs: acozine dmsimard felixfontein lmodemal samccann tadeboro
14:33:27 <acozine> who else is around?
14:34:41 <acozine> gundalow: alongchamps andersson007_ briantist cyberpear madonius mrproper persysted tremble I'm pinging you because you've joined the conversation before
14:34:47 <acozine> talking docs today?
14:34:52 <cyberpear> o/
14:35:00 * dericcrago waves
14:35:14 * tremble lurks but doesn't need to become furniture
14:35:17 <cyberpear> I'm only sort of here... in several meetings at once
14:35:18 <alongchamps> I am not around today unfortunately, double-booked for 10 EST
14:35:26 <acozine> for anyone who is watching this chat and thinking, "but they didn't ping me" . . .  please join in any time!
14:35:54 <acozine> hi and welcome cyberpear dericcrago tremble
14:35:57 <acozine> alongchamps: bummer
14:36:02 <acozine> #chair dericcrago
14:36:02 <zodbot> Current chairs: acozine dericcrago dmsimard felixfontein lmodemal samccann tadeboro
14:36:12 <acozine> cyberpear: you want to be furniture?
14:36:36 <cyberpear> no need, thanks!
14:36:49 <cyberpear> .chair cyberpear
14:36:51 <zodbot> cyberpear is seated in a chair with a nice view of a placid lake, unsuspecting that another chair is about to be slammed into them.
14:37:30 <acozine> heh
14:37:48 <samccann> omgosh!!!
14:37:55 <acozine> it's a COVID meeting - NO CHAIR-SLAMMING!
14:38:33 <dmsimard> agenda ? :)
14:38:38 * gundalow waves
14:38:43 <gwmngilfen> o/
14:38:44 <acozine> #chair gundalow
14:38:44 <zodbot> Current chairs: acozine dericcrago dmsimard felixfontein gundalow lmodemal samccann tadeboro
14:38:49 <acozine> #chair gwmngilfen
14:38:49 <zodbot> Current chairs: acozine dericcrago dmsimard felixfontein gundalow gwmngilfen lmodemal samccann tadeboro
14:38:51 <lmodemal> hey gundalow!
14:38:54 * gundalow sits
14:38:57 <acozine> agenda begins with https://github.com/ansible/community/issues/521#issuecomment-724802607
14:38:59 <gwmngilfen> !!
14:39:35 <acozine> and i have a late-breaking addition as well ;-)
14:39:47 <acozine> maybe we can get through a few items quickly?
14:40:01 <felixfontein> let's try that!
14:40:02 <samccann> shoot... I forgot to followup with abadger as someone who could attempt taking rst files out of the tarballs and estimate how hard/easy it is
14:40:22 <acozine> hmmm, maybe roll that one over to next week, then?
14:40:36 <acozine> I'll put them in the minutes though
14:40:43 <acozine> #topic removing rst files from tarballs
14:40:50 <samccann> #action samccann to followup with abadger on RST files out of the tarballs
14:40:59 <cyberpear> at what point does the "source tarball" no longer represent the actual source code if we're not shipping all the things there?
14:41:28 <samccann> hmm... interesting point
14:41:34 <acozine> cyberpear: that's one of the questions we have to answer - is there a legal consequence to breaking "the source tarball" into a couple of files?
14:41:44 <samccann> so for Ansible the package - I 'think' we already take some stuff out?
14:41:45 <dmsimard> with my distribution packager hat on, it's typical to have separate packages for docs and tests
14:41:48 <acozine> we would still provide the docs, it would just be a separate package
14:42:09 <acozine> dmsimard: ah, good to know
14:42:59 <samccann> #action samccann to again bug abadger to see if we already take anything out of the Ansible package that's part of the collections source
14:43:00 <acozine> but the question is moot until we have a way to pull the docs out (a way we can implement in a reasonable timeframe)
14:43:02 <tadeboro> cyberpear: Ansible is already a bit special since it includes collections from the galaxy, and there is no guarantee what those packages do (not) contain.
14:43:29 <dmsimard> so for example in a fedora or rhel package you'd have python3-foo with the actual python code, foo-tests for unit/integration tests and then foo-docs
14:43:33 <tremble> acozine, It would likely depend on the license that the code's released under
14:43:38 <cyberpear> the collections make it complicated, yes. For -base, it's probably not too big a deal since the git repo is public, but I think generally the tarball should be an editable body of code if someone wanted to base a patch on it.
14:43:49 <dmsimard> not all packages are that way, ultimately it's up to the packager
14:44:30 <tremble> acozine, But it's not that uncommon to (for example) not package up test suites.
14:44:57 <acozine> yeah, the conversation about licensing is complicated, and way outside of my area of expertise
14:45:03 <samccann> #info some package tarballs contain everything - e.g. should be an editable body of code if someone wanted to base a patch on it
14:45:41 <samccann> #info need to consider that as well as licensing/legal implications of removing docs etc from ansible tarballs
14:45:46 <felixfontein> getting rid of the tests/ directories in the collections would save a lot of space. and removing docs/ as well (though a lot less than tests/).
14:46:06 <acozine> but again, unless we can actually implement this change, we don't need to debate the legal side of things
14:46:27 <cyberpear> can't we just ship a wheel and remove the tests/docs/whatever from there, but keep it in the source tarball?
14:46:40 <cyberpear> (I know we don't ship a wheel today)
14:46:47 <dmsimard> felixfontein: I wonder not just about the size difference but the install performance too -- even the latest 2.10 still installs far slower than 2.9
14:47:13 <felixfontein> dmsimard: I think install performance is correlated to package size
14:47:38 <samccann> #info size of tarball may also be slowing down installation times...
14:47:46 <felixfontein> after removing all the coverage logs in the last release, package size reduced a lot and install got a lot faster
14:47:47 <dericcrago> is it size or number of files?
14:48:00 <samccann> ok I dunno what a wheel is, but for those who do  - is this something we should bring to core/community to discuss?
14:48:04 <dmsimard> dericcrago: little bit of column A and a little bit of column B ?
14:48:10 <felixfontein> no idea. tests usually are both big and many files, so it does not matter too much what's the exact reason
14:48:23 <dmsimard> samccann: wheel is more or less a pre-compiled package
14:48:25 <acozine> either way, docs would contribute a lot (and so would tests)
14:48:58 <cyberpear> might make sense to bring the wheel discussion t o core and/or community
14:48:59 <felixfontein> acozine: I think docs are a lot less than tests, like 10% vs. 40%-50% of the size
14:49:13 <acozine> felixfontein: ah, good to know
14:50:11 <dmsimard> ansible can't produce wheels yet: https://github.com/ansible/ansible/issues/71992#issuecomment-700739135
14:50:41 <felixfontein> dmsimard: that's ansible-base/ansible-core, not ansible
14:50:44 <cyberpear> but if we're stripping things out like tests/docs, I think it should be done at the wheel level (which we don't ship/create yet)... if we're making a separate PyPI package for the tests or docs, that might be different, but we already saw the pain that comes from splitting PyPI packages w/ the base/ACD split
14:51:10 <dmsimard> felixfontein: thank you for the distinction, that is what I meant, yes
14:51:11 <felixfontein> dmsimard: though, I think ansible also has that code thanks to pip and the 2.9 -> 2.10 change (and soon 2.10 -> 2.11)
14:51:31 <cyberpear> it'd be nice if he had more details in that comment... currently the setup.py checks that no older version of ansible is installed
14:52:10 <felixfontein> cyberpear: the dynamic code (I know about) makes sure that installing ansible-base does not wreck ansible 2.9, and vice versa
14:52:15 <gundalow> Did we get legal sign off yet?
14:52:43 <acozine> so removing the docs files is a complicated question, and one that is linked to many other concerns - I think we should explore the possibilities for implementing it (how long would it take, etc.) and then bring in the larger questions (legal, packaging, etc.)
14:53:51 <cyberpear> even if ansible-base can't ship a wheel, ansible ACD probably can ship a wheel, unless we have setup.py dynamics there, too
14:54:02 <felixfontein> cyberpear: as I said above, it has
14:54:14 <cyberpear> sorry, the complicated terminology strikes again
14:54:24 <cyberpear> I see "ansible" and still thing "ansible-base"
14:54:26 <cyberpear> *think
14:54:29 <samccann> so wheel solution isn't an option?
14:54:35 <samccann> for either  :-)
14:55:22 <samccann> #info cannot use wheel option because ansible-core and thus Ansible have setup.py dynamics. See https://github.com/ansible/ansible/issues/71992#issuecomment-700739135
14:56:43 <acozine> okay, I'm going to go rogue on our agenda
14:56:54 <acozine> and introduce a totally new topic
14:57:07 <acozine> #topic docs user survey
14:57:12 <samccann> heh
14:57:52 <felixfontein> :)
14:58:11 * gwmngilfen is totally not being a meerkat right now
14:58:26 <acozine> 2+ years ago I said we'd do a survey of docs users, and we're finally almost ready
14:59:26 <acozine> this is part of the conversation about re-organizing documentation around personas and levels of experience
15:00:07 <acozine> so things like "I'm a network admin" or "I'm just starting with Ansible because <other_automation_tool> isn't working for my team"
15:00:48 <acozine> of course I'd like to ask ALL THE QUESTIONS, but I know people won't actually fill in a survey of 150 questions . . .
15:01:29 <acozine> so I've got a draft and am looking for ideas about what are the most important/helpful things to ask
15:02:02 * acozine realizes that her draft is invisible to the outside world
15:02:05 <acozine> drat
15:02:09 <acozine> hang on
15:03:49 * samccann hums hold music
15:05:05 <acozine> okay, this looks awful, but it's a start: https://hackmd.io/JemYBo_8QbqqO9cULo3rJQ
15:05:30 <acozine> can folks see it?
15:05:38 <lmodemal> I can see it
15:06:24 <felixfontein> me too
15:06:34 <acozine> whoever is editing to make it look nice, thank you!
15:06:45 <samccann> lol a secret cleaning crew!
15:06:59 <lmodemal> I thought that was you acozine lol
15:07:08 <dmsimard> that's me
15:07:11 <dmsimard> just adding bullet points :p
15:07:18 <acozine> thanks dmsimard, it needed it
15:07:18 <felixfontein> on the second question: how about a 'looking up plugin options (reference)' option?
15:07:22 <lmodemal> good job dmsimard!
15:07:37 <felixfontein> that's what I'm doing a lot with the docs, and I guess other people are too
15:07:45 <gwmngilfen> dmsimard++
15:07:48 <zodbot> gwmngilfen: Karma for dmsimard changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:08:32 <acozine> felixfontein: good idea, added
15:08:48 <samccann> #info draft docs survey for review - https://hackmd.io/JemYBo_8QbqqO9cULo3rJQ
15:09:22 <gundalow> What's the objective of `The last time you used the Ansible documentation, what was your goal?`?
15:09:39 <dmsimard> for the first question I would defer to gwmngilfen but would a scale from 1 to 5 (or 1 to 10) work better ?
15:10:00 <gwmngilfen> its the same thing
15:10:09 <acozine> gundalow: you mean, what's the difference between `the last time` and `usually`? or what is the objective of `what was your goal` in general?
15:10:21 <gwmngilfen> you can use numbers if you want, but the fact remains that you are measuring something non-linear :)
15:10:45 <felixfontein> the employer section could use the option "my employer is not connected to redhat, also not as a customer, but I use ansible at work"
15:11:03 <dmsimard> felixfontein: +1
15:11:18 <gwmngilfen> +1 but, perhaps a bit shorter :P
15:11:29 <dmsimard> yeah, sure :p
15:11:33 <gundalow> acozine: How will you use the answers to that question
15:11:47 <acozine> felixfontein: I tried to roll the two answers into one, apparently not very successfully
15:12:04 <dmsimard> maybe rephrase the first option
15:12:14 <acozine> gundalow: it's the experience-based equivalent of "what kind of docs would you like to see more of?"
15:12:22 <gwmngilfen> +1 to gundalow's question, I hadn't spotted that they were essentially the same Q
15:12:55 <acozine> yeah, I think those two could be rolled into one, timeframe isn't important
15:13:10 <acozine> but the question itself is to find out what type of docs will be most useful
15:13:20 <gwmngilfen> keep the "usually" then
15:13:25 <acozine> at least, that's what I was thinking about/hoping for
15:14:14 <gundalow> Should `Q3` be "Have you ever used the docs to ... (tick all that apply)". Which would help us identify which areas people use the most/least?
15:14:43 <gundalow> Or do we need a more direct question along the lines of "areas of documentation" vs "how well I rate them"
15:14:59 <samccann> how is that different from using the adobe analytics to tell us what they use most/least?
15:15:09 <acozine> gundalow: I think we might get a lot of "all of the above"
15:15:11 <gwmngilfen> that could be quite a long list though, right?
15:15:48 <samccann> perhaps a question like 'tell us the top 3 areas of docs you want to see improvement on" or something?
15:16:04 <gwmngilfen> samccann: combing this with the AA stuff is a good point
15:16:32 <gwmngilfen> but if you want to cross-reference this with, say, job role, then we have to ask it here
15:16:45 <lmodemal> +1 samccann
15:17:03 <gwmngilfen> also, we could then use the AA to weight the survey, if we wanted to get really fancy
15:17:18 <acozine> samccann: that's a good question - I was hoping to tease out intent, which analytics can't give us
15:18:40 <acozine> samccann: for "top 3 areas for improvement", would that be write-in? or pick-3 from a list?
15:19:10 <samccann> i was thinking write in.  it might give us stuff all over the map though.  But I'm not sure I could pick which areas to add to a list
15:19:23 <gwmngilfen> i the list is large, then write-in is probably better
15:19:26 <gwmngilfen> *if
15:19:38 <gwmngilfen> i can deal with it :)
15:20:49 <samccann> write in gives them the option to be specific.
15:22:26 <acozine> all right, thanks everybody for the ideas and feedback, I'll keep working on this - if you come up with other ideas, bring them to the chat any time
15:23:10 <samccann> thanks for chugging through and creating the draft!
15:23:18 <gundalow> It's looking good, thanks for doing it
15:23:29 <felixfontein> indeed!
15:24:11 <acozine> I hope we can get some useful, actionable information out of it . . .
15:24:49 <acozine> we've got a bunch of follow-up items on the agenda
15:25:05 <acozine> #topic follow up on long-running items
15:26:29 <acozine> these include: collection /docs folder uses, filter/test plugin docs, role argspec, Felixfontein's sphinx extension for module docs, bitflip process for Ansible release, redirect policy be post 2.10, and the new documentation fields proposal
15:26:38 <felixfontein> the sphinx extension is now part of antsibull (not sure whether it's in a release yet though)
15:26:52 <felixfontein> #info the sphinx extension is now part of antsibull
15:27:00 <acozine> \o/
15:27:35 <felixfontein> besides that, nothing from my side
15:27:41 <Shrews> ohai! what would you like to know about role argspec?
15:28:02 <acozine> #chair Shrews
15:28:02 <zodbot> Current chairs: Shrews acozine dericcrago dmsimard felixfontein gundalow gwmngilfen lmodemal samccann tadeboro
15:28:36 <acozine> Shrews: do we have one?
15:28:50 <acozine> and if so, is it documented already?
15:29:49 <Shrews> we are working towards the feature for 2.11. what we currently have of that feature is a PR to ansible-doc (https://github.com/ansible/ansible/pull/72120) to output the spec docs. We still need changes to core to actually _use_ the spec, but that is being worked on as we speak.
15:30:29 <Shrews> I think I'll merge 72120 today, but it might need changes as we go.
15:31:23 <acozine> sounds like progress!
15:31:27 <acozine> thanks Shrews
15:31:29 <felixfontein> so still a lot of under development
15:31:41 <Shrews> But the spec itself is not yet publicly documented. We'll add that "real soon now"
15:31:42 <felixfontein> Shrews: are there plans to have some validation of role argspecs in ansible-test?
15:31:56 <Shrews> felixfontein: not currently
15:33:07 <samccann> shrews: - so does that mean the role docs will be generated from the role argspec?
15:33:14 <samccann> or am I just dreamin :-)
15:33:44 <Shrews> @samccann well, yes, but only in text format (or optional json). just like the output currently supported for plugins
15:34:14 <Shrews> there is an example in that PR description
15:34:45 <samccann> #info roleargspec PR - https://github.com/ansible/ansible/pull/72120
15:35:54 <felixfontein> Shrews: do role args support deprecation?
15:36:19 <gundalow> Shrews: myself (or sivel) can explain how to write schema validation for argspec. I'd like to see that in before this is released, Happy to help
15:36:47 <Shrews> felixfontein: not in the current design.
15:37:16 <Shrews> gundalow: we'll be using the AnsibleModule validation code for this. It's currently being extracted into a common utility
15:37:17 <acozine> the test output looks like we could send it through the docs pipeline, though we obviously can't publish docs for every role out there
15:37:51 <acozine> https://github.com/ansible/ansible/pull/72120/files#diff-96c4675726c535de24f519c4d5f49737a9fb0d184e166786e02b7033ae8ca0b0
15:38:10 <gundalow> Shrews: ace
15:38:15 <felixfontein> acozine: the docs pipeline would need to learn some specificalities of roles (like multiple entry-points), but it is doable :)
15:38:31 <acozine> it's not as big of a stretch as I'd feared
15:39:06 <felixfontein> Shrews: are there plans for a top-level description, besides having one per entry-point?
15:39:19 <samccann> so perhaps we would bring role docs in for the collections in Ansible that have them?
15:39:34 <samccann> does anyone know the roadmap for roles docs in AH/Galaxy?
15:39:40 <Shrews> felixfontein: no. descriptions are per entry point right now
15:40:14 <felixfontein> Shrews: it would be nice to be able to document something top-level. I guess right now it's still possible to add that to the design
15:40:31 <felixfontein> Shrews: (I'm also thinking of version_added for the changelog generator :) )
15:40:47 <acozine> yes, the overall "what does this role do / what is this role for" would be a good addition
15:41:09 <acozine> samccann: yes, I think we could bring role docs in for certain collections . . .
15:41:10 <felixfontein> Shrews: it would be annoying if `description`, `author`, `short_description`, `version_added`, ... would collide with entrypoints
15:41:32 <acozine> samccann: no idea on the AH/Galaxy roadmap
15:43:10 <felixfontein> Shrews: it could of course go into a separate file, but why load two files when one is enough? (also ansible-doc probably would have to load both then, because that's also stuff that should be shown by it)
15:44:56 <acozine> sounds like the role argspec discussion will continue
15:44:59 <tadeboro> If role argspec could contain roughly the things your usual README.md contains (short descritpion, variables and their purpose) that would be great.
15:45:30 <Shrews> (sorry, 2 concurrent meetings)...
15:45:34 <acozine> tadeboro: agreed
15:45:36 <sivel> Just something to clarify here, we're not shooting for the moon in the 2.11 release for argspec
15:45:50 <sivel> it'll be MVP, and may not solve every problem everyone wants to see solved
15:45:51 <acozine> sivel: you mean we can't have everything immediately???
15:45:51 <Shrews> ^ yes that ( i was just typing similar )
15:45:58 <felixfontein> sivel: true, but if entrypoints stay at top level, it is next to impossible to fix that later
15:46:20 <sivel> just saying, this meeting shouldn't devolve into a wish list for argspec
15:46:23 <acozine> we can design the MVP with later enhancements in mind
15:46:27 <acozine> sivel: gotcha
15:46:38 <sivel> s/argspec/role argspec/
15:46:40 <sivel> :)
15:47:43 <acozine> we've already `info`'d the PR for role argspec, right?
15:47:49 <acozine> so folks can put comments there
15:48:03 <samccann> yep
15:48:13 <acozine> samccann: thanks!
15:48:24 <acozine> all right, any other updates on our long-running topics?
15:48:29 <tadeboro> sivel: Maybe completely ignoring the documentation needs during the design statge is not the best thing? ;)
15:49:25 <sivel> I'm not against taking feedback, just want to make sure people understand the scope, and not to get too deep into the weeds with 100 different feature ideas to extend the MVP
15:50:32 <acozine> sivel: thanks
15:51:04 <acozine> sivel: Shrews leaving room for role-level documentation (as opposed to entry-point-level documentation) in the design would be really helpful
15:51:57 <acozine> we can't implement it all now, but if we preserve the possibility of implementing it later without rewriting the spec entirely, that would be good
15:52:13 <sivel> +1
15:52:20 <felixfontein> +1
15:52:26 <Shrews> noted. we could always add a 'role_summary' special entrypoint or something for that. nothing about the current design prevents adding it later
15:52:40 <felixfontein> I added the point about non-top-level entrypoints to the PR
15:52:57 <felixfontein> Shrews: it prevents anyone from calling their entrypoint `role_summary` :)
15:53:27 <acozine> heh
15:54:21 <tadeboro> felixfontein: Like having a `"_comment"` keys in JSON you mean?
15:55:03 <felixfontein> tadeboro: yep. that's just a terribly ugly hack that can sooner or later bite you
15:55:29 <acozine> having a special-case entry point would work, but it's not the clearest solution . . . Future Me feels a bit squirrely about it
15:55:34 <felixfontein> tadeboro: I've spent a lot of time in the last 7 years on $job on working around such limitations
15:56:50 <acozine> okay, we've covered the sphinx extension and the role argspec
15:56:59 <acozine> any other updates on our long-running items?
15:57:48 <acozine> long-running items include: collection /docs folder uses, filter/test plugin docs, bitflip process for Ansible release, redirect policy be post 2.10, and the new documentation fields proposal
15:58:14 <acozine> if not, we're already 30 minutes over our stated time
15:58:39 <acozine> well, we're over time whether or not folks have other updates ;-)
15:58:39 <gundalow> No updates from my side
15:58:43 <felixfontein> I have something for a quick open floor
15:58:45 <samccann> collection /docs folder seems to be an item we have to resolve with The Powers That Be as there are conflicting uses/wishes for it
15:58:51 <acozine> samccann: true
15:58:57 <acozine> #topic open floor
15:59:28 <acozine> anyone and everyone is welcome to bring up topics now!
15:59:46 <felixfontein> since we're moving stuff out from community.general and community.network, I'd like some DaWGs feedback on changelog fragments for (a) announcing a new location for content (https://github.com/ansible-collections/community.general/pull/1303) and (b) removing the old content (https://github.com/ansible-collections/community.general/pull/1304)
16:00:18 <felixfontein> I created two WIP PRs for the docker content in community.general, with the intention of them being kind of templates (at least for the changelog fragments) for all the similar PRs that need to be created
16:00:51 <samccann> #info looking for docs feedback on c.g changes - (a) announcing a new location for content (https://github.com/ansible-collections/community.general/pull/1303) and (b) removing the old content (https://github.com/ansible-collections/community.general/pull/1304)
16:01:03 <acozine> ah, yes, "content moved" PRs may be rather common for the next few months/years
16:02:04 <felixfontein> yep. and if we have a good template for the changelog fragments, we avoid repeating the same mistakes every time ;)
16:02:22 <acozine> +1
16:02:27 <tadeboro> Where is the fun in that? ;)
16:02:36 <samccann> heh
16:02:52 <acozine> for creating a template and dropping in <content>, <old_collection>, and <new_collection>
16:03:14 <acozine> tadeboro: this is a new meaning of the word "fun" with which I am not familiar ;)
16:04:58 <acozine> felixfontein: my main comment is that we could rewrite the sections to "speak to the user" - so instead of "users who X should" we say "If you do X, you should"
16:05:33 <acozine> "If you run `ansible-core` and install collections manually, <instructions>."
16:05:58 <acozine> I can turn that thought into suggestions on the PR
16:06:56 <acozine> thanks for pulling this together!
16:07:04 <felixfontein> acozine: sounds like a good idea. I'll rewrite it later.
16:08:40 <acozine> time for weekly reminders
16:09:22 <acozine> #info anyone can add an agenda item for this meeting by putting a comment on https://github.com/ansible/community/issues/521
16:09:51 <samccann> I have on open floor item...
16:09:58 <samccann> one even...sigh.
16:10:03 <acozine> samccann: excellent!
16:10:34 <samccann> if folks could take a look at the hack I did for a set of docs focusing on Ansible the package as a set of collections - http://docs.testing.ansible.com/ansible/devel/
16:11:07 <acozine> ooh, nice!
16:11:15 <lmodemal> +1 acozine
16:11:24 <samccann> it's a total hack so focus more on the left-hand nav and the fact that all the features of Ansible are actually `ansible-core` ... so the proposal would rename most of what we have today on docs.ansible.com/ansible as 'Ansible Core Documentation'
16:11:48 <samccann> y'all can add comments here later as you get a chance to take a look and let me know what you think.
16:12:48 <acozine> this is a nice transition to the second reminder, which is . . .
16:13:14 <acozine> #info we currently have an additional meeting on Thursdays, starting one hour later than the regular DaWGs meeting, to focus on splitting out the `ansible-core` docs from the `Ansible` (package) docs
16:14:39 <acozine> #info the split is necessary because next year we will have two things with version `2.11` - an `ansible` 2.11 package, and an `ansible-core` 2.11 version
16:15:29 <acozine> anything else for open floor?
16:15:59 <acozine> going once . . .
16:16:05 <acozine> going twice . . .
16:16:54 <acozine> all right, thanks everybody!
16:17:04 <felixfontein> thanks everyone!
16:17:08 <acozine> #endmeeting