#ansible-docs: Documentation Working group aka DaWGs Supplemental meeting
Meeting started by samccann at 15:30:35 UTC
(full logs).
Meeting summary
- opening chatter (samccann, 15:30:44)
- Creating a separate Ansible Collections Documentation site (samccann, 15:35:11)
- the current proposal -
https://hackmd.io/TQmzyhCUSSKa22iFR_079A?both (samccann,
15:36:12)
- a hack of what this might look like -
http://docs.testing.ansible.com/ansible/devel/ (samccann,
15:36:27)
- TL;DR; of the idea is to create a separate
'Ansible Collections Documentation' and move all scenario etc guides
over there, plus the collection index. And leave all the 'what is
ansible, how to use ansible, etc on the existing site and call it
Ansible Core Documentation (samccann,
15:36:59)
- this is in 'interim' solution as there is more
work/discussions on creating an improved docs.ansible.com overall.
But that is too far out to solve our immediate problem (samccann,
15:39:52)
- if we split the docs - core vs Collections - we
also impact search. Today it would be two independent
searches (samccann,
15:59:38)
- ACTION: samccann
acozine - review old old DaWGs meeting minutes and other docs that
described decisions when we created the docs pipeline but decided
NOT to create a /collections/ url on the docsite (samccann,
16:03:43)
- we have to decide if we duplicate
ansible.builtin to Ansible Collections and rebuild for every
ansible-base release, how do we handl the folks who upgrade only
based on Ansible releases? They won't get the updated ansible-base
until the next Ansible release, but the docs will already be on that
future ansible-base release (samccann,
16:14:16)
- ACTION: - open a docs
PR to explain how to determine ansible-base version vs Ansible
package version...`ansible --version` is base, `pip show ansible` is
Ansible version (samccann,
16:23:23)
- https://github.com/ansible/community/issues/560#issuecomment-700723990
https://meetbot.fedoraproject.org/ansible-meeting/2020-09-29/ansbile_core_irc_public_meeting.2020-09-29-18.58.log.html
(felixfontein,
16:24:14)
- could use pip show for both ansible-core and
Ansible but doesn't solve the problem for those who don't install
w/ pip (samccann,
16:25:02)
- could say ' pip ... or use the package manager
from your OS' (samccann,
16:26:22)
- how to we handle google search when we
duplicate docs such as installing and using collections vs
cannonical url (samccann,
16:36:54)
- ACTION: samccann to
create pro/con list for the different way forward and/or an outline
of which content goes where (samccann,
16:55:54)
Meeting ended at 16:57:54 UTC
(full logs).
Action items
- samccann acozine - review old old DaWGs meeting minutes and other docs that described decisions when we created the docs pipeline but decided NOT to create a /collections/ url on the docsite
- - open a docs PR to explain how to determine ansible-base version vs Ansible package version...`ansible --version` is base, `pip show ansible` is Ansible version
- samccann to create pro/con list for the different way forward and/or an outline of which content goes where
Action items, by person
- acozine
- samccann acozine - review old old DaWGs meeting minutes and other docs that described decisions when we created the docs pipeline but decided NOT to create a /collections/ url on the docsite
- samccann
- samccann acozine - review old old DaWGs meeting minutes and other docs that described decisions when we created the docs pipeline but decided NOT to create a /collections/ url on the docsite
- samccann to create pro/con list for the different way forward and/or an outline of which content goes where
People present (lines said)
- samccann (116)
- abadger1999 (75)
- acozine (61)
- bcoca (16)
- felixfontein (14)
- zodbot (10)
- cybette (3)
- dericcrago (3)
- andersson007_ (2)
- lmodemal (2)
- gundalow (1)
- dmsimard (0)
Generated by MeetBot 0.1.4.