#ansible-docs: DaWGs Mini Docs PR Review Day

Meeting started by acozine at 14:01:09 UTC (full logs).

Meeting summary

  1. goals and ground rules (acozine, 14:01:30)
    1. our goal today is to review (and merge if possible) as many docs PRs as possible (acozine, 14:01:51)
    2. ground rules: all are welcome (acozine, 14:02:33)
    3. if you want to be a "chair" of the meeting, just wave like this `o/` or say hi (acozine, 14:03:08)
    4. we follow the Ansible Code of Conduct: https://docs.ansible.com/ansible/latest/community/code_of_conduct.html (acozine, 14:04:58)
    5. PRs from the ansible/ansible repo are welcome, so are PRs from collections repos (acozine, 14:06:54)
    6. https://github.com/ansible/community-docs/pull/5 (samccann, 14:08:39)

  2. https://github.com/ansible/community-docs/pull/5/files (acozine, 14:26:04)
  3. https://github.com/ansible/ansible/pull/74334 (acozine, 14:33:29)
  4. https://github.com/ansible/ansible/pull/74254 (acozine, 14:36:25)
  5. https://github.com/ansible/ansible/pull/74330 (acozine, 14:40:11)
  6. https://github.com/ansible/ansible/pull/74288 (acozine, 14:48:23)
  7. https://github.com/ansible/ansible/pull/73211 (acozine, 14:54:59)
    1. https://github.com/ansible/ansible/blob/a077bca5d5866603cdc4a2a13aef8f416860aacb/lib/ansible/module_utils/_text.py (schurzi, 14:57:45)

  8. https://github.com/ansible/ansible/pull/73984/files (acozine, 15:07:44)
    1. this is the usual start time (well, I'm a bit late) for the Docs Working Group aka DaWGs meeting (acozine, 15:09:29)
    2. today we are doing a Mini Docs PR Review Day (acozine, 15:09:45)

  9. https://github.com/ansible/ansible/pull/74268 (acozine, 15:12:17)
  10. https://github.com/ansible/ansible/pull/74242/files (acozine, 15:32:56)
    1. https://jinja.palletsprojects.com/en/2.11.x/templates/#random (acozine, 15:40:57)
    2. https://github.com/ansible/ansible/blob/devel/lib/ansible/plugins/filter/core.py#L36 (acozine, 15:41:23)
    3. https://github.com/ansible/ansible/blob/devel/lib/ansible/plugins/filter/core.py#L36 (samccann, 15:41:25)
    4. https://docs.python.org/3/library/random.html#random.Random (samccann, 15:56:10)

  11. 10-minute break (acozine, 16:01:34)
  12. second half of the first-ever Mini Docs PR Review Day (acozine, 16:14:02)
  13. https://github.com/ansible/ansible/pull/74201/files (acozine, 16:14:40)
    1. https://github.com/ansible/ansible/pull/74201/files#diff-fdb133ce38964cecbfb4a1ec6fa0d8420eb4dbe627e57f361eab1be9f0cddfb5R125 (acozine, 16:16:13)
    2. ACTION: samccann to take over https://github.com/ansible/ansible/pull/74201 and update makefiles etc so htmlsingle and making docs w one module works again (samccann, 16:26:46)

  14. https://github.com/ansible/ansible/pull/74161 (acozine, 16:29:15)
  15. https://github.com/ansible/ansible/pull/74158/files (acozine, 16:31:21)
  16. https://github.com/ansible/ansible/pull/74129/files (acozine, 16:45:40)
  17. https://github.com/ansible/ansible/pull/74105/files (acozine, 16:52:32)
    1. https://github.com/ansible/ansible/pull/74348 looks like a good addition (acozine, 17:12:30)

  18. https://github.com/ansible/ansible/pull/74088 (samccann, 17:13:00)
  19. https://github.com/ansible/ansible/pull/74076 (acozine, 17:15:50)
  20. https://github.com/ansible/ansible/pull/74087 (acozine, 17:19:00)
  21. https://github.com/ansible/ansible/pull/74088 (acozine, 17:23:21)
    1. https://github.com/ansible-collections/community.network/pull/111 is not part of a release yet. (tadeboro, 17:28:42)
    2. https://github.com/ansible-community/ansible-build-data/blob/main/4/ansible-4.build#L40 (samccann, 17:32:18)

  22. https://github.com/ansible/ansible/pull/73716/files (acozine, 17:34:59)
    1. https://docs.ansible.com/ansible/latest/reference_appendices/config.html#default-allow-unsafe-lookups is the "modern" alternative with the same info. (tadeboro, 17:38:56)
    2. https://github.com/ansible/ansible/pull/73273/files looks like an easy one. (tadeboro, 17:56:18)

  23. https://github.com/ansible/ansible/pull/73273/files (samccann, 17:56:56)
    1. https://github.com/ansible/ansible/pull/73273#pullrequestreview-640276535 (acozine, 18:00:51)
    2. 11 PRs merged, 1 closed, 7 reviewed/requested changes (samccann, 18:06:22)


Meeting ended at 18:07:57 UTC (full logs).

Action items

  1. samccann to take over https://github.com/ansible/ansible/pull/74201 and update makefiles etc so htmlsingle and making docs w one module works again


Action items, by person

  1. samccann
    1. samccann to take over https://github.com/ansible/ansible/pull/74201 and update makefiles etc so htmlsingle and making docs w one module works again


People present (lines said)

  1. acozine (279)
  2. samccann (163)
  3. tadeboro (43)
  4. sdoran (16)
  5. abadger1999 (15)
  6. zodbot (14)
  7. schurzi (8)
  8. baptistemm (7)
  9. bcoca (5)
  10. Shrews (4)
  11. lmodemal (1)


Generated by MeetBot 0.1.4.