#ansible-docs: Documentation Working Group aka DaWGS

Meeting started by acozine at 15:01:57 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:02:02)
  2. moving docker scenario guide (acozine, 15:06:19)
    1. https://github.com/ansible/ansible/pull/74736 (acozine, 15:06:21)
    2. docker PR to remove old scenario guide and put in a stub https://github.com/ansible/ansible/pull/74736/files (samccann, 15:11:49)
    3. depends on this devel PR to work on devel - https://github.com/ansible/ansible/pull/74987 (samccann, 15:12:39)

  3. updating collection version list for devel docs (acozine, 15:16:47)
    1. https://github.com/ansible/ansible/pull/74987/files (acozine, 15:16:50)
    2. https://github.com/ansible/ansible/pull/74987/files (samccann, 15:17:13)
    3. the workaround will ensure the collections section of the devel docs will be identical to the collections section of latest docs for now. Until we have real 'devel' collections docs (samccann, 15:21:33)
    4. https://github.com/ansible-community/antsibull/pull/282 (acozine, 15:26:29)
    5. https://github.com/ansible/ansible/pull/74988 (acozine, 15:26:38)
    6. reviews welcome on https://github.com/ansible-community/antsibull/pull/282 and https://github.com/ansible/ansible/pull/74988 (samccann, 15:28:38)
    7. related issue is https://github.com/ansible-community/antsibull/issues/54 (samccann, 15:29:12)
    8. reviews welcome on https://github.com/ansible/ansible/pull/74914 (samccann, 15:37:20)
    9. reviews also welcome on https://github.com/ansible/ansible/pull/74963 btw which adds documentation capabilities for filter and test docs (samccann, 15:38:27)
    10. the two PRs above expand the range of the generated technical docs (by extending config documentation and documenting filter and test plugins) (acozine, 15:39:34)

  4. semantic markup (acozine, 15:41:31)
    1. just fyi - devel docs get approx 4% of the traffic vs /latest/ docs and /ansible-core/ gets approx 1% (samccann, 15:43:39)
    2. https://github.com/ansible/ansible/pull/74937 (acozine, 15:44:17)
    3. https://github.com/ansible-community/antsibull/pull/281 (acozine, 15:44:34)
    4. https://github.com/ansible-collections/community.dns/pull/23 (acozine, 15:44:48)
    5. https://github.com/ansible/ansible/pull/73137 (acozine, 15:44:59)
    6. related PRs https://github.com/ansible/ansible/pull/74937 https://github.com/ansible-community/antsibull/pull/281 https://github.com/ansible-collections/community.dns/pull/23 (samccann, 15:45:44)
    7. key=value pair rendering - IBM style guide suggests monospace (samccann, 15:48:17)
    8. - older discussions on this topic https://github.com/ansible/community/issues/521#issuecomment-739263018 and https://meetbot.fedoraproject.org/ansible-docs/2020-12-15/dawgs_aka_docs_working_group.2020-12-15-16.01.log.html (search for value) (samccann, 15:55:14)
    9. ACTION: - review these rendering options to vote next week: (samccann, 15:59:44)
    10. 1. I(option=value) https://dmsimard.com/files/docsite/1/collections/ansible/builtin/lineinfile_module.html (samccann, 15:59:50)
    11. 2. C(option=value) https://dmsimard.com/files/docsite/2/collections/ansible/builtin/lineinfile_module.html (samccann, 16:00:08)
    12. 3. I(option)=C(value) https://dmsimard.com/files/docsite/3/collections/ansible/builtin/lineinfile_module.html (samccann, 16:00:21)
    13. 4. I(option=)C(value) https://dmsimard.com/files/docsite/4/collections/ansible/builtin/lineinfile_module.html (acozine, 16:01:21)
    14. 5. B(option)=C(value) https://dmsimard.com/files/docsite/5/collections/ansible/builtin/lineinfile_module.html (acozine, 16:01:38)

  5. open floor (acozine, 16:01:47)


Meeting ended at 16:04:50 UTC (full logs).

Action items

  1. - review these rendering options to vote next week:


People present (lines said)

  1. acozine (124)
  2. felixfontein (48)
  3. samccann (46)
  4. zodbot (16)
  5. bcoca (8)
  6. lmodemal (3)
  7. Xaroth (2)
  8. briantist (2)
  9. gundalow (1)
  10. dericcrago (1)


Generated by MeetBot 0.1.4.