#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 15:01:01 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:01:07)
  2. semantic markup (acozine, 15:11:04)
    1. summary issue: https://github.com/ansible/ansible/issues/75054 (acozine, 15:12:19)
    2. https://github.com/ansible/ansible/pull/73137 (felixfontein, 15:17:34)
    3. the proposed semantic markup is O(k) for option names, O(k=v) for option key/values, V(v) for option values, E(env) for env variables, and P(community.general.foo#lookup) for plugin references (samccann, 15:19:31)
    4. ACTION: acozine to followup with core, navigator? and galaxy on the proposed new markup options (samccann, 15:24:34)
    5. correction to the vote above: semantic markup macros: O(k) for option names, O(k=v) for option key/values, V(v) for option values, E(env) for env variables, and P(FQCN#plugintype) for plugin references; existing markup macros will remain (acozine, 15:31:31)
    6. AGREED: semantic markup macros: O(k) for option names, O(k=v) for option key/values, V(v) for option values, E(env) for env variables, and P(FQCN#plugintype) for plugin references; existing markup macros will remain (samccann, 15:34:18)
    7. IBM style guide says parameter names are 'bold monospace' and values are 'monospace' but key-value pairs are monospace only. (samccann, 15:44:11)
    8. AGREED: follow IBM style guide as much as we can with RST for these semantic markup options (samccann, 16:04:50)

  3. open floor (acozine, 16:05:17)
    1. rendering bold mono might require a custom RST role, which can be achieved by a Sphinx extension (which the antsibull sphinx extension happens to be) (felixfontein, 16:06:36)
    2. ACTION: review and merge backport of ansible sphinx theme to 2.11 https://github.com/ansible/ansible/pull/75058 (samccann, 16:08:36)
    3. ACTION: abadger1999 to review and (hopefully) merge antsibull PRs 284, 283, 285, and then 282 today. (abadger1999, 16:16:53)
    4. ACTION: with a new version of antsibull (potentially today?), getting https://github.com/ansible/ansible/pull/75059 (with == 0.7.0 and not >= 0.7.0) merged would be good, as well as getting https://github.com/ansible/ansible/pull/74956 merged (probably first, so it doesn't collect more potential conflicts) (samccann, 16:18:19)


Meeting ended at 16:20:05 UTC (full logs).

Action items

  1. acozine to followup with core, navigator? and galaxy on the proposed new markup options
  2. review and merge backport of ansible sphinx theme to 2.11 https://github.com/ansible/ansible/pull/75058
  3. abadger1999 to review and (hopefully) merge antsibull PRs 284, 283, 285, and then 282 today.
  4. with a new version of antsibull (potentially today?), getting https://github.com/ansible/ansible/pull/75059 (with == 0.7.0 and not >= 0.7.0) merged would be good, as well as getting https://github.com/ansible/ansible/pull/74956 merged (probably first, so it doesn't collect more potential conflicts)


Action items, by person

  1. abadger1999
    1. abadger1999 to review and (hopefully) merge antsibull PRs 284, 283, 285, and then 282 today.
  2. acozine
    1. acozine to followup with core, navigator? and galaxy on the proposed new markup options
  3. UNASSIGNED
    1. review and merge backport of ansible sphinx theme to 2.11 https://github.com/ansible/ansible/pull/75058
    2. with a new version of antsibull (potentially today?), getting https://github.com/ansible/ansible/pull/75059 (with == 0.7.0 and not >= 0.7.0) merged would be good, as well as getting https://github.com/ansible/ansible/pull/74956 merged (probably first, so it doesn't collect more potential conflicts)


People present (lines said)

  1. acozine (111)
  2. felixfontein (75)
  3. samccann (65)
  4. abadger1999 (23)
  5. tadeboro (20)
  6. briantist (14)
  7. zodbot (11)
  8. lmodemal (7)


Generated by MeetBot 0.1.4.