15:00:45 <acozine> #startmeeting Docs Working Group aka DaWGs
15:00:45 <zodbot> Meeting started Tue Jul 20 15:00:45 2021 UTC.
15:00:45 <zodbot> This meeting is logged and archived in a public location.
15:00:45 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:45 <zodbot> The meeting name has been set to 'docs_working_group_aka_dawgs'
15:00:50 <acozine> #topic opening chatter
15:00:53 <acozine> who's around?
15:01:05 <lmodemal> DING DING DING! DaWGs (documentation working group meeting) happening now https://github.com/ansible/community/issues/579
15:01:06 <acozine> I see gundalow and felixfontein are both out
15:01:26 <tadeboro> o/
15:01:47 <acozine> abadger1999: dericcrago dmsimard briantist cyberpear Xaroth zbr you folks chatting docs today?
15:01:52 <acozine> #chair lmodemal tadeboro
15:01:52 <zodbot> Current chairs: acozine lmodemal tadeboro
15:02:04 * dericcrago[m] waves
15:02:11 <acozine> #chair dericcrago[m]
15:02:11 <zodbot> Current chairs: acozine dericcrago[m] lmodemal tadeboro
15:02:33 <samccann> o/
15:02:45 <abadger1999> Bom día
15:02:47 <acozine> oohhhhhh, the `username[m]` logins are from matrix?
15:02:56 <acozine> #chair samccann abadger1999
15:02:56 <zodbot> Current chairs: abadger1999 acozine dericcrago[m] lmodemal samccann tadeboro
15:03:21 <briantist> o/
15:03:41 <acozine> #chair briantist
15:03:41 <zodbot> Current chairs: abadger1999 acozine briantist dericcrago[m] lmodemal samccann tadeboro
15:04:16 <acozine> official agenda begins with https://github.com/ansible/community/issues/579#issuecomment-879375768
15:04:47 <acozine> welcome everybody, thanks for taking the time to join the Docs WG today!
15:04:58 <dericcrago[m]> acozine: yes, trying it out
15:05:23 <acozine> what's your Early Adopter Review? Are you liking the experience?
15:06:00 <acozine> dericcrago[m]: ^^^
15:06:29 <dericcrago[m]> in terms of using it for IRC, it's a pretty similar experience as long as you had a persistent client of some sort for IRC that is
15:07:20 <acozine> for anyone curious about Matrix, it's something we're considering / trying out for Ansible community stuff - see https://ansible.github.io/community/posts/matrix_and_ansible.html for more information
15:07:55 <dmsimard> o/
15:08:06 <acozine> dericcrago[m]: cool, it's always good to have continuity when adding new options
15:08:10 <acozine> #chair dmsimard
15:08:10 <zodbot> Current chairs: abadger1999 acozine briantist dericcrago[m] dmsimard lmodemal samccann tadeboro
15:08:19 <gwmngilfen-work> i'm here if there's questions, nothing is decided yet. I have a new post on the topic going up soon ;)
15:08:22 <dericcrago[m]> basically, you get the experience of a bouncer without paying / maintaining one
15:08:31 <dmsimard> btw I have a topic that just came up, will keep it for open floor
15:08:46 <acozine> dmsimard: sounds good, we will be sure to leave plenty of time
15:09:01 <Xaroth> o7
15:09:12 <Xaroth> I'm around, but first I'm grabbing some pizza.
15:09:16 <samccann> Welcome Xaroth!
15:09:17 * Xaroth hungry
15:09:23 <samccann> #chair Xaroth
15:09:23 <zodbot> Current chairs: Xaroth abadger1999 acozine briantist dericcrago[m] dmsimard lmodemal samccann tadeboro
15:09:33 <acozine> mmmm, pizza
15:09:35 <gwmngilfen-work> mmm 🍕
15:09:54 <lmodemal> pizza sounds about right
15:10:20 <acozine> #topic acton item review
15:10:45 <acozine> we did two of last week's action items
15:11:24 <acozine> abadger1999 finalized the flag for building the docs with OR without breadcrumbs, so if we run into memory issues in future, we have a quick workaround
15:11:53 <acozine> samccann integrated that functionality into the current docs build
15:11:57 <acozine> thank you both!
15:12:13 <abadger1999> Thanks samccann !
15:12:15 <samccann> it's not there yet, but I will hopefully do that today. It's just in a test job right now
15:12:38 <samccann> I hit a snag where the existing jenkins logic allowed for a way to wipe out ALL the docs
15:12:45 <samccann> so..erm... had to fix that ;-)
15:12:48 <acozine> heh
15:13:02 <acozine> luckily it only actually wiped out all the docs on the testing site
15:13:09 <lmodemal> Good job abadger1999 samccann
15:14:07 <acozine> oh, I'm looking at older action items
15:14:27 * acozine needs a vacation
15:14:28 <felixfontein> o/
15:14:35 <felixfontein> (partially here)
15:14:36 <acozine> #chair felixfontein
15:14:36 <zodbot> Current chairs: Xaroth abadger1999 acozine briantist dericcrago[m] dmsimard felixfontein lmodemal samccann tadeboro
15:14:45 <acozine> felixfontein: do you want to be furniture, then?
15:15:35 <felixfontein> sure, why not :)
15:15:42 <felixfontein> I'll unchair myself when I go (or try to remember ;) )
15:15:43 <acozine> cool
15:17:01 <acozine> looks like a lot of the action items are on my plate
15:17:07 <acozine> I spent most of the last week on a couple of rewrites, so not a lot of progress
15:17:40 <samccann> important rewrites
15:17:51 <lmodemal> +1
15:17:59 <acozine> heh, thanks
15:18:28 <acozine> #topic redirects on the docsite
15:18:36 <acozine> this is a topic we've had on the agenda for a while
15:18:43 <acozine> but not spent a lot of time and brainpower on
15:18:50 <acozine> Redirect policy for module docs pages in 3.x and beyond. Do we continue updating redirects for moved collections? do we use stub pages, etc? see Script to create docsite redirects ansible-community/antsibull#77 (comment)
15:19:07 <acozine> A little background:
15:19:08 <felixfontein> right now we're using stub pages
15:19:21 <felixfontein> (auto-generated ones by antsibull for meta/runtime.yml redirects)
15:19:59 <acozine> felixfontein: yes
15:20:11 <acozine> do folks think that's the best approach?
15:20:34 <acozine> are redirects for the old URLs still working today?
15:20:43 * acozine goes to check
15:20:44 <felixfontein> I think they do
15:21:14 <felixfontein> right now https://docs.ansible.com/ansible/latest/modules/docker_container_module.html redirets to https://docs.ansible.com/ansible/latest/collections/community/general/docker_container_module.html, which is a stub page which redircets to https://docs.ansible.com/ansible/latest/collections/community/docker/docker_container_module.html
15:21:38 <acozine> if things are working and we all like stub pages for future moves, then maybe this topic is solved and 'can come off the agenda
15:22:13 <felixfontein> I'm happy with stub pages in general
15:22:15 <samccann> +1. It's working, let's keep it
15:22:26 <lmodemal> If it's working, let's keep using it.
15:23:09 <abadger1999> I think the pro for stub pages is that the name has actually changed so it's big hint that people should update their playbooks to use the new name too. The pro for redirects is that the website experience transparently does the right thing.
15:24:05 <acozine> ahh, i see
15:24:17 <abadger1999> (I lean towards staying with stub pages since we have them working but I'm willing to implement redirects if others want that)
15:24:22 <acozine> this module has been in three locations since 2.9
15:24:46 <samccann> yeah I think the stub pages are the correct approach so people know it's moved and know the name changed
15:25:22 <samccann> but should we consider individual redirects as we move scenario guides?
15:25:40 <acozine> it was in core (`/modules/docker_container_module.html`) then in community.general (`/collections/community/general/docker_container_module.html`) and then in community.docker (`/collections/community/docker/docker_container_module.html`) . . . that makes sense
15:26:10 <acozine> though the message on the stub page could be a bit clearer
15:26:34 <acozine> yeah, stub pages seem useful for this
15:26:58 <abadger1999> samccann: Would we need to curate those manually or is a record of where scenario guides have moved going to be kept in ansible-core somewhere?
15:27:13 <samccann> there is no record abadger1999
15:27:15 <acozine> samccann: you're thinking server-side redirects for the scenario guides?
15:27:22 <samccann> yep
15:27:43 <samccann> though if it's lower priority, we could take a chance on the sphinx redirect extension. might be a good test case
15:27:45 * acozine checks what she proposed for the AWS guide move
15:29:00 <acozine> current PR leaves a stub page behind with a note: "The content on this page has moved. Please see the updated :ref:`ansible_collections.amazon.aws.docsite.aws_intro` in the AWS collection."
15:29:20 <acozine> samccann: how does the sphinx redirect extension work?
15:29:48 <abadger1999> samccann: <nod> I think redirects would be nice for the scenario guide but if we can do them in a separate htaccess file, it would be nice to keep the stuff that can be auto-generated separate from the things we need to modify manually.
15:30:31 <samccann> acozine: I'd have to check, but I think it's a file we'd maintain within ansible/ansible instead of the htaccess file on the docsite
15:30:42 <acozine> +1 for keeping manually-maintained and auto-generated redirects separate
15:30:47 <samccann> I didn't try it the last time because it's like version 0.1 or something
15:30:49 <felixfontein> here's how the docker scenario guide stub page looks: https://docs.ansible.com/ansible/devel/scenario_guides/guide_docker.html
15:31:03 <acozine> samccann: that sounds pretty cool, that way the redirects would be visible to the community
15:31:17 <samccann> but web analytics has scenario guides (all of them) at about 4% of our website visitors.
15:31:34 <samccann> so it's low enough that we could experiment and see what folks think. I'm happy to dig in and give it a try
15:31:41 <acozine> felixfontein: nice, I obviously copied the note in my PR from yours
15:31:47 <samccann> :-)
15:31:52 <felixfontein> (I guess I need to create a backport of https://github.com/ansible/ansible/pull/74736 ...)
15:32:25 <felixfontein> acozine: I think you did your PR first and I copied from you, but mine got merged first since the docker guide moved out sooner :)
15:32:25 <abadger1999> cyb-clock: 32 minutes into the meeting
15:32:30 <samccann> hmm. do we want to backport scenario guide moves? or just try to move as many as we can before ansible-5?
15:32:48 <samccann> thanks abadger1999 :-)
15:32:48 <acozine> samccann: I think it's worth trying the sphinx redirects
15:32:56 <felixfontein> samccann: only backport to stable-2.11, because right now it's only on devel
15:33:24 <samccann> #action samcann to try sphinx redirects on test for docker and aws guide moves
15:33:58 <samccann> yeah that was my question felixfontein - I'm not against backports for sure, just wondering if it's a path we want to take or if there are higher priorities etc.
15:34:58 <felixfontein> samccann: I don't think backporting to stable-2.11 blocks another path, so it should be ok :)
15:35:03 <samccann> though I guess we've been saying we can't remove the old guide until the collection is included in a released Ansible package... so we've already held things up until Latest catches up
15:35:19 <acozine> is community.docker included in Ansible 4?
15:35:39 <felixfontein> yes, it was also in Ansible 3 :)
15:35:42 <acozine> ah
15:35:48 <acozine> then bakcporting definitely makes sense
15:35:48 <felixfontein> (I think even in 2.10, though not in 2.10.0)
15:36:33 <acozine> it's the AWS collection that hasn't released a version that includes the guide yet
15:37:02 <felixfontein> ok I have to go, have a great day everyone :)
15:37:04 <felixfontein> #unchair felixfontein
15:37:04 <zodbot> Current chairs: Xaroth abadger1999 acozine briantist dericcrago[m] dmsimard lmodemal samccann tadeboro
15:37:10 <acozine> bye felixfontein!
15:37:23 <abadger1999> bye felixfontein
15:37:34 <lmodemal> bye felixfontein!
15:37:40 <acozine> okay, we have some next steps for redirects
15:37:43 <samccann> #info community.docker is in Ansible 4 and the version with the moved scenario guide is part of latest so a backport of the stub page is good. AWS collection hasn't released a version that includes the guide yet
15:38:06 <acozine> let's try to start talking about one more topic before the open floor
15:38:52 <acozine> #topic adding argspec modifiers to docstrings
15:38:54 <acozine> https://github.com/ansible/ansible/pull/74873
15:39:10 <acozine> and particularly https://github.com/ansible/ansible/pull/74873#issuecomment-880850893
15:39:11 <samccann> #action samccann acozine - find better wording for built-in stub page generation for collections in antsibull
15:39:31 <acozine> samccann: thanks for catching that
15:39:41 <abadger1999> This is a PR from someone on the content team to add mutually_exclusive, required_if, and other pieces of module argument spec to the DOCUMENTATION
15:40:30 <abadger1999> (Oh... required_if probably needs more documentation than the other pieces.... IIRC, it takes an arbitrary function to evaluate whether the requirement is met or not)
15:40:54 <abadger1999> #action abadger1999 to look into whether required_if needs more information.
15:41:17 <samccann> I would add beyond what you had in the comment abadger1999 - that in needs to work with galaxy-ng as well. We're at the point where we can't make independent decisions because so much depends on this DOCUMENTATION block now
15:41:26 <abadger1999> <nod>
15:41:29 <acozine> okay, so this would move things like `mutually exclusive with <other_param>` out of the text description of an option?
15:41:41 <acozine> because we do document things like that in some places
15:43:15 <acozine> I need to read the PR in more detail, clearly
15:43:27 <tadeboro> What we did a while ago is https://github.com/xlab-steampunk/ansible-argspec-gen#writing-module-documentation
15:43:43 <tadeboro> It does not cover all use cases, but it does cover what we needed ;)
15:44:19 <samccann> #link https://github.com/ansible/ansible/pull/74873
15:44:31 <abadger1999> Yeah.... I think that Yeah. right now, when you create an AnsibleModule() object you can pass it parameters like: `mutually_exclusive=('stable', 'devel')`
15:44:33 <samccann> #info and especially https://github.com/ansible/ansible/pull/74873#issuecomment-880850893
15:44:48 <samccann> #info related work happened at https://github.com/xlab-steampunk/ansible-argspec-gen#writing-module-documentation
15:45:09 <abadger1999> And we have to separately document those constraints in the DOCUMENTATION (usually for the options in question)
15:45:16 <tadeboro> But if that data could be stashed into docs in any other way, I am all for it.
15:45:51 <acozine> I'm not informed enough yet to have ideas or even much of an opinion
15:46:00 <abadger1999> This would move the information into the DOCUMENTATION string in a standard set of fields.
15:46:12 <samccann> yeah same here. maybe we need to action that to ourselves acozine to read over the PR etc
15:46:15 <acozine> we've only got 15 minutes left in today's meeting and we know we have at least one topic for open floor
15:46:33 <abadger1999> The content team specifically needs this for suboptions rather than for the toplevel argument spec. But making it apply to the toplevel is one of the changes I requested.
15:46:43 <abadger1999> <nod>
15:46:50 <acozine> I'd propose that everyone with any interest read the links samccann has info'd and we come back next week prepared for an opinionated discussion
15:46:53 <abadger1999> Cool. Just wanted to make sure this was on the docs radar.
15:47:04 <samccann> #info The content team specifically needs this for suboptions rather than for the toplevel argument spec. But making it apply to the toplevel is one of the changes abadger199 requested.
15:47:12 <acozine> thank you abadger1999 for bringing that to the DaWGs!
15:48:03 <acozine> #topic open floor
15:48:04 <samccann> #action all - read the PR https://github.com/ansible/ansible/pull/74873 and associated info shared above for argspec modifiers for modules and be prepared for next week's DaWGs
15:49:02 <acozine> all comments, quesitons, ideas, suggestion now welcome
15:49:14 <acozine> who mentioned having a topic earlier?
15:49:19 <acozine> dmsimard: dericcrago[m] ?
15:49:30 <dmsimard> \o
15:49:39 <acozine> the floor is yours dmsimard
15:49:51 <dmsimard> I prepared a body of text in the best interest of time :)
15:49:54 <abadger1999> (Required_if looks like it can be documented without special casing... it's roughly: required_if([parameter, equals_value, (these, params, must, be, set), any|all], [repeat])
15:50:01 <dmsimard> Fedora needed to patch 2.9 so it could build successfully against sphinx>=4 in rawhide: https://src.fedoraproject.org/rpms/ansible/c/f2669e12902f2fa425bcc49cb0d6a7f6bce7cfce?branch=rawhide
15:50:08 <dmsimard> It turns out that felixfontein had proposed the same fix for the issue: https://github.com/ansible/ansible/pull/74798
15:50:13 <dmsimard> That PR was closed in favor of https://github.com/ansible/ansible/pull/74318/ which "fixes" the issue by removing the file in devel.
15:50:17 <dmsimard> The lexer remains in both stable-2.9 and stable-2.10, though. Should we propose felix's patch to both 2.9 and 2.10 so Fedora can drop their patch ?
15:50:56 <samccann> i'm a little lost - fedora generates ansible docs?
15:51:31 <abadger1999> Yeah, in their rpm, they generate the docs so that users can read them offline
15:51:46 <dmsimard> There is an optional documentation package, yes: https://src.fedoraproject.org/rpms/ansible/blob/rawhide/f/ansible.spec#_129
15:51:53 <samccann> #info fedora generates ansible docs so users can read them offline
15:52:09 <samccann> #info Fedora needed to patch 2.9 so it could build successfully against sphinx>=4 in rawhide: https://src.fedoraproject.org/rpms/ansible/c/f2669e12902f2fa425bcc49cb0d6a7f6bce7cfce?branch=rawhide
15:52:43 <acozine> dmsimard: I think the fix wasn't so much "removing the file in devel" as "moving the file out of ansible/ansible and into the ansible theme"
15:52:57 <samccann> #info the new ansible theme we use on docs.ansible.com doesn't need this, but the lexer reamains in stable.2.9 and stable-2.10
15:53:25 <samccann> #info optional fedora docs package for ansible - https://src.fedoraproject.org/rpms/ansible/blob/rawhide/f/ansible.spec#_129
15:53:43 <dmsimard> acozine: fedora doesn't package >=2.10 (yet) so it hasn't come across that yet
15:53:46 <abadger1999> acozine: the file was removed in the theme (but I'm unclear if it is needed when the lexer is bundled in ansible-core but not needed in the theme or if it's not needed in either place)
15:54:00 <acozine> ah, okay
15:54:16 <samccann> I'm uncomfortable making code changes for a separate distribution, even if it's in older releases
15:54:38 <samccann> it feels like a slippery slope off the top of my head. Could Fedora start using the ansible theme to solve this?
15:55:06 <samccann> tho maybe we do this regularly and I'm just not in the loop
15:55:14 <abadger1999> Note that this would affect anyone who wants to build the docs for 2.9 and 2.10 with the new sphinx
15:55:33 <abadger1999> We know about Fedora but it's not limited to them.
15:55:56 <samccann> yeah so that's the higher level point I want us to decide one
15:56:04 <samccann> s/one/on/g
15:56:16 <abadger1999> Fedora could use the ansible theme but that's an even bigger patch against upstream so... they'd probably want us to make 2.9 and 2.10 use the ansible theme rather than maintaining that themselves.
15:56:17 <samccann> Do we support people building from ansible docs on their own?
15:56:39 <abadger1999> for some value of support, yes.
15:56:59 <dmsimard> for what it's worth, we're talking about a one line fix as per https://github.com/ansible/ansible/pull/74798/files (discounting the seemingly unrelated regex change)
15:56:59 <samccann> huh... so if 2.9 doesn't have the new ansible theme, how is it working but fedora isn't?
15:57:18 <abadger1999> offline docs is a desired thing for some sites (since internet access isn't always allowed)
15:57:26 <samccann> #info this patch could solve the problem if implemented in 2.9 and 2.10 - https://github.com/ansible/ansible/pull/74798/files (wo the regex change probly)
15:57:33 <acozine> if we tried to republish the 2.9 docs, would we run into this problem?
15:57:41 <abadger1999> But the red hat rpm, for instance, no longer ships the built docs.
15:57:43 <dmsimard> acozine: with sphinx4, yes
15:57:55 <samccann> they were republished overnight last night (2.9)
15:58:09 <acozine> so currently they can build the docs with sphinx 3.x?
15:58:16 <samccann> at least our internal jenkins job sez they were.
15:58:27 <dmsimard> acozine: that works for fedora 34 and below, rawhide (soon f35) updates sphinx to 4
15:58:34 <acozine> ah, i see
15:58:53 <tadeboro> If I understand this correctly, only rawhide has the problem because it has Sphinx 4 in repos.
15:59:03 <abadger1999> yep
15:59:16 <acozine> but they want to continue distributing the Ansible 2.9 docs and Ansible 2.9 instead of upgrading to Ansible 4
15:59:30 <samccann> yeah I'm stuck on why we don't have the problem today. I thought jenkins was building to all new sphinx, but I'll action that to myself to see what up
15:59:53 <samccann> #action - samccann to investigate if we hit this problem with 2.9 docs ourselves since 2.9 isn't using sphinx ansible theme?
16:00:35 <acozine> does anyone know why they don't want to use Ansible 4?
16:00:37 <dmsimard> acozine: for context, upgrading to ansible >2.10 is a significant undertaking from a fedora packaging standpoint due to the shift to core and collections
16:00:50 <acozine> true
16:00:54 <dmsimard> i.e, collections could end up being 80+ standalone packages
16:01:07 <acozine> well, they could package the package, couldn't they?
16:01:15 <abadger1999> acozine: manpower. Needing to maintain 75+ new packages for all of the collections in ansible-4
16:01:50 <acozine> ah, so they can't "repackage" the pypi Ansible somehow?
16:01:58 <dmsimard> acozine: somehow unblocking the >=2.10 situation in fedora/centos is on my short term todo list
16:02:00 <acozine> sorry, I don't know much about linux package maintenance
16:02:05 <abadger1999> Yeah... maybe. policy might prevent that (no bundled libraries). But dmsimard or I should talk to nirik at some point about whether there's ways to work around that.
16:02:11 <samccann> cyb-clock-clone sez we are 2 min over
16:02:14 <dmsimard> but if it was easy, it would already be done :p
16:02:19 <acozine> heh, true
16:02:20 <samccann> heh
16:02:22 <tadeboro> Packaging is a PITA since the split. I saw that Gentoo has ansible-base-2.11 ...
16:02:54 <tadeboro> And not, that is not a typo: https://packages.gentoo.org/packages/app-admin/ansible-base
16:03:01 <acozine> sigh
16:03:03 <samccann> sigh
16:03:19 <dmsimard> as in, that should be ansible-core
16:03:21 <dmsimard> naming things is hard
16:03:38 <samccann> ok for the problem at hand - are we able to decide on the PR that would fix this for fedora and possibly other distros? or do we need to do some digging/thinking?
16:04:20 <acozine> if the core maintainers are okay with it, I don't object to a small change to 2.9 to support sphinx 4 for the 2.9 docs
16:04:37 <abadger1999> acozine: +1
16:04:48 <tadeboro> I would say we should try to accomodate Sphinx 4 if the changes are not too invasive.
16:05:07 <samccann> maybe a quick vote to close out the day? :-)
16:05:37 <samccann> VOTE - if core approves, we implement the one line change so other distros can generate docs with Sphinx 4 (in stable-2.9 and stable-2.10)
16:05:42 <abadger1999> +1
16:05:43 <tadeboro> Ansible has a year or two of security fixes?
16:05:44 <tadeboro> +1
16:05:47 <samccann> +1
16:05:52 <acozine> +1
16:05:57 <samccann> #chair
16:05:57 <zodbot> Current chairs: Xaroth abadger1999 acozine briantist dericcrago[m] dmsimard lmodemal samccann tadeboro
16:05:57 <acozine> #chair
16:05:57 <zodbot> Current chairs: Xaroth abadger1999 acozine briantist dericcrago[m] dmsimard lmodemal samccann tadeboro
16:06:01 <acozine> heh
16:06:08 <samccann> heh PING THEM ALL!!!
16:06:14 <dericcrago[m]> +1
16:06:15 <tadeboro> Twice ;)
16:06:17 <lmodemal> +1
16:06:17 <acozine> multiple times!
16:06:24 <dmsimard> +1
16:06:28 <samccann> vote early vote often
16:06:40 <dmsimard> I can even take the action to submit the PRs to 2.9 and 2.10
16:07:03 <samccann> 7 in favor, 2 no response
16:07:16 <samccann> #agreed if core approves, we implement the one line change so other distros can generate docs with Sphinx 4 (in stable-2.9 and stable-2.10)
16:07:28 <acozine> dmsimard: sounds good, thanks
16:07:36 <samccann> #action dmsimard to create PR for 2.9 and 2.10 and test before merging
16:07:40 <acozine> all right, we're over time
16:07:45 <dmsimard> thanks everyone
16:07:53 <samccann> dmsimard let us know if you need us to stage on test once you have the PRs ready
16:08:15 <acozine> please add any other topics to the agenda for next week at https://github.com/ansible/community/issues/579
16:08:37 <acozine> thanks Xaroth abadger1999 briantist dericcrago[m] dmsimard lmodemal samccann tadeboro
16:08:48 <lmodemal> Thanks all!
16:08:48 <acozine> #endmeeting