15:00:37 <ariordan> #startmeeting Documentation Working Group aka DaWGs
15:00:37 <zodbot> Meeting started Tue Oct  5 15:00:37 2021 UTC.
15:00:37 <zodbot> This meeting is logged and archived in a public location.
15:00:37 <zodbot> The chair is ariordan. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:37 <zodbot> The meeting name has been set to 'documentation_working_group_aka_dawgs'
15:00:52 * acozine waves
15:00:55 <gwmngilfen-work> o/
15:01:00 <ariordan> #topic opening chatter
15:01:11 <felixfontein> hi!
15:01:17 <ariordan> #chair acozine
15:01:17 <zodbot> Current chairs: acozine ariordan
15:01:33 <ariordan> #chair Gwmngilfen
15:01:33 <zodbot> Current chairs: Gwmngilfen acozine ariordan
15:01:59 <ariordan> #chair Felix Fontein
15:01:59 <zodbot> Current chairs: Felix Fontein Gwmngilfen acozine ariordan
15:02:12 <ariordan> #chair felixfontein
15:02:12 <zodbot> Current chairs: Felix Fontein Gwmngilfen acozine ariordan felixfontein
15:03:57 <ariordan> Hello everyone!
15:03:57 <acozine> good morning/afternoon/evening!
15:03:57 <tadeboro> Hi all!
15:03:57 <lmodemal[m]> Hello 👋
15:03:57 <ariordan> Shall I chair everyone?
15:03:57 <ariordan> @chair lmodemal
15:03:58 <felixfontein> usually everyone gets chaired who says something (except if they don't want to)
15:04:21 <tadeboro> ariordan: I tend to preffer sofas latelly ;)
15:04:25 <ariordan> I chaired you twice, felixfontein
15:04:28 <acozine> heh
15:04:33 * tadeboro is getting old ;)
15:04:42 <ariordan> #chair tadeboro
15:04:42 <zodbot> Current chairs: Felix Fontein Gwmngilfen acozine ariordan felixfontein tadeboro
15:04:50 <ariordan> -- option: sofa
15:04:53 <acozine> tadeboro: comfort is key!
15:05:15 <acozine> #chair lmodemal
15:05:15 <zodbot> Current chairs: Felix Fontein Gwmngilfen acozine ariordan felixfontein lmodemal tadeboro
15:05:17 <felixfontein> ariordan: you once chaired my matrix account, and once my IRC account - though the matrix account won't work, since it is treated as two different persons
15:05:23 <felixfontein> #unchair Fontein Felix
15:05:23 <zodbot> Current chairs: Gwmngilfen acozine ariordan felixfontein lmodemal tadeboro
15:05:24 <ariordan> #topic agenda
15:05:30 <ariordan> https://github.com/ansible/community/issues/579#issuecomment-924134849
15:05:58 * gwmngilfen-work wonders why zodbot didn't pickup the irc nick for that account
15:06:18 <gwmngilfen-work> i saw a zodbot:fedora.im in the wild last week. who knows when it'll work though :)
15:07:00 <ariordan> I hit tab to complete the nicks.
15:07:25 <gwmngilfen-work> yeah, not your issue, i'm just wondering aloud. i shall stop derailing
15:07:26 <ariordan> samccann can't join us today.
15:08:34 <felixfontein> gwmngilfen-work: it might not like spaces
15:08:35 <ariordan> Gwmngilfen: I wondered quietly, so we're on the same track.
15:09:02 <gwmngilfen-work> afaik that shouldn't matter, but we can discuss/test later if you like :)
15:09:13 <ariordan> #info we are tracking 2.12 docs needs with https://github.com/ansible/ansible/issues/75664
15:09:36 <ariordan> Update on that: We're on track: we have started the backports.
15:11:14 <ariordan> #info Sandra has an open action item: extending rstcheck so we can have expand/collapse capability in the module docs
15:11:54 <felixfontein> looks like we will have Ansible 5.0.0 alpha1 today (at least according to the schedule)
15:12:59 <acozine> w00t!
15:13:36 <lmodemal[m]> Awesome!
15:15:43 <ariordan> # info (Action item review update from Sandra) - The ansible-test split controller docs are TBD and we have to go back to the coder to see where he's at for docs on that.
15:16:27 <ariordan> I'll repeat that, hopefully in normal font size:
15:16:34 <gwmngilfen-work> ooh, markdown fun. hadn't thought of that with respect to zodbot
15:16:36 <acozine> wow, that's a large PR (75605)
15:16:42 <felixfontein> you probably have to remove the space between `#` and `info` as well
15:16:50 <ariordan> # info (Action item review update from Sandra) - The ansible-test split controller docs are TBD and we have to go back to the coder to see where he's at for docs on that.
15:17:11 <gwmngilfen-work> ariordan: that's element interpreting your message as markdown
15:17:16 <felixfontein> acozine: it definitely is! probably the largest change to ansible-test ever
15:17:28 <ariordan> Ah.  I'll try again, sana brio:
15:17:37 <acozine> Gwmngilfen: ah, I wondered why it came through as such a big font
15:17:58 <ariordan> #info (Action item review update from Sandra) - The ansible-test split controller docs are TBD and we have to go back to the coder to see where he's at for docs on that.
15:18:06 <gwmngilfen-work> 1. markdown parsing
15:18:06 <gwmngilfen-work> 2. is usually great :P
15:18:55 <ariordan> Any comments on the action items, before we move onto ongoing work?
15:20:02 <ariordan> #topic Updates on ongoing work
15:20:19 <ariordan> cyb-clock-clone says we are 20 minutes into the meeting
15:20:48 <briantist> o/
15:20:53 <briantist> hey folks
15:21:15 <ariordan> #chair briantist
15:21:15 <zodbot> Current chairs: Gwmngilfen acozine ariordan briantist felixfontein lmodemal tadeboro
15:21:28 <ariordan> Hi briantist
15:21:31 <acozine> hey briantist
15:22:27 <ariordan> #info I created an issue for the update to wording on boilerplate for module docs so it doesn't suggest the user needs to install the collection
15:22:37 <ariordan> https://github.com/ansible-community/antsibull/issues/312
15:22:41 <felixfontein> thanks for the issue!
15:22:48 <lmodemal[m]> I have a hard stop 👋 See everyone next time
15:23:11 <ariordan> Bye, lmodemal
15:23:14 <felixfontein> bye lmodemal[m]! (and hi briantist :) )
15:23:25 <briantist> 👋
15:23:26 <ariordan> #unchair lmodemal
15:23:26 <zodbot> Current chairs: Gwmngilfen acozine ariordan briantist felixfontein tadeboro
15:25:09 <ariordan> So for the boilerplate text, can we just delete the "To install the module, use `ansible-galaxy collection install <collection-name>`" line?
15:25:26 <acozine> Hmmmm
15:25:41 <acozine> All the modules documented on docs.ansible.com/ansible/ are in collections that are included in the ansible PyPI package. However, the shared snippet could be used on other docsites for collections that are not included, in that package, right?
15:25:42 <felixfontein> I wouldn't delete it, since that's useful for people who don't have the collection intsalled
15:25:53 <ariordan> That's what I thought.
15:26:09 <acozine> also, if you are "rolling your own", that info is helpful
15:26:13 <felixfontein> also people who don't have Ansible installed, but ansible-core + some collections, could look at the docsite for a collection they haven't installed yet
15:26:31 <ariordan> Yep. Glad my overthinking wasn't too far wrong.
15:27:51 <acozine> we could say something more complete, like `To see if this module is already installed, type ansible-doc <module_name>. To install it, use: . . .. `
15:28:14 <acozine> but it gets long
15:28:56 <felixfontein> it definitely does
15:29:22 <felixfontein> maybe this would be a good usage for the details extension
15:29:31 <felixfontein> by hiding the long text in a details environment
15:30:38 <ariordan> I'll create a PR to get this started, and we can iterate on it. Does that sound OK?
15:30:52 <felixfontein> +1
15:31:08 <acozine> Sounds great, post the draft here when it's ready for 👀
15:31:29 <ariordan> #action ariordan to create PR for boilerplate text issue https://github.com/ansible-community/antsibull/issues/312
15:31:44 <ariordan> cyb-clock-clone says we are 30 minutes into the meeting
15:32:12 * gwmngilfen-work adds "write a timer bot" to his bots list
15:32:38 <ariordan> Make sure it has a BBC World Service accent :)
15:33:05 <acozine> ooh, would it say "I'm Julian Marshall" in that plummy way?
15:33:33 <gwmngilfen-work> "At the tone, the time will be precisely 16:33 and 10 seconds"
15:33:33 <ariordan> Exactly, Gwmngilfen
15:34:04 <ariordan> #info Ongoing work item: moving collection scenario guides
15:34:10 <gwmngilfen-work> actually i think the precisely was at the end, but anyway, I am distracting you again :)
15:35:02 <ariordan> There's  a PR to move the AWS scenario guide out of the main docs
15:35:06 <ariordan> https://github.com/ansible/ansible/pull/74704
15:35:53 <ariordan> acozine: Are there extra steps remaining here?
15:36:15 <acozine> we were waiting on a new release of the collection
15:36:24 <felixfontein> acozine: it already has been released
15:36:44 <acozine> ah, then the "exit" PR can be merged
15:36:48 <acozine> might need a rebase first
15:36:49 <felixfontein> (if you mean amazon.aws 2.0.0)
15:37:10 <acozine> let me double-check
15:37:29 <acozine> yep, that looks right
15:37:46 <acozine> here's the content going into the collection: https://github.com/ansible-collections/amazon.aws/pull/362
15:38:06 <ariordan> There's a tag in one of the files: `.. should work soon: :ref:`ansible_collections.amazon.aws.docsite.aws_intro``
15:38:28 <felixfontein> and it's included in 2.0.0: https://github.com/ansible-collections/amazon.aws/blob/2.0.0/docs/docsite/rst/guide_aws.rst
15:38:50 <acozine> it does need a rebase
15:39:13 <acozine> I can try to do that today, and open a PR for the changes against amazon.aws
15:39:34 <felixfontein> +1
15:39:57 <ariordan> The `should work soon` text is in rst/scenario_guides/guides.rst
15:40:01 <acozine> ah, yes, ariordan I can get that ref link fixed too
15:40:17 <acozine> it was WIP until the new collection release
15:40:36 <acozine> looks like it's there twice
15:43:16 <ariordan> acozine: Could you ping me in a comment in the PR for the changes against amazon.aws, please? I need to make notes for future migrations.
15:43:42 <acozine> ariordan: will do
15:43:48 <ariordan> Any other updates on ongoing work?
15:44:06 <acozine> it'll just be copying the changes from https://github.com/ansible/ansible/pull/75375 over to the collection
15:44:54 <tremble> ariordan do you need us to wait on you before merging it?
15:45:16 <ariordan> tremble: No need.
15:45:46 <ariordan> cyb-clock-clone says we are 45 minutes into the meeting
15:48:04 * acozine AFK 5 for howling cat
15:48:22 <gwmngilfen-work> that is an excellent excuse
15:48:55 * acozine back
15:49:08 <ariordan> That was quick!
15:49:34 <acozine> I Locked Her IN!!! (with her food, but she was done eating)
15:49:41 <felixfontein> hehe :)
15:49:42 <acozine> as soon as I opened the door, the howling stopped
15:49:52 <gwmngilfen-work> ahhh the in/out game
15:50:01 <felixfontein> cats know how to address their employees
15:50:55 <acozine> felixfontein: yep, I am used to being called "Peon" in cat language
15:52:31 <acozine> any other agenda items to cover? is it time for Open Floor?
15:54:04 <ariordan> #topic Open Floor
15:54:25 <acozine> on Matrix, people's icons drift down from message to message - I assume a move down means the person has read that message . . . it's funny to watch, kind of soothing in a weird way
15:54:43 <gwmngilfen-work> yes. its called the fall-from-the-heavens by some :)
15:54:46 <ariordan> It feels like playing Tetris
15:54:57 <gwmngilfen-work> i particularly like watching it after a room ping ;)
15:55:14 <acozine> alas, Zodbot does not read, it only writes, so the Z never moves
15:55:26 <ariordan> The docs issues that we created for the Contributor Summit Hackathon were all completed.
15:55:30 <ariordan> I merged them yesterday.
15:55:30 <gwmngilfen-work> its just that you cannot get read-reciepts from irc
15:55:44 <gwmngilfen-work> it'll move when it prints something
15:55:47 <acozine> ariordan: that is awesome!
15:56:44 <ariordan> acozine: I created REALLY detailed issues and confined each issue to a single guide, to prevent merge conflicts :)
15:56:55 <acozine> nice planning
15:57:25 <ariordan> I'm creating a few more for Hacktoberfest.
15:58:42 <briantist> a very small open floor docs build update: my build was previously only using changes to `docs/docsite/` for security reasons; we need a privileged GitHub workflow, and can't trust the PR code, and building plugin/module docs does execute some (user supplied) code
15:59:25 <felixfontein> that's unfortunately true
15:59:37 <briantist> so I've set up a GitHub "environment" with approval rules, and now run a second docs build that requires approval (on every push) before it's run. That one uses the full contents of the PR, so it can include docs changes to plugins, doc fragments, modules, etc.
15:59:59 <acozine> nice!
15:59:59 <briantist> The idea is, a person has to review each time before approving that workflow to run
16:00:21 <briantist> but the original build still provides fast feedback for docsite changes at least, even when a maintainer is unavailable
16:00:46 <briantist> there's still work to do, adding that separate workflow required duplicating a lot, but I'll work on DRYing that up later, via composite actions
16:01:34 <acozine> that's a useful workaround - maintaining automated visibility for simple changes, and enabling manual(ish) previews for more complex changes
16:01:52 * felixfontein is now afk... thanks everyone!
16:01:57 <acozine> woops, I have to run too
16:02:13 <acozine> thanks for "driving" ariordan
16:02:21 <acozine> good to see folks!
16:02:23 * acozine waves
16:02:32 <ariordan> I'll end the meeting, unless anyone has another issue to discuss.
16:02:35 <briantist> it does have some quirks.. approvers are set individually, they all get emailed on every push, and github calls it a "deployment" so the verbiage is weird. But it works.
16:02:38 * samccann strolls in at the end
16:02:43 <briantist> nothing else to discuss from me
16:02:48 <samccann> thanks for running it all ariordan !!
16:04:20 <ariordan> Thanks for the update, briantist : sounds really useful!
16:04:36 <ariordan> Bye, everyone!
16:04:41 <ariordan> #endmeeting