#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 15:01:22 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:01:29)
  2. module/plugin attributes (acozine, 15:08:36)
    1. background: started with https://github.com/ansible/ansible/pull/73707 (samccann, 15:10:11)
    2. expanded with https://github.com/ansible/ansible/pull/74331 (samccann, 15:10:23)
    3. felixfontein has a schema PR to help with this but we need to decide how we want to add this info to the module pages too. (samccann, 15:16:50)
    4. Schema PR: https://github.com/ansible-community/antsibull/pull/301 (abadger1999, 15:17:22)
    5. all collections that support ansible-core < 2.12 cannot use the common atrributes docs fragment, so they have to have their own descriptions everywhere, which will result in a large amount of different texts for the same attributes. Not easy to solve this. (samccann, 15:30:27)
    6. if we backport the fragment, then a whole bunch of collections then have to specify very specific versions of 2.9, 2.10, etc that they are compatible with. If we add a tiny collection, then a whole bunch of collections have a new dependency they don't like. (samccann, 15:32:35)
    7. https://www.irccloud.com/pastebin/w5SvVDOx/ (samccann, 15:38:08)
    8. ACTION: samccann add deciding how the attributes should look like in the docs to next week's agenda (samccann, 15:56:41)

  3. open floor (acozine, 15:56:41)


Meeting ended at 16:04:59 UTC (full logs).

Action items

  1. samccann add deciding how the attributes should look like in the docs to next week's agenda


Action items, by person

  1. samccann
    1. samccann add deciding how the attributes should look like in the docs to next week's agenda


People present (lines said)

  1. acozine (66)
  2. samccann (36)
  3. felixfontein (32)
  4. abadger1999 (29)
  5. briantist (11)
  6. zodbot (10)
  7. tadeboro (5)
  8. lmodemal[m] (4)
  9. gundalow (2)
  10. gwmngilfen-work (2)
  11. dericcrago (1)


Generated by MeetBot 0.3.