#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 15:01:12 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:01:18)
    1. IDEA: ... what does the idea hashtag do in the meeting minutes??? (samccann, 15:01:56)

  2. action item review (acozine, 15:05:59)
    1. details on attributes - https://hackmd.io/R71WLQjPQOa-Ze0Cg97V7A and PR - https://github.com/ansible/ansible/pull/75563 (samccann, 15:10:37)
    2. ACTION: samccann to test out https://github.com/ansible/ansible/pull/75563 to see how it looks (samccann, 15:11:05)
    3. expand/collapse on the ansible theme has some suggestions at https://github.com/ansible-community/antsibull/pull/303#issuecomment-905391511 (samccann, 15:11:40)
    4. https://sphinx-design.readthedocs.io/en/furo-theme/dropdowns.html looks pretty nice; https://sphinx-toolbox.readthedocs.io/en/stable/extensions/collapse.html#directive-collapse would need some CSS (felixfontein, 15:11:40)
    5. ACTION: samccann to test out the expand/collapse extensions listed in https://github.com/ansible-community/antsibull/pull/303#issuecomment-905391511 to see how they display (samccann, 15:18:58)
    6. https://github.com/ansible-community/community-topics/issues/39 (felixfontein, 15:20:41)
    7. https://github.com/ansible-community/community-topics/issues/39#issuecomment-906133762 (samccann, 15:20:45)
    8. we were able to update CI to use Sphinx 3.5.4 but Sphinx 4.x generates errors (acozine, 15:26:14)
    9. on Sphinx 4.x we get the `1 validation error for ModuleDocSchema\ndoc -> attributes\n extra fields not permitted ` warnings (acozine, 15:27:05)
    10. https://www.irccloud.com/pastebin/eIT0SdYX/Sphinx%204%20error%20messages (acozine, 15:29:08)
    11. ACTION: acozine to test Sphinx upgrade in CI for the devel branch (acozine, 15:38:43)
    12. ACTION: samccann to discuss docs backport merging with core folks (samccann, 15:50:55)

  3. open floor (acozine, 15:51:21)


Meeting ended at 16:08:31 UTC (full logs).

Action items

  1. samccann to test out https://github.com/ansible/ansible/pull/75563 to see how it looks
  2. samccann to test out the expand/collapse extensions listed in https://github.com/ansible-community/antsibull/pull/303#issuecomment-905391511 to see how they display
  3. acozine to test Sphinx upgrade in CI for the devel branch
  4. samccann to discuss docs backport merging with core folks


Action items, by person

  1. acozine
    1. acozine to test Sphinx upgrade in CI for the devel branch
  2. samccann
    1. samccann to test out https://github.com/ansible/ansible/pull/75563 to see how it looks
    2. samccann to test out the expand/collapse extensions listed in https://github.com/ansible-community/antsibull/pull/303#issuecomment-905391511 to see how they display
    3. samccann to discuss docs backport merging with core folks


People present (lines said)

  1. acozine (108)
  2. samccann (57)
  3. felixfontein (39)
  4. abadger1999 (15)
  5. gwmngilfen-work (13)
  6. zodbot (12)
  7. gundalow (3)
  8. Xaroth (3)
  9. tadeboro (1)
  10. briantist (1)
  11. ariordan (1)


Generated by MeetBot 0.3.