#ansible-docs: Documentation Working Group aka DaWGs
Meeting started by samccann at 15:01:52 UTC
(full logs).
Meeting summary
- opening chatter (samccann, 15:02:14)
- Action Item updates: (samccann, 15:05:34)
- core freeze is Sept 19 (samccann,
15:06:57)
- resolved action item -
https://github.com/ansible/ansible/pull/78668 (samccann,
15:07:09)
- Core Freeze (samccann, 15:08:07)
- items to complete before core freeze:
(samccann,
15:08:59)
- update docs build dependencies (keeping
rstcheck < 6 for now) (samccann,
15:09:13)
- merge of
https://github.com/ansible/ansible/pull/78700 so new filter/test
plugins display correctly (samccann,
15:09:36)
- possible update to antsibull-docs based on
results of #78700 (samccann,
15:09:54)
- would be good to have more filter docs as there
aren't many yet with the new sidecar docs feature in 2.14
(samccann,
15:11:17)
- https://github.com/ansible/ansible/pull/78548
(felixfontein,
15:15:04)
- ACTION: samccann to
clarify w bcoca on whether he is omitting filter docs from
https://github.com/ansible/ansible/pull/78548 in his filter docs
PR (samccann,
15:16:39)
- open action item - Create tracking issue
'somewhere' to track all the collections that SHOULD consider using
true/false boolean in examples (tho some may not want to for
$REASONS) (samccann,
15:17:18)
- https://github.com/ansible/ansible/issues/78760
(bcoca,
15:17:59)
- Documentation updates (samccann, 15:23:13)
- archiving 2.3 docs archive is at
https://docs.ansible.com/archive/ansible/2.3/. Redirects coming soon
for older urls . (samccann,
15:23:19)
- User guide high-level restructure complete -
https://docs.ansible.com/ansible-core/devel/index.html Feedback
welcome (samccann,
15:24:45)
- Reminder on new project tracking board for
Ansible docs- https://github.com/orgs/ansible/projects/94
(samccann,
15:29:24)
- Help on issues always welcome :-) (samccann,
15:29:24)
- - if you need an editor to review docs PRs or
do light editing (edit on github) we have a team of community
writers willing to help. See
https://github.com/orgs/ansible-community/projects/3/views/1?sortedBy%5Bdirection%5D=asc&sortedBy%5BcolumnId%5D=Status
and ping us here if you need access to add your PRs/easyfix issues
to that board. (samccann,
15:29:25)
- doctools (samccann, 15:29:26)
- nightly docs build broken still. (samccann,
15:29:37)
- ACTION: samccann to
discuss requirements update w/ matt due to broken docs build
etc (samccann,
15:34:48)
- ACTION: samccann to
get PR for requirements update ready (samccann,
15:38:22)
- https://galaxy.ansible.com/community/aws
(samccann,
15:46:17)
- Open Floor (samccann, 15:48:26)
- https://github.com/ansible-collections/community.hashi_vault/#collection-documentation
(briantist,
15:49:38)
- ACTION: samccann to
open issues on community.aws, community.windows, and possibly
ansible.windows on using the correct links to module-level
docs (samccann,
15:56:25)
- ACTION: samcann also
review amazon.aws for similar issue (samccann,
15:57:26)
Meeting ended at 16:03:00 UTC
(full logs).
Action items
- samccann to clarify w bcoca on whether he is omitting filter docs from https://github.com/ansible/ansible/pull/78548 in his filter docs PR
- samccann to discuss requirements update w/ matt due to broken docs build etc
- samccann to get PR for requirements update ready
- samccann to open issues on community.aws, community.windows, and possibly ansible.windows on using the correct links to module-level docs
- samcann also review amazon.aws for similar issue
Action items, by person
- bcoca
- samccann to clarify w bcoca on whether he is omitting filter docs from https://github.com/ansible/ansible/pull/78548 in his filter docs PR
- samccann
- samccann to clarify w bcoca on whether he is omitting filter docs from https://github.com/ansible/ansible/pull/78548 in his filter docs PR
- samccann to discuss requirements update w/ matt due to broken docs build etc
- samccann to get PR for requirements update ready
- samccann to open issues on community.aws, community.windows, and possibly ansible.windows on using the correct links to module-level docs
People present (lines said)
- samccann (87)
- felixfontein (25)
- acozine (21)
- briantist (18)
- bcoca (10)
- zodbot (9)
- DonNaro[m] (6)
- tremble (2)
- Don (0)
- Naro (0)
Generated by MeetBot 0.4.