#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by samccann at 15:01:20 UTC (full logs).

Meeting summary

  1. Moving docs out of ansible/ansible (samccann, 15:04:13)
    1. this is part of putting package docs under ansible steering committee/community control. See https://github.com/ansible-community/community-topics/issues/243 (samccann, 15:04:18)
    2. an interim step is to move all docs out to ansible/ansible-documentation. From there, we can iterate faster to get to the point where the community package docs are under community control (likely another repo in ansible-community org) and separate from core docs. (samccann, 15:04:26)
    3. new docs repo is https://github.com/ansible/ansible-documentation (samccann, 15:05:23)
    4. Folks are expressing concerns that we will lose technical contributors to docs in the new repo over time, and the long-term health of the documentation will be impacted by this move (samccann, 15:16:34)
    5. identified risk - the docs lose technical accuracy over time because it's an extra step to remember to open a docs PR in another repo. Identified benefits - aster iteration on antsibull-docs updates, ability to split the core from community docs, and lead toward full community control over the documentation (samccann, 15:32:07)

  2. Getting Started guide revamp (samccann, 15:41:14)
    1. https://github.com/ansible/ansible-documentation/pull/14 (samccann, 15:41:44)
    2. https://github.com/ansible-community/community-team/issues/243#issuecomment-1588912447 (samccann, 15:42:38)
    3. EE content that is being discussed is here - https://github.com/ansible/community-docs/tree/main/execution_environments (samccann, 15:43:00)
    4. https://docs.ansible.com/ansible/latest/getting_started/index.html (samccann, 15:43:39)
    5. https://github.com/ansible/community-docs/tree/main/execution_environments (samccann, 16:00:43)
    6. AGREED: The EE content (overview and getting started) should be its own guide in the Getting started navigation area on docs.asible.com (samccann, 16:12:36)

  3. Open Floor (samccann, 16:12:52)


Meeting ended at 16:13:53 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. samccann (103)
  2. oranod (56)
  3. acozine (26)
  4. zodbot (11)
  5. felixfontein (9)
  6. TVo[m] (2)
  7. gwmngilfen-work (2)
  8. sutapa_bhattacha (1)
  9. TVo (0)
  10. Don (0)
  11. Naro (0)
  12. sutapa_bhattacharjee (0)


Generated by MeetBot 0.4.