#ansible-galaxy: Ansiblefest: Galaxy
Meeting started by abadger1999 at 18:09:14 UTC
(full logs).
Meeting summary
-
- https://etherpad.openstack.org/p/ansible-summit-october-2018-galaxy
(abadger1999,
18:10:36)
- ACTION: jtanner to
publish a link to the gathered statistics (abadger1999,
18:20:13)
- http://tannerjc.net/ansible/galaxy.html
(jtanner,
18:22:43)
- https://galaxy-qa.ansible.com/testing/ansible_testing_content
(alikins,
18:26:32)
- https://github.com/atestuseraccount/ansible-testing-content
(alikins,
18:26:43)
- https://github.com/ansible/mazer/tree/devel/tests/ansible_galaxy/collection_examples/hello
is a 'hello world' example (alikins,
18:27:48)
- https://gist.github.com/alikins/d09e34e68af2b7573b60f917b37846b4
example of the 'built' artifact (alikins,
18:31:52)
- we are not abandoning the traditional role
format (tima,
18:40:46)
- versioning is staying at the repo level;
subcomponents of a collection will not be independently
versioned (defionscode,
18:42:03)
- we will version at the collection level. each
piece of content will *not* have their own individual version
number. (that would be insane) (tima,
18:42:05)
- packaging roles/content via mazer will be able
to have versioned content (abadger1999,
18:44:46)
- migration guide and tool for going from
traditional roles to content collections. (tima,
18:46:26)
- collection == repo (tima,
18:50:50)
- need to scan/check/warn of variables coming
from multiple roles. (tima,
18:58:24)
- Molecule! (abadger1999, 19:20:48)
- https://github.com/ansible/galaxy
(abadger1999,
19:38:39)
- https://github.com/pulp/pulp_ansible/
(bmbouter,
19:40:59)
- on-prem/self-hosted galaxy server will work
with mazer. pulp and static-metadata-over-http may work/be
implemented as well (abadger1999,
19:42:14)
- galaxy web ui update (abadger1999, 19:42:33)
Meeting ended at 19:46:44 UTC
(full logs).
Action items
- jtanner to publish a link to the gathered statistics
Action items, by person
- jtanner
- jtanner to publish a link to the gathered statistics
People present (lines said)
- abadger1999 (43)
- geerlingguy (37)
- bcoca (32)
- defionscode (25)
- zodbot (9)
- bmbouter (7)
- tima (7)
- alikins (7)
- bearrito (5)
- gundalow (2)
- felixfontein (2)
- jtanner (2)
- willthames (1)
- mattclay (1)
- jhawkesworth_ (1)
- retr0h (0)
- gregdek (0)
Generated by MeetBot 0.1.4.