18:11:35 <gregdek> #startmeeting community-working-group
18:11:35 <zodbot> Meeting started Fri Mar 18 18:11:35 2016 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:11:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:11:35 <zodbot> The meeting name has been set to 'community-working-group'
18:11:40 <gregdek> #chat rbergeron
18:11:43 <gregdek> GAH
18:11:46 <gregdek> #chair rbergeron
18:11:46 <zodbot> Current chairs: gregdek rbergeron
18:11:54 <gregdek> (lag is brutal for me right now fyi)
18:12:11 <gregdek> #info Agenda: https://waffle.io/ansible/community
18:12:29 <gregdek> #topic Triage process
18:12:30 <svg> guys, really, I'm in the middle of my aperitif.
18:12:32 <gregdek> #undo
18:12:32 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4fb67c10>
18:12:51 <gregdek> #topic Issue Triage process
18:13:02 <gregdek> svg: I always drink during this meeting. :)
18:13:08 <svg> sounds like a plan
18:13:20 <svg> only this meeting?
18:13:26 <gregdek> https://github.com/ansible/community/issues/36
18:13:32 <gregdek> Most meetings. All IRC meetings.
18:13:36 <rbergeron> waitk you're drinking?
18:13:38 <rbergeron> that's not fair
18:13:50 <svg> hey, it's past 1900 here!
18:13:50 <gregdek> (no i'm not drinking my doc says stop drinking sigh)
18:13:56 <gregdek> ANYWAY
18:14:03 <rbergeron> :)
18:14:03 <gregdek> rbergeron: any update on ^^^?
18:14:05 <svg> Weekens started
18:14:14 <svg> but don't let me hold you
18:14:33 <rbergeron> gregdek: no. and to be fair: i have no updates on anything from wednesday at all, pretty much, because office + travel
18:14:41 <rbergeron> but I did THINK about issue triage process quite a bit so i shoul dhave something soon.
18:14:45 <gregdek> OK!
18:14:47 <rbergeron> and i retrieved my gliffy stuff, which took a while.
18:14:57 <rbergeron> because migrations and accounts and whatever.
18:14:58 <gregdek> thank goodness for that. I was worried that was lost tbh
18:15:49 <rbergeron> yep. it's alive.
18:16:14 <gregdek> shall we set a date to check back on that?
18:16:20 <gregdek> like next wednesday maybe?
18:16:23 <rbergeron> so: next steps are still next stes, no updates.
18:16:24 <rbergeron> Ohhhhhh
18:16:34 <rbergeron> not monday, but praobably wednesday next week, feels good.
18:16:46 <gregdek> kk
18:17:04 <gregdek> #info update on issue triage proposal next wednesday
18:17:08 * gregdek adds to issue
18:17:31 <rbergeron> gregdek: thanks for updating issue, plane bandwidth makes it a little less easy.
18:17:40 <gregdek> yep, no worries
18:17:44 <gregdek> ok next issue:
18:18:12 <gregdek> Oh, well, no progress because meetings and plane and such for rbergeron issues
18:18:18 <rbergeron> man, i think this meeting is going to be my flogging meeting
18:18:22 <rbergeron> because i suck this week :(
18:18:42 <gregdek> Nah, we had other things.
18:18:52 <gregdek> Personal bandwidth is not the time to tick off todo lists.
18:19:10 <gregdek> The big miss this week is new module process. Grr.
18:19:20 * gregdek glares at newtMckerr
18:19:28 <rbergeron> what are we missing right now? a human's name?
18:20:11 <rbergeron> and we kind of also just need a regular irc-meeting-time announced for not-modules but just relating to proposals (might be regular devel meeting time).
18:20:14 <rbergeron> yes?
18:20:22 <rbergeron> i mean as long as we're going to go asking for things :)
18:20:29 <rbergeron> ask for it all at once if it's loosely related?
18:20:32 <gregdek> Yes.
18:20:46 <gregdek> Well, I wanted to secure One Important Thing at a time.
18:21:17 <gregdek> And was promised time/date/person for new module review, which is most important since it's most on fire and blocks on having a core committer available.
18:21:21 <rbergeron> Well,l then secure the module meeting and kind human or set of humans.
18:21:45 * gregdek will ping newtmckerr again, perhaps a bit more pointedly this time
18:22:12 <gregdek> Failing that, I'll just start reviewing new modules myself and putting them into shipit, and let people panic :)
18:22:32 <gregdek> "Whoops I didn't know there was no smart person to guide me!"
18:22:41 <gregdek> I NEED A GROWNUP PLS
18:22:48 <rbergeron> NOT IT
18:22:50 <rbergeron> not me
18:22:57 <rbergeron> i'm not a grown-up
18:22:58 <rbergeron> lol
18:23:04 <gregdek> ok.
18:23:31 <rbergeron> moving on?
18:23:41 <gregdek> Well, those are the opens, and we don't have much more to report, since we mostly spent our week opening issues and not closing them.
18:24:03 <gregdek> If there's something in particular you want to pick, we can. No need to just say "no progress" over and over.
18:25:17 <rbergeron> no progress no progress :)
18:25:27 <rbergeron> I don't have a thing to pick.
18:25:31 <rbergeron> Do you?
18:25:38 <gregdek> Nope.
18:26:20 <gundalow> Morning/afternoon
18:26:31 <gregdek> Hi gundalow!
18:26:49 <gregdek> We're actually running this meeting earlier than normal, since rbergeron is in travel and may not have her otherwise.
18:26:55 <gregdek> #topic open floor
18:27:13 <gregdek> but happy to discuss anything you'd like if you've got something you want to discuss.
18:28:10 <gundalow> gregdek: I noticed, rbergeron happy travels :)
18:28:59 <gundalow> I'm going to be chatting with Matt Davis and bcoca next week (hopefully) about the QE side of things
18:29:15 <gregdek> Excellent. Those are the right folks.
18:29:45 <gundalow> if anyone has any thoughts of where were are, and whsts next I can chew over them till then
18:30:18 <gundalow> Is it Brian that's got the task of moving tests to be along side the code?
18:30:47 <gundalow> Eg,  in Ansible/ansible-modules-core and ansible/ansible-modules-core
18:31:03 <gregdek> It is bcoca, yes.
18:31:08 <gundalow> Copl
18:31:11 <gundalow> Cool
18:31:22 <gregdek> He says there's some untangling to do, so you might ask him some detailed questions about that.
18:31:46 <gundalow> Sure,  will. Do
18:31:49 * rbergeron cheers for testing of anything real soon now
18:32:05 <gregdek> I asked him "can you hand this off and if not why?" And the answer was "probably not and it's complicated," heh. So might pay to get specific with him when you chat.
18:32:19 <rbergeron> or planning or thinking about testing. :)
18:32:39 <gundalow> I've obviously got access to the travis-ci.org via github, is there any details about the Jenkins instance, or anything else you have?
18:33:21 <gregdek> So the current jenkins instance is internal. Runs a lot of tests, all kind of munged up together.
18:33:25 <gregdek> (I believe.)
18:33:57 <rbergeron> gundalow: i think there are a few notes maybe in the notes from the contributor summit if you haven't seen those.
18:34:02 <gregdek> I *think* that phase one for module testing is to identify the things that can be pulled out of that and put into travis.
18:34:13 <gregdek> But again: I'm at the end of a bad game of telephone.
18:34:50 <gregdek> I do know one concern is that certain modules really can't be tested without access to a cloud provider. Can't test digital_ocean modules without using digital_ocean, for instance.
18:35:39 <gregdek> And we have internal tests that we can run there occasionally and manage cost -- but to do actual CI-style testing, we need to figure out how that works, because it woul dbe easy to run up a huge bill quickly.
18:35:52 <gundalow> I've watches the first 2 hours, need to watch the rest
18:36:12 <rbergeron> gregdek: well, we have contacts almost everywhere --
18:36:17 <mordred> gregdek: we can help
18:36:21 <rbergeron> oh hey, the drink cart --- hang on
18:36:38 <rbergeron> sorry, plane must be made bearable
18:36:41 <mordred> gregdek: we might have a giant pile of resources that are really good at doing CI on open source projects :)
18:36:54 <gundalow> cool
18:36:56 <gregdek> mordred: so I hear. ;)
18:37:02 <misc> travis is being slow from time to time, so more ressources would be great
18:37:17 <gundalow> Misc how exactly slow?
18:37:27 <rbergeron> misc: :D
18:37:48 <gundalow> FYI I'm on a train so may disappear for a minute or so. Yay for mosh SSH
18:38:04 <mordred> just got in the air - I do not have a happy drink like rbergeron yet
18:38:27 <gregdek> Wow. Crazy.
18:38:37 <gregdek> I'm the only one even vaguely stationary in this meeting!
18:38:41 <mordred> gregdek: if jeblair and i can manage to stop being in on-site meetings with people for more than a day at a time, I'll write you up a proposal for how I think it can work
18:38:50 <misc> gundalow: well, i was watching some PR waiting 2 to 3h to be scheduled
18:38:58 <gundalow> Misc jesus
18:39:03 <mordred> gregdek: I think there are slightly more details than would make sense to _start_ in IRC
18:39:21 <misc> I understand that travis is free and ressources are not, and maybe I was impatient, and maybe it was temporary
18:39:21 <mordred> but if I write you a long-form thing then we can discuss it here perhaps?
18:39:22 <gundalow> Misc Jesus,  that is slow.
18:39:41 <gregdek> mordred: that would be great.
18:39:55 <gregdek> Submit as an issue here:
18:40:13 <gregdek> https://github.com/ansible/community/issues/
18:40:21 <misc> but that's the difference between "I will look on it tomorow and forget" and "I will do that in a few minutes" :)
18:40:23 <mordred> gregdek: awesome
18:40:35 <gregdek> LOL
18:40:56 <gundalow> Misc exactly, though Travis *should* email you on completion.
18:41:08 <gundalow> Oh,  though not if this was someone's else's PR
18:41:12 <gregdek> When it shows up, it'll automatically go on the agenda for our next meeting (currently 1900 GMT MWF).
18:42:00 <rbergeron> does travis only run on ... travis?
18:42:14 <rbergeron> or can you get faster-travis somehow? :)
18:42:27 <rbergeron> signed, "robyn doesn't always know but loves to learn"
18:42:38 <gregdek> I think you can sign up for Enterprise Travis, actually.
18:42:49 <gundalow> there is a paided version of tracis
18:42:56 <gundalow> what Greg Said :)
18:43:47 <rbergeron> and then total dependence on travis?
18:43:51 <rbergeron> or...
18:43:57 <gregdek> Of course!
18:43:58 <rbergeron> i guess we're there anyway
18:44:01 <gundalow> want to stick an action for me to have a look and to see if there are any stats about how long our jobs are sitting around waiting
18:44:07 <rbergeron> well.
18:44:12 <rbergeron> #addchair gundalow
18:44:30 <rbergeron> wait, did that work? gregdek: am i chaired? :)
18:44:41 <gregdek> #chairs
18:44:41 <gundalow> Hehe
18:44:45 <gregdek> #chair
18:44:45 <zodbot> Current chairs: gregdek rbergeron
18:44:57 <rbergeron> gundalow: i was going to say, action what you want to do :)
18:45:03 <gregdek> #chair gundalow
18:45:03 <zodbot> Current chairs: gregdek gundalow rbergeron
18:45:05 <rbergeron> or greg can do that :)
18:45:09 <rbergeron> freaky.
18:45:09 <gregdek> There's the syntax. :)
18:45:11 <gregdek> Actually:
18:45:16 <rbergeron> ohhhhhh
18:45:20 <gregdek> Why don't we add it as an issue?
18:45:20 <mordred> rbergeron: there is no need to increase the dependency on travis
18:45:47 <mordred> rbergeron: it's a temporarily convenient way to achieve a t hing with a non-free service, and it's the right choice to have used so far
18:45:49 <gregdek> gundalow: remind me of your github id
18:46:15 <mordred> but before anybody goes and increases the ties to the walled garden, I'd love to get the pitch to be able to use open source written up :)
18:46:34 <gregdek> I think we'll be dealing with travis for a while, and there will be some cost to using multiple ci environments, but I think we need to start exploring options, so happy to see mordred's upcoming proposal
18:46:47 <gundalow> gregdek: bob-smith
18:47:12 <mordred> gregdek: yah. proposals with details are easier to talk about than "mordred has an idea none of us are really up on" :)
18:47:26 <gundalow> hum, I should maybe get my names/accounts synced up
18:47:30 <gregdek> And bob's your uncle!
18:47:49 <gundalow> Roberts you mothers brother!
18:48:01 <gregdek> bob-smith has been invited to participate in the ansible-community team, which should give you access to the ansible/community repo.
18:48:18 <gregdek> So you can add an issue and assign it to yourself, and then it'll be on our agenda!
18:48:20 <misc> mordred: travis is free software, iirc
18:48:24 <gundalow> Thank you :)
18:48:28 <gregdek> thank you!
18:49:30 <mordred> misc: it is completely not even close to being free software
18:49:41 <mordred> it is a free service
18:49:43 <mordred> just like github
18:49:46 <mordred> and just like github
18:49:49 <mordred> the software is NOT open source
18:49:54 <misc> mordred: well, so what about https://github.com/travis-ci ?
18:49:59 <gundalow> #action It has been noticed there is sometimes a long delay between PR and Travis starting. Look at the difference between Travis and Travis Enterprise. See if we can get any stats on the queue for core, modules, extra
18:50:07 <gregdek> (also added you mordred)
18:50:29 <gundalow> Should that have created an issue?
18:50:34 <gregdek> Nope.
18:50:38 <gregdek> We don't have that magic yet. :/
18:51:00 <gregdek> You'll have to accept your invite, and then create an issue yourself on github.
18:51:06 <gregdek> Which, meh.
18:51:11 <mordred> misc: oh! maybe I stand corrected and can lower my level of travis hatred :)
18:51:22 <mordred> misc: I will go read more of those repos
18:51:30 <gundalow> Thatvs cool.Just need to know the process
18:51:53 * rbergeron notes that mordred and misc are pretty aligned when it comes to Freedom and Things :)
18:52:13 * rbergeron just isn't sure if she has met anyone running their own travis which makes me feel sketchy
18:52:19 <mordred> well
18:52:23 <misc> yeah, sound like transifex :/
18:52:32 <mordred> yeah. that really screwed us
18:52:39 <mordred> (different us)
18:52:58 <rbergeron> (a bunch of different us's)
18:53:08 <misc> but they push chef cookbooks, so they are trying at least
18:53:27 <gregdek> Sigh. tx.
18:53:48 <gregdek> Love dimitris, but ¯\_(ツ)_/¯
18:53:49 <rbergeron> gregdek: i know it is probably more painful for you :\
18:54:03 <gregdek> ANYWAY.
18:54:05 <rbergeron> old school fedorans
18:54:07 <rbergeron> YES ANYWAY
18:54:21 * rbergeron salutes all the lovely humans who are here about testing and ci and travis and maybe we should make this more of a regular thing
18:54:39 <rbergeron> maybe once we have some notes and proposals and whatever.
18:54:45 <rbergeron> and maybe not on a plane
18:55:41 * rbergeron wonders if she just scared everyone off :)
18:55:42 * misc think rbergeron mean "salud!" instead of salute
18:56:27 <gregdek> Gah, laaaaaag
18:56:29 <rbergeron> misc: some combo of both :)
18:57:14 <gregdek> We can keep talking testing here until we've got critical mass to split off a separate group, I think.
18:57:23 <gregdek> And I think we'll know it when it happens.
18:57:25 <rbergeron> gregdek: *nod*
18:57:38 <rbergeron> gregdek: lol, yep
18:57:48 <gregdek> Anyway.
18:57:52 * rbergeron wonders if anyone else has other topics for open floor?
18:57:52 <gregdek> Anyone with anything else?
18:58:02 <gregdek> Because if not, I've got PR triage to catch up on :)
18:58:10 <misc> when we will have someone write jenkins tasks to run the meeting, then we know that testing people have took over
18:58:24 <gundalow> rbergeronhuge ammount of packet loss here
18:58:41 <rbergeron> misc: who needs jenkins, we haz ansible :)
18:58:48 <gundalow> So nothing else of value I can add
18:59:48 <gundalow> Unless there are any non online,  but not secret bits of documentation that aren't on github that I could read
19:00:07 <gregdek> ok. Calling the meeting then. Thanks for folks who came!
19:00:13 <gregdek> #endmeeting