#ansible-meeting: Ansible Public Core Meeting

Meeting started by abadger1999 at 19:07:12 UTC (full logs).

Meeting summary

  1. smart fact caching https://github.com/ansible/ansible/issues/14456#issuecomment-217920803 (gundalow, 19:09:18)
    1. expiration of facts during play execution is a concern (jtanner|t420, 19:22:13)
    2. expiration behavior is also controlled by the external source and out of ansible's control (jtanner|t420, 19:31:43)
    3. abadger1999 confirmed that expiration check logic changed between 1.9 and 2.x (jtanner|t420, 19:44:47)
    4. https://github.com/ansible/ansible/issues/12722 <= for this ticket (bcoca, 19:46:10)
    5. expiration behavior was a result of fixing https://github.com/ansible/ansible/issues/12722 (jtanner|t420, 19:48:29)
    6. https://gist.github.com/bcoca/cecca870587adb052cb8cc4b2bd51cd8 (bcoca, 19:51:34)
    7. ACTION: bcoca to create intermediate patch for expiration only at gather time and then review other plugins at a later date (jtanner|t420, 19:54:01)
    8. https://github.com/ansible/ansible/issues/14456#issuecomment-217920803 (MichaelBaydoun, 19:54:24)

  2. https://github.com/ansible/ansible/pull/15434 (MichaelBaydoun, 19:55:41)
  3. https://github.com/ansible/ansible/pull/15434 Add port argument for bigsuds (abadger1999, 19:55:49)
    1. ACTION: jtanner merged https://github.com/ansible/ansible/pull/15434 (jtanner|t420, 20:07:14)

  4. open floor (jtanner|t420, 20:08:04)


Meeting ended at 20:11:07 UTC (full logs).

Action items

  1. bcoca to create intermediate patch for expiration only at gather time and then review other plugins at a later date
  2. jtanner merged https://github.com/ansible/ansible/pull/15434


Action items, by person

  1. bcoca
    1. bcoca to create intermediate patch for expiration only at gather time and then review other plugins at a later date


People present (lines said)

  1. bcoca (90)
  2. jtanner|t420 (57)
  3. abadger1999 (47)
  4. MichaelBaydoun (38)
  5. nitzmahone (24)
  6. caphrim007 (21)
  7. zodbot (8)
  8. alikins (6)
  9. gundalow (4)
  10. ryansb (1)


Generated by MeetBot 0.1.4.