19:00:30 <rbergeron> #startmeeting ansible community meeting
19:00:30 <zodbot> Meeting started Wed May 18 19:00:30 2016 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:30 <zodbot> The meeting name has been set to 'ansible_community_meeting'
19:00:48 <rbergeron> #chair gregdek
19:00:48 <zodbot> Current chairs: gregdek rbergeron
19:00:50 <bcoca> we really need to space these appart, Wed == no code touched today
19:01:25 <gregdek> Your attendance is not compulsory to this one. :)
19:01:33 * gundalow waves
19:01:52 <gregdek> This one tends to be more "community housekeeping".
19:01:54 <rbergeron> the good news is: we're doing open floor for this today :)
19:02:19 <rbergeron> because also piles of things to do here as well :)
19:04:45 <gundalow> I have Travis update (Spoilor alert: We often have a crazy huge queue)
19:05:03 * MichaelBaydoun interest is perked
19:05:38 <rbergeron> #topic travis update
19:05:43 <rbergeron> #chair gundalow
19:05:43 <zodbot> Current chairs: gregdek gundalow rbergeron
19:05:49 <rbergeron> take it away! :)
19:05:58 <gundalow> https://github.com/ansible/community/issues/47
19:06:03 <gundalow> See the last comment
19:06:28 <gundalow> erm, no
19:06:32 <gundalow> one moment :P
19:06:52 <gundalow> ah, yes Ididn't refresh
19:06:54 <gundalow> https://github.com/ansible/community/issues/47
19:07:18 <gundalow> https://docs.google.com/spreadsheets/d/1VzUPNN_KseqySj5CFRUjU1okgXQN6he57ZHrOwyQRGc/edit?usp=sharing is a graph of the last 15 days of Travis for Ansible
19:07:26 <gundalow> combined ansible, core & extras
19:07:43 <gundalow> Max: 245 queued builds
19:07:43 <gundalow> Min: 1 queued build
19:07:43 <gundalow> Average: 67.94 queued builds
19:07:43 <gundalow> Mode: 6 queued builds
19:07:44 <gundalow> Median: 44 queued builds
19:08:40 <gundalow> Which is a lot worse than I expected
19:09:10 <gundalow> But does explain why we often see huge delays in testing appearing
19:10:19 <gundalow> For ansible/docsite only changes we should maybe add in [ci skip] so Travis ignores https://docs.travis-ci.com/user/customizing-the-build/#Skipping-a-build
19:10:46 <gundalow> thoughts?
19:11:09 <rbergeron> e thinks
19:11:28 * rbergeron ... that is
19:11:51 <rbergeron> gregdek: any thoughts?
19:12:18 <gundalow> there are a few small things we can do, like putting more dependencies in docker, but doing larger scale stuff requires some actual planning (detect what files are been changed & only run applicable test) an resource allocating to it
19:12:37 <gundalow> and* resource allocating to it
19:12:55 <gregdek> This is the class of problem that we should be able to throw money at.
19:13:19 <gregdek> The fact that it isn't indicates a serious flaw in Travis's business model. :/
19:13:36 <gundalow> Travis will accept money to change the queue size
19:13:52 <gundalow> "I'll let you review the data and please don't hesitate to send back new questions this might have generated. We could then talk about the paid options we can offer you if you decide to go forward with a paid plan.
19:13:56 <gundalow> "
19:14:15 <gregdek> Ahh, missed that bit.
19:14:23 <gundalow> it wasn't in the ticket
19:14:28 <gundalow> so you didn't :)
19:14:29 <gregdek> So I think we should escalate that internally.
19:14:34 <gregdek> Ah, then that's why I missed it, LOL
19:14:38 <gregdek> So.
19:14:54 <gregdek> Maybe we should assign that one to me to "solve the Travis resource problem" and I'll escalate internally?
19:15:18 <gundalow> gregdek: Should I contact them to find out if we were (and make it clear I'm not, nor can I) what paid options would make sense for our use cases
19:15:41 <gregdek> Yes, that would be great. Maybe make an intro to me?
19:15:44 <gundalow> they tried to sell me things before, but I said I need some hard data showing the problem. Which they've now provided
19:16:29 <gundalow> #action gundalow to contact TravisInc again and introdue gregdek and see if we were to go for paid options what would make sense
19:16:32 <gundalow> next?
19:16:34 <gundalow> thanks
19:18:15 <gregdek> Floor still open!
19:18:25 * gregdek is working on a deadline for other stuff right now...
19:19:27 <gundalow> #topic open floor
19:19:44 <gundalow> rbergeron: Anything from your goodself?
19:20:58 <gundalow> or anyone else?
19:21:21 <gundalow> MichaelBaydoun: ?
19:21:55 <gundalow> 10...
19:23:00 <gundalow> 3
19:23:01 <gundalow> 2
19:23:01 <gundalow> 1
19:23:03 <gundalow> 0
19:23:05 <gundalow> #endmeeting