#ansible-meeting: new-modules

Meeting started by gregdek at 18:00:25 UTC (full logs).

Meeting summary

  1. roll call (gregdek, 18:00:37)
    1. https://github.com/ansible/community/issues/96 (gundalow, 18:03:14)
    2. Agenda at https://github.com/ansible/community/issues/96 (gregdek, 18:03:19)

  2. extras/1987 (gregdek, 18:06:56)
    1. https://github.com/ansible/ansible-modules-extras/pull/1987 (gregdek, 18:07:40)

  3. extras/1988 (gregdek, 18:08:15)
  4. extras/2208 (gregdek, 18:11:36)
    1. https://github.com/ansible/ansible-modules-extras/pull/2208 (gregdek, 18:11:39)
    2. AGREED: new modules will adhere to a subset a pep8, as defined and documented in the Makefile. (gregdek, 18:24:36)
    3. ACTION: gundalow will update quidelines / uidelines (gregdek, 18:26:12)
    4. We all agreed 160 chars. (gundalow, 18:27:17)
    5. We all agreed 160 chars. (gundalow, 18:27:39)

  5. Open Floor (gregdek, 18:30:29)
    1. ACTION: abadger1999 to update module tests to check new modules are valid python3 syntax and add an item to module guidelines that modules should be valid python3 syntax. (abadger1999, 18:47:42)


Meeting ended at 19:00:00 UTC (full logs).

Action items

  1. gundalow will update quidelines / uidelines
  2. abadger1999 to update module tests to check new modules are valid python3 syntax and add an item to module guidelines that modules should be valid python3 syntax.


Action items, by person

  1. abadger1999
    1. abadger1999 to update module tests to check new modules are valid python3 syntax and add an item to module guidelines that modules should be valid python3 syntax.
  2. gundalow
    1. gundalow will update quidelines / uidelines


People present (lines said)

  1. gregdek (65)
  2. gundalow (58)
  3. sivel (36)
  4. abadger1999 (35)
  5. bcoca (26)
  6. nitzmahone (10)
  7. ryansb (7)
  8. rbergeron (7)
  9. zodbot (6)
  10. privateip (4)
  11. MichaelBaydoun (4)
  12. dharmabumstead (1)


Generated by MeetBot 0.1.4.