19:00:17 <gregdek> #startmeeting community-working-group
19:00:17 <zodbot> Meeting started Wed Jun  8 19:00:17 2016 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:17 <zodbot> The meeting name has been set to 'community-working-group'
19:00:22 <gregdek> #topic roll call
19:00:30 <gregdek> I know gundalow isn't here this week, he's on vacation
19:00:44 <rbergeron> on a what?
19:00:46 <rbergeron> :)
19:00:53 * rbergeron is here.
19:01:14 <gregdek> A vacation is a thing that people outside of America take.
19:01:20 <rbergeron> interesting
19:01:36 <gregdek> And something that Americans do between employers, if they can afford it.
19:01:38 <gregdek> ANYWAY.
19:01:43 <rbergeron> Hi greg!
19:01:49 <gregdek> :)
19:01:51 <gregdek> ok, agenda
19:01:58 * rbergeron looks for a chair
19:02:00 <gregdek> https://waffle.io/ansible/community
19:02:03 <gregdek> #chair rbergeron
19:02:03 <zodbot> Current chairs: gregdek rbergeron
19:02:07 <alikins> howdy
19:02:27 <rbergeron> #topic agenda: https://waffle.io/ansible/community
19:02:36 <gregdek> #topic Planning for Contributor Conference
19:02:37 <rbergeron> okay. so:
19:02:39 <gregdek> https://waffle.io/ansible/community
19:02:40 <rbergeron> that
19:02:41 <gregdek> GAH
19:02:53 <rbergeron> #link https://github.com/ansible/community/issues/93
19:02:56 <gregdek> https://github.com/ansible/community/issues/93
19:02:57 <gregdek> GAH
19:02:59 <rbergeron> I WIN
19:03:04 <gregdek> anyway!
19:03:46 <gregdek> Need to just publicize that document, I guess.
19:03:50 <rbergeron> I feel like there's gonna be a lot of testing-related things going on. Which is awesome.
19:03:59 <gregdek> Yes, I think that's the right thing.
19:04:36 <rbergeron> So: Do we want to have a little blog post about ... this doc, the event in general, cover a bit of what happened at the last one?
19:04:39 <rbergeron> I guess?
19:04:51 <gregdek> The next question is attendees. We've probably got a limit of 30 or so live, so first come first serve, and we should make sure we get the MUST HAVE folks there, whoever we decide they are.
19:05:11 <gregdek> Fortunately, the remote thing worked really well.
19:05:17 <gregdek> So hoping that will work well again.
19:05:17 <rbergeron> it did.
19:05:54 <rbergeron> I think we probably just want to have some way for the remote people to maybe see the bigger room better (rather than my clunky "let me tilt my spare tablet around" thing)
19:06:05 <rbergeron> but beyond that -- all good.
19:06:08 <gregdek> We can ping Carrie about that.
19:06:24 <rbergeron> Yeah. Well, that's "robyn brings one of her spare laptops" or something, really, i think.
19:06:27 <gregdek> Or we can just bring a better camera.
19:06:31 <gregdek> Right.
19:06:47 <rbergeron> Or that. Whatever. Anyway: so -- we should figure out that list?
19:06:53 <gregdek> Yes.
19:07:16 <gregdek> It'll be open after that, but let's give key folks right of first refusal to be present in person.
19:08:03 <rbergeron> So: I know how we did this last time -- i'm not sure who your list was that you sent the etherpad to offhand, if that's the list or if the list is a little bigger, or what
19:08:45 <gregdek> I'm not sure right this second, but I'll figure it out in the next day or two.
19:09:06 <rbergeron> okay.
19:09:14 <gregdek> gundalow is the big one this time, I think, since he's right in the middle of the testing vortex.
19:09:27 <gregdek> And then various other usual suspects, and then an open call.
19:09:27 <rbergeron> *nod*
19:09:37 <gregdek> Mooooving on!
19:09:51 <rbergeron> okay. We can probably work that out in the next day or two i think if we want to find a slot of time.
19:09:57 <rbergeron> Or you can do it yourself. :D
19:10:02 <rbergeron> Move on!
19:10:38 <gregdek> #topic module maintainer guidelines
19:10:39 <gregdek> https://github.com/ansible/community/issues/81
19:10:47 <gregdek> some progress w00t
19:10:52 <rbergeron> you beat me that time
19:11:09 <rbergeron> indeed, progress, and more things to do.
19:11:35 <gregdek> We need to link in the bot documentation here.
19:11:43 <rbergeron> I can probably do a few of those other things tomorrow, because otherwise things are shot until we meet again next week a little bit because travel
19:11:49 <rbergeron> is there bot documentation?
19:12:01 <rbergeron> Or maybe i should be asking "which bot documentation"
19:12:16 <gregdek> Right. :)
19:12:23 <gregdek> We had a nice list of bot states we wrote up.
19:12:26 <gregdek> Where did we put it?
19:12:40 <gregdek> https://github.com/ansible/community/blob/master/PR-FLOW.md
19:12:42 <gregdek> That's it.
19:12:51 <rbergeron> oh! that. okay
19:12:58 <rbergeron> Yes, we should.
19:13:06 * rbergeron adds this into the issue
19:13:30 <rbergeron> or not
19:13:37 * rbergeron shakes her fist at gregdek
19:13:40 <gregdek> HAHAHA
19:13:42 <rbergeron> you beat me again
19:13:51 <rbergeron> i'm just gonna stop trying and let you do all the pasting
19:13:52 <rbergeron> ;)
19:14:04 <gregdek> Not if... I QUIT FIRST!!!
19:14:19 <gregdek> HAHAHAHA
19:14:26 <rbergeron> anyway.
19:14:35 <rbergeron> moving along
19:14:58 <rbergeron> #action rbergeron to add bot documentation and sort out some of the lingering cleanup for #81
19:15:11 * gregdek remains conspicuously silent
19:15:25 <rbergeron> that was not really conspicuous
19:16:15 <gregdek> GAH
19:16:23 <rbergeron> #topic https://github.com/ansible/community/issues/104 -- Ansible Durham meetup
19:16:35 <rbergeron> #action gregdek to still schedule the Ansible Durham meetup.
19:16:39 <rbergeron> Probably still about containers. :)
19:16:42 <gregdek> Yep. Pinging chouseknecht to see if we can do this early July.
19:16:51 <gregdek> And yes, a dry run on ansible-container is the plan.
19:17:03 <chouseknecht> no
19:17:20 <rbergeron> there's your answer!
19:17:57 <gregdek> Well! We will definitely take that offline, LOL.
19:18:06 <rbergeron> okay!
19:18:31 <rbergeron> #topic https://github.com/ansible/community/issues/42 - Phoenix Ansible Meetup
19:18:52 <rbergeron> So: This was scheduled, and now it is unscheduled until something with a better date is sorted out, because the facility became not-available.
19:19:03 <rbergeron> So. Hooray juggling. I will note this in the issue.
19:19:18 <gregdek> ok.
19:20:01 <rbergeron> #info Still getting a new date for the same location
19:20:04 <rbergeron> sigh.
19:20:30 <rbergeron> Okay, and gundalow isn't here, so... not sure if we want to do the testing working group issue?
19:21:01 <gregdek> Yep, we'll wait on that one.
19:21:53 <gregdek> So that's it for right now.
19:22:32 <rbergeron> okay!
19:22:35 <rbergeron> #topic open floor
19:22:44 * bcoca grabs mop
19:22:56 <rbergeron> #topic open floor at robyn's house
19:23:01 <rbergeron> #undo
19:23:01 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x4312e390>
19:23:03 <rbergeron> :)
19:23:59 <gregdek> We have a bunch of things in backlog.
19:24:08 <gregdek> Should we pick some of them and move them into ready?
19:24:18 <gregdek> No, let me rephrase.
19:24:29 <gregdek> Should we go through the things in Ready and discuss why they're not In Progress?
19:25:07 * rbergeron looks
19:25:14 <rbergeron> oh, yes, i think so
19:26:04 <rbergeron> well: a bunch of them are bot related, it seems
19:26:31 <gregdek> Looks like it.
19:26:32 <gregdek> So.
19:26:42 <gregdek> There are a lot of Bot Improvements that have been stacking up.
19:27:03 <gregdek> So I'm going to go into a hole and make a bunch of them over the next couple of days. That will move a lot of those one way or the other.
19:27:06 <gregdek> Any others?
19:27:42 <rbergeron> Okay -- I moved over one of teh bot ones for myself (add labels in github to diff from issuebot and prbot)
19:28:22 <rbergeron> And I moved over the public metrics, since it's time. And it's probably something that I can get enough info on to have something useful enough to show when we have the contributor summit.
19:28:31 <gregdek> Hey alikins -- any progress on issuebot?
19:28:43 <gregdek> Have you and resmo managed to get anywhere on that?
19:28:48 <rbergeron> And i'm tired of not having public metrics :)
19:28:52 <gregdek> :)
19:30:10 <alikins> gregdek: I looked at it a little Monday, started implementing detection of new labels, but not real far. I'm not sure if any changes will apply if there are refactorings underway
19:31:04 <gregdek> Wonder if it's worth getting into a room and banging on it for a few hours. I was pretty close to something myself, and then resmo said he had something, and then there's your stuff. I kinda think we need to just get something in.
19:31:18 <gregdek> We've got a lot of chicken-and-egg going on there.
19:31:30 <rbergeron> :)
19:31:48 <alikins> in the back of mind, I kind of want to change the rules/logic part to be more of a state machine based on the issue 'events', but thats just conceptual so far...
19:31:53 <rbergeron> poultry is weird like that
19:32:03 <alikins> gregdek: agreed
19:32:48 <alikins> and there is some low hanging generalizations needed if we want to turn it on for ansible/ansible as well
19:33:27 <rbergeron> alikins: yeah, that always has seemed like the optimal way to go. webhooks are nice.
19:33:32 <rbergeron> but at this point... anything at all would be nice
19:33:37 <gregdek> ^^^
19:33:40 <gregdek> ANYTHING
19:33:52 <gregdek> There's also no requirement that this be part of triage.py.
19:33:54 <rbergeron> just having a forced template now is super nice
19:33:59 <gregdek> In many ways, it's a much simpler workflow.
19:34:07 <alikins> I hadn't seen https://github.com/ansible/community/blob/master/PR-FLOW.md  so that wil help clear up some things
19:34:11 <rbergeron> yeah, i figured these would be separate things.
19:34:12 <gregdek> Ah, good.
19:34:15 <rbergeron> prbot vs. issuebot
19:34:46 <gregdek> alikins: in the office tomorrow or fri and have some time to sit down / discuss?
19:35:08 <alikins> gregdek: yeah, I can be in tomorrow
19:35:24 <gregdek> Morning ok? Maybe 10ish?
19:35:36 <alikins> gregdek: that works for me
19:35:41 * alikins closes NOTABUG
19:35:53 <alikins> sorry, habi
19:35:56 <alikins> habit
19:36:08 <gregdek> :)
19:36:10 <gregdek> ok.
19:37:06 <rbergeron> :)
19:37:45 <rbergeron> anything else?
19:38:35 <rbergeron> gregdek: all done?
19:38:48 <gregdek> I think we're done.
19:38:55 <gregdek> I'm gonna go close issues now. :)
19:39:57 <rbergeron> kk :)
19:39:59 <gregdek> Unless anyone else has anything else.
19:40:02 <rbergeron> Nope.
19:40:07 <gregdek> #endmeeting