19:01:38 <gregdek> #startmeeting community-working-group
19:01:38 <zodbot> Meeting started Wed Jul  6 19:01:38 2016 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:38 <zodbot> The meeting name has been set to 'community-working-group'
19:01:44 * rbergeron applauds
19:01:49 <gregdek> #chair rbergeron gundalow
19:01:49 <zodbot> Current chairs: gregdek gundalow rbergeron
19:01:53 * gregdek bows.
19:02:02 * gundalow waves
19:02:08 * rbergeron waves to gundalow
19:02:27 <gregdek> Agenda, as always: https://waffle.io/ansible/community
19:02:40 <gregdek> #topic Planning for Contributor Conference SF
19:02:52 <gregdek> https://github.com/ansible/community/issues/93
19:02:53 <rbergeron> heyyyyo!
19:03:09 <gregdek> So. Any word back from Carrie re: "session is full"?
19:03:44 <rbergeron> looking
19:04:02 <rbergeron> not yet!
19:04:12 <rbergeron> i wonder if we have a link to the spreadsheet where things go, though
19:04:19 <gregdek> ok. that's weird. kinda need to know what's up there.
19:04:31 <gregdek> Assuming we get that sorted, we should probably announce to the world in the next day or two.
19:04:39 <gregdek> And finalize an agenda.
19:04:53 <gregdek> Got time to work out the final agenda tomorrow or Fri?
19:05:08 <rbergeron> i don't seem to have that link.
19:05:27 <rbergeron> yeah, we do. I kind of wonder if the link got forwarded to the core team and they filled it up, since i think there was a loose cap on it.
19:05:34 <rbergeron> which we can revise, but.
19:05:52 <rbergeron> and: yes, probably earlier tomorrow morning would be better, if that works for you?
19:06:01 <gregdek> Yep!
19:06:04 <rbergeron> and maybe we'll have more data from carrie by then, also.
19:06:09 <gregdek> Pick a time and put it on the calendar.
19:06:21 <rbergeron> because i'd love to know who is actually going to be present while making the agenda, to some extent.
19:07:19 <rbergeron> (your entire calendar says "busy" all day tomorrow till 4pm your time. is 10am your time okay?)
19:07:31 <gregdek> Yep.
19:07:54 <gregdek> OK, anything more on that front for now?
19:08:39 <gregdek> Imma guess "no" and we'll move on!
19:08:40 <rbergeron> Nope! Just a bit concerned about the link situation.
19:08:52 <rbergeron> Especially if we're going to advertise things or whatever.
19:09:06 <gregdek> #topic Module Maintainer Guidelines
19:09:08 <gregdek> https://github.com/ansible/community/issues/81
19:09:20 <gregdek> Now it's post-Summit so we can think about these things again!
19:09:25 <gregdek> I have no idea where we left this.
19:09:55 <gregdek> oh, right, alikins proposed some good changes.
19:10:06 <rbergeron> Hey! Well, i was supposed to be working on it, and uh, I guess now i can work on it more with more time and stuff.
19:10:09 <gregdek> Maybe just pull all this together for a review session next week?
19:10:19 <rbergeron> yeah.
19:10:28 <gundalow> right, I'm back
19:10:29 <rbergeron> deadlines plz so i don't slack.
19:10:35 <rbergeron> heh
19:10:55 <rbergeron> or get distracted by shiny objects
19:11:13 <gregdek> By next Wednesday so we can make it the focus of this mtg.
19:11:50 <rbergeron> pressure! okay
19:12:10 <rbergeron> #action rbergero to pull together the module maintainer guidelines for review in this mtg next week
19:12:59 <gregdek> Next!
19:13:37 * gregdek finds the right tab grrr
19:13:50 <gregdek> #topic Public Metrics
19:13:51 <gregdek> https://github.com/ansible/community/issues/81
19:13:59 <gregdek> Doh
19:14:00 <gregdek> https://github.com/ansible/community/issues/38
19:14:44 <rbergeron> Well, i have nothing here but stuff in my head, I guess.
19:14:47 <gregdek> Should we hand this over to newtMcKerr or work with him on it?
19:14:53 <gregdek> Because he's got Teh Big Googlz
19:14:57 <rbergeron> probably work with him on it, to some extent.
19:14:58 <rbergeron> exactly
19:15:26 <newtMcKerr> I’m actually already running some of those.  definitely assign to me
19:15:36 <gregdek> Great! Done!
19:16:18 <gregdek> Maybe we can catch up in the next week or two to figure out what we can expose, and how?
19:17:25 <rbergeron> yes, lol.
19:17:34 <rbergeron> i'll just volunteer him for yes on that.
19:17:35 <rbergeron> :)
19:17:49 <rbergeron> we can help a bit probably with figuring out where to put the info.
19:17:52 <gregdek> Go git 'im.
19:18:05 <newtMcKerr> cool
19:18:17 <rbergeron> newtMcKerr: i will be beeping at you about such things :)
19:18:17 <gregdek> GOT 'EEM
19:18:25 <newtMcKerr> sounds good
19:19:32 <rbergeron> next!
19:19:47 * gregdek looks
19:19:50 * rbergeron hopes it's something for greg to be working on and not something i'm failing to get done
19:19:55 <rbergeron> :D
19:20:07 <gregdek> #topic Add labels for issuebot and prbot to ansible/ansibullbot
19:20:26 <gregdek> But this is really on mine and/or alikins plate at this point.
19:20:31 <rbergeron> I guess we have issuebot now.
19:20:38 <gregdek> Oh wait, no it's not.
19:20:41 <gregdek> Well, we KINDA do.
19:20:48 <rbergeron> well, it was mostly so we could separate issues from one and the other.
19:20:59 <gregdek> Yeah. But issuebot still doesn't exist. DAMMIT.
19:21:01 <rbergeron> so people working on different things could easily see which bot the problems listed were for.
19:21:12 <gregdek> Sigh. Lots of false starts, nothing running.
19:21:14 <rbergeron> well, make a label and and issue saying "issuebot needs to exist" and label it issuebot
19:21:25 <rbergeron> and then we can close this one :) lol
19:21:41 <gregdek> Done!
19:22:12 * rbergeron brings the solutions
19:22:45 <gregdek> We now have an issuebot label.
19:22:56 <gregdek> ISSUE #1 GET ISSUEBOT DONE (sigh(
19:23:13 <rbergeron> z;0
19:23:15 <rbergeron> :)
19:23:25 <gregdek> NEXT!
19:23:31 <gregdek> #topic Testing Working Group
19:23:42 <gregdek> https://github.com/ansible/community/issues/47
19:23:48 * gundalow waves
19:23:50 <gregdek> :)
19:24:00 <rbergeron> this is a thing we plan to chat about at the contributor summit a bit.
19:24:00 <rbergeron> also, gundalow has things and magic
19:24:00 <gundalow> So I'm now part of the team \o/
19:24:01 <gregdek> Well, you're in for it now, sir.
19:24:08 <rbergeron> you were part of the team anyway :)
19:24:14 <gregdek> CONGRATULATIONS!
19:24:18 <gundalow> THANKS!
19:24:27 <gregdek> (And rbergeron is right, of course.)
19:24:40 <gregdek> But now you can spend all your time on this stuff, instead of just most of it!
19:24:41 <gregdek> So.
19:25:13 <gregdek> It's probably time to figure out what the remit of this Working Group is. Maybe a proposal to discuss at AnsibleFest for what the scope is?
19:25:59 <gundalow> So, I was chatting with newtMcKerr about this earlier. We need to agree what we want to get out of it. I've just had 90minute chat with Matt Clay about where he's upto. I think the next thing is a very short video call between a few of us to work out the remit
19:26:11 <rbergeron> maybe.. though i would argue that could / should be a fairly light proposal / scope.
19:26:15 <gundalow> My priority is Network for privateip
19:26:22 <gregdek> I mean, it can be pretty loose to start... "people who care about testing and want to do things" at first. Just a place to plant the flag even.
19:26:31 <rbergeron> since... having a group would be nice, and hopefully those who might want to be part of the group might have ideas. :)
19:26:44 <gundalow> Both of those points are good points
19:27:06 <rbergeron> a wise man once told me
19:27:08 <rbergeron> "just start doing stuff"
19:27:11 <gregdek> And yes, $DAYJOB for privateip clearly takes precedence, no argument there.
19:27:16 <rbergeron> (and make it visible)
19:27:34 <gundalow> I'm here till Tuesday 12th July, then I'm traveling and I'll see you in SanFran. I plan on getting there on the Monday
19:28:49 <gundalow> I'd like to get some thoughts together *before* the Community Summit, so we make best use of that time. Also to avoid the "erm, yes, stuff, we should, erm do stuff"
19:29:42 <rbergeron> aye.
19:30:01 <rbergeron> :)
19:30:09 <rbergeron> ugh, lag
19:30:15 <gundalow> The community has lots of energy, we can do good things together
19:30:16 <gregdek> Oh excellent!
19:30:29 <gregdek> Yes. I think that's right.
19:30:47 <gregdek> Throw stuff at the wall, see if it sticks.
19:30:50 <gundalow> yarp
19:31:34 <rbergeron> progress++
19:31:58 <gundalow> gregdek: Could you poke me tomorrow/Friday when you have a bit of time and we can put together the lightest weight proposal
19:32:01 <gregdek> gundalow: want a deadline or anything?
19:32:05 <gregdek> Ah, lol, timing
19:32:10 <gundalow> :D
19:32:14 <gregdek> Can we do Friday AM eastern US time?
19:32:33 <gregdek> If that works for you, I can send out a calendar invite
19:32:47 <gregdek> rbergeron: want to be along for that or nah?
19:32:49 <gundalow> that works jobarker@redhat.com
19:32:55 <gregdek> okeydoke
19:34:13 <rbergeron> augh, the lag
19:34:16 <rbergeron> sorry
19:34:18 <gregdek> rbergeron: I included you on the invite, if you can make it good, if not no worries
19:34:27 <rbergeron> gregdek: merci
19:35:04 <gregdek> Next:
19:35:16 <gregdek> #topic schedule some #&$(# meetups
19:35:32 <gregdek> rbergeron: you and me need to get these done to get them off the plate.
19:36:26 <rbergeron> yeah, yes. the folks here who were working to host that stuff basically deferred until after summit, so if they're still not ready to do things, then i'll just .. do things without them, i guess.
19:36:34 <rbergeron> they were offering me the lazy way though :) lol
19:37:19 <rbergeron> and we can set other things up.
19:37:52 <gregdek> Anyway. Nothing to talk about there except just doin' stuff.
19:37:53 <rbergeron> maybe we should make a meeting, so we actually, like, figure out what needs doing on this front, without figuring it out right this second. unless it's literally "phoenix and rdu" in which case, we should go do
19:38:06 <rbergeron> and it sounds like that's the case.
19:38:10 <rbergeron> the latter
19:38:10 <gregdek> It's literally Phoenix and RDU, since they're in our backyards.
19:38:16 <gregdek> Yup.
19:38:18 <gregdek> JUST DO
19:38:22 <gregdek> THINGY
19:38:23 <rbergeron> okay. "some" just sounded like it could be "a whole bunch"
19:39:04 <rbergeron> what else are we (me) dreadfully behind on? :D
19:40:03 <gregdek> Nothing that can't wait. We've got backlog, but we should just knock this stuff out first.
19:40:09 <rbergeron> okay!
19:40:30 <gregdek> #topic Open Floor
19:40:33 <gregdek> Anything else?
19:40:35 <gregdek> Anyone?
19:40:38 <gregdek> Bueller?
19:40:42 <gregdek> Anyone?
19:40:51 <rbergeron> nope. ;)
19:40:55 <gundalow> How do we tell people when meetings are canceled
19:41:15 <rbergeron> :D
19:41:55 <gundalow> Also Privateip and I are both away Wed 13th, so no Networking meeting then
19:42:51 <gregdek> Yes. Good point.
19:43:01 <gregdek> The question is, "who's looking for this stuff and where?"
19:43:13 <gregdek> An email to ansible-project is one possibility, but there's a lot of noise.
19:43:25 <gregdek> Wherever it is, we need to tell people to look there.
19:43:35 <gundalow> I've changed the Networking meeting to a standing agenda like the New Modules. So I guess I could just put it on there
19:43:56 <gundalow> and as we have just one agenda people should hopefullysubscribt
19:44:10 <rbergeron> *nod*
19:45:04 <gregdek> Yes, that actually makes a lot of sense.
19:46:53 <dag-> Proposal: Move the AnsibleFest one month so I can come ;-)
19:47:05 <gregdek> #agreed canceling a meeting? Add a comment to the github meeting agenda issue
19:47:08 <rbergeron> dag-: :(
19:47:15 <gundalow> dag-: Come to the London one?
19:47:15 <dag-> It's now right in the middle of the holiday season :-/
19:47:16 <gregdek> dag-: we will be having another one in October in NYC...
19:47:26 <rbergeron> gregdek: aye
19:47:31 <dag-> aha
19:48:03 <dag-> Lets start the negotiations with my significant other...
19:48:03 <gundalow> gregdek: rbergeron I did https://github.com/ansible/community/issues/110 You might want to do the same on the others?
19:48:07 <gregdek> And they're all well wired for remote participation, so you can't weasel out. ;)
19:48:15 <gregdek> Bring your SO to NYC!
19:48:26 <dag-> (and the significant little ones ;-))
19:48:53 <gregdek> That's trickier. :)
19:49:20 <gregdek> gundalow: yes, I will.
19:49:37 <gregdek> OK! Any other items?
19:50:19 <rbergeron> not here.
19:50:31 <gundalow> nah
19:51:04 <gundalow> beer time I think
19:51:18 <rbergeron> ;)
19:52:49 <rbergeron> gregdek: you are welcome to end the meeting now unless you'd like me to :)
19:52:59 <gregdek> #endmeeting