15:32:37 <gregdek> #startmeeting Contributor Conference SF 2016
15:32:37 <zodbot> Meeting started Wed Jul 27 15:32:37 2016 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:32:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:32:37 <zodbot> The meeting name has been set to 'contributor_conference_sf_2016'
15:32:50 <gregdek> #chair rbergeron
15:32:50 <zodbot> Current chairs: gregdek rbergeron
15:32:53 <gregdek> #char gundalow
15:32:56 <gregdek> #chair gundalow
15:32:56 <zodbot> Current chairs: gregdek gundalow rbergeron
15:57:18 <svg> Hi all!
15:57:23 * svg will try to lurk
16:04:34 <svg> ansible meeting ga beginnen
16:04:51 <svg> woopsie
16:22:25 <bcoca> anyone able to connect to BJ?
16:26:25 <gregdek> We've got 10 people on, so I think the answer is yes.
16:30:41 <bcoca> finally in, had to use tablet
16:30:54 <bcoca> greg, can you set your feed as 'principal'?
16:30:57 <bcoca> thanx
16:31:52 <bcoca> i can hear you!
16:32:40 <bcoca> /mute
16:33:50 <gregdek> Today's agenda:
16:33:51 <gregdek> https://public.etherpad-mozilla.org/p/ansible-summit-july-2016-general
16:34:02 <gregdek> #topic General Introductions!
16:34:23 * bcoca waves
16:35:35 * rbergeron waves back
16:35:43 <bcoca> lmao
16:36:10 <bcoca> rbergeron: sadly i  your 'hello' was choppy and i missed the joke
16:36:49 <bcoca> can hear you
16:37:16 <rbergeron> can you hear us now?
16:37:26 <rbergeron> we're trying all this again :)
16:37:27 <rbergeron> woooo
16:37:33 <rbergeron> testing, testing, and stuff.
16:39:08 <bcoca> can hear, but now micheal baydoun is 'main feed', can you force the laptop to be that?
16:39:38 <bcoca> gregdek:  if you make them repeat introductions, you should repeat tower/zuul jokes!
16:41:03 <gregdek> alikins: can you hear us?
16:41:05 * ryansb also in
16:41:08 <gregdek> Can you say hello?
16:47:27 <MichaelBaydoun> bcoca: but maybe I like being main feed
16:47:51 <bcoca> you muted your side
16:48:09 <bcoca> MichaelBaydoun: as long as dog is there, i'm ok with it
16:48:15 <MichaelBaydoun> lol
16:48:34 <MichaelBaydoun> The pink bandana is my wifes idea
16:48:47 <bcoca> idont judge
16:49:03 <rbergeron> woooo
16:49:08 <notmorgan> o/
16:49:57 <bcoca> years?
16:50:14 <rbergeron> bcoca: since the dawn of humanity
16:50:28 <bcoca> since the big bang!
16:51:06 <resmo> hi
16:51:12 <rbergeron> resmo: hai!
16:51:22 <bcoca> /me waves
16:51:43 <bcoca> "recording has started"
16:52:25 <jhawkesworth> Hey
16:52:44 <svg> It's cocktail o'clock here though.
16:53:01 <bcoca> its always cocktail o'clock somewhere
16:53:11 <bcoca> in spain that is every hour on any minute
16:53:33 <jtanner> did he say ##ansible-meeting2 ?
16:53:38 <bcoca> yes
16:53:39 <abadger1999> jtanner: correct
16:53:44 <bcoca> in there already
16:53:49 <resmo> hey svg!
16:54:03 <vincent_vdk> hi resmo
16:54:11 <resmo> hey vincent_vdk
16:54:31 <svg> Hi resmo!
16:54:40 <svg> hi vincent_vdk
16:54:47 <abadger1999> jtanner: okay -- I was wrong -- ##ansible-meeting-2
16:54:52 <vincent_vdk> svg: you again...
16:55:06 <svg> hey, vincent_vdk I invited you here
16:55:21 <vincent_vdk> svg: _o_
16:55:53 <rbergeron> i hope that's a highly available web page1
16:56:07 <svg> It 404'd me
16:56:34 <rbergeron> i think it's not actually up yet.
16:56:39 <bcoca> loosing audio
16:56:47 <jhawkesworth> Losing audio here too
16:56:58 <bcoca> only thing i heard is 'tower is opensource'
16:57:08 <bcoca> ^ joking, but it did sound like that
16:57:16 <svg> bcoca you troll
16:57:43 <bcoca> i know what he was going to say, but the audio was 'tower .... open ... source ... community .. leverage'
16:58:25 <rbergeron> okay! we now have greg un-muted :)
16:58:27 <bcoca> i also hear public?
16:58:34 <bcoca> yep, sound good now
16:58:45 <bcoca> s/hear/heard/
16:58:56 <jimi_|ansible> i think only gundalow's computer was unmuted, so he's a bit far from where greg is standing
17:01:55 <jhawkesworth> back as soon as I can, probably around noon PST
17:04:26 <bcoca> OUCH
17:04:44 <bcoca> local feedback
17:04:47 <bcoca> its NOT US
17:05:28 <ryansb> videoconferencing in 2016: still ridiculously hard
17:07:30 <svg> Is there a reason to the heavy focus and keeping everything on Github?
17:08:06 <rbergeron> svg: will ask in a second
17:08:34 <bcoca> cannot hear question
17:08:38 <bcoca> can toshio repeat?
17:08:46 <nitzmahone> It was svg's question
17:09:07 <bcoca> ah
17:09:15 <bcoca> no irc to speach?
17:09:26 <jimi_|ansible> where was that question? i don't see it here?
17:09:32 <jimi_|ansible> or was it when i reconnected networks
17:09:40 <rbergeron> #info we are github native; one o f the great advantages of github is that the barrier to learning is low
17:09:46 <notmorgan> jimi_|ansible right before you joined the channel
17:09:49 <bcoca> its here
17:09:50 <rbergeron> #info it's the center of gravity (github)
17:10:06 <notmorgan> jimi|ansible: so when you reconnected.
17:10:08 <rbergeron> #info being on github is why we have 2200+ contributors, gregdek suspects
17:10:12 <abadger1999> jimi|ansible: Is there a reason to the heavy focus and keeping everything on Github?
17:10:22 <abadger1999> (that was the question)
17:10:25 <jimi|ansible> k
17:10:25 <rbergeron> #info at some point we may figure out how we deal with gitlab and etc.
17:10:41 <rbergeron> Local question: unclear on how metadata solves the problem
17:11:01 <gundalow> rbergeron: are you chaired?
17:11:10 <jimi|ansible> #chairs
17:11:21 * jimi|ansible does not appear to be
17:11:21 <nitzmahone> #chairs
17:11:24 <rbergeron> #chair jimi|ansible
17:11:24 <zodbot> Current chairs: gregdek gundalow jimi|ansible rbergeron
17:11:42 <jimi|ansible> ty
17:11:45 <rbergeron> #chair abadger1999
17:11:45 <zodbot> Current chairs: abadger1999 gregdek gundalow jimi|ansible rbergeron
17:11:50 <jimi|ansible> #chair nitzmahone
17:11:50 <zodbot> Current chairs: abadger1999 gregdek gundalow jimi|ansible nitzmahone rbergeron
17:11:59 <rbergeron> #chair chouseknecht
17:11:59 <zodbot> Current chairs: abadger1999 chouseknecht gregdek gundalow jimi|ansible nitzmahone rbergeron
17:12:11 <jimi|ansible> #chair bcoca alikins
17:12:11 <zodbot> Current chairs: abadger1999 alikins bcoca chouseknecht gregdek gundalow jimi|ansible nitzmahone rbergeron
17:12:11 <rbergeron> anyone else want chair-ism?
17:12:21 <jimi|ansible> #chair jtanner
17:12:21 <zodbot> Current chairs: abadger1999 alikins bcoca chouseknecht gregdek gundalow jimi|ansible jtanner nitzmahone rbergeron
17:13:08 <MichaelBaydoun> would the bot allow ansible module owners to merge tests for those modules?
17:13:53 <bcoca> no reason it shouldnt
17:14:05 <rbergeron> #info ideally, yes - the way the ansible bot works now... it's primitive but effective
17:14:10 <rbergeron> #info it's a list of file owners.
17:14:20 <rbergeron> #info we'll have to figure out how we deal with new modules.
17:15:01 <jtanner> we will need to add this directory/filenames to the maintainers list ... they're currently only specifying the module file. Easy fix though
17:15:22 <jtanner> integration/roles/test_<module> directory ^
17:16:50 <bcoca> also unit/test/<module>/
17:17:17 <jtanner> yeah, that too
17:17:50 <jtanner> we could probably make the keys a bit regexy too, so that we could include action plugins and the lot without making too many keys
17:18:10 <bcoca> we will have that problem no matter how the repo looks
17:18:18 <jtanner> yeah, for sure
17:18:52 <bcoca> not completely ... mostly ...
17:18:56 <jtanner> ... almost fixed "completely ignoring"
17:19:01 * rbergeron would be delighted to have more help translating to irc :)  (or making notes on the etherpad
17:19:09 * resmo waves
17:19:20 <svg> I'm not sure I follow here. Can someone give me the quick and short explanation?
17:19:30 <svg> .. of this proposal
17:19:33 <jimi|ansible> svg: regarding which?
17:19:48 <jtanner> "repo consolidation"
17:19:55 <svg> bsaically the short version of what is proposed on the modules
17:19:56 <bcoca> merge repos, no more core/extras, deal with maintainer and packaging using metadata instead of repo lines
17:20:10 <svg> so bck to one repo?
17:20:12 <jimi|ansible> svg: 1) to make it easier for people to contribute and maintain modules without us being a gatekeeper and 2) to make ansible more supportable over longer periods of time
17:20:27 <abadger1999> svg: one repo for modules to live in -- not sure yet whether that repo will also include ansible/ansible or not.
17:20:30 <bcoca> maybe a engine/modules repo, we are still deciding, i like 1 repo to rule tehem all! also ... no submodules!!!
17:20:45 <jtanner> bot is slowing becoming "smart"
17:20:50 <jtanner> slowly*
17:20:58 <jimi|ansible> jtanner is working on creating the singularity...
17:21:19 <jimi|ansible> ansiskynet
17:21:23 <jtanner> thank you resmo for getting us this far
17:21:45 <resmo> jtanner: did it pleasure :)
17:21:49 <bcoca> github.com/ansible/ansibot
17:22:01 <svg> #resmorulez
17:22:02 <rbergeron> #info live question: where is the discussion about the bot happening?
17:22:07 <jtanner> gregdek: https://github.com/jctanner/ansibullbot/blob/ISSUE_TRIAGE_CLASS/ISSUE_HELP.md
17:22:13 <rbergeron> svg: YES, he does :)
17:22:28 <jtanner> https://github.com/jctanner/ansibullbot/blob/ISSUE_TRIAGE_CLASS/ISSUE_HELP.md
17:22:30 <rbergeron> (current repo is http://github.com/ansibullbot
17:22:33 <svg> but you too rbergeron
17:22:36 <jimi|ansible> ansible/ansibot is the old code
17:22:37 <jtanner> yes, that's for issues
17:22:40 <abadger1999> jtanner: what's the meaning of the link?
17:22:57 <abadger1999> (greg is explaining now)
17:22:58 <bcoca> sorry for confusion, we should really remove the old one
17:23:01 <jtanner> the link is a general guide for submitters and maintainers to understand what the bot is doing and how to interact with it
17:23:05 <jimi|ansible> is it even public?
17:23:09 <abadger1999> <nod>
17:23:11 <jtanner> rather than dumping 3 pages of text in every comment
17:23:23 <jimi|ansible> yeah ansible/ansibot was never made public
17:23:29 <jimi|ansible> we had talked about it, but never did it
17:23:30 <jtanner> i have a "bot help" link in the comment templates now
17:23:57 <resmo> jtanner: is there any plans for adding maintainers for new modules?
17:24:03 <jtanner> could be one
17:24:04 <rbergeron> svg: YES, he does :)
17:24:07 <jtanner> i just haven't worked on it
17:24:07 <resmo> s/is/are
17:24:27 <rbergeron> #info there are two separate bots: ansibot is the "legacy" bot that was used in ansible/ansible
17:24:29 <gundalow> please #action stuff so we can formally track actions
17:24:30 <jtanner> umm ... repo is your choice greg
17:24:32 <rbergeron> (i think that is right)
17:24:44 <jtanner> i'll stick with ansible/ansibullbot till told otherwise =)
17:24:48 <resmo> lol
17:24:51 <rbergeron> ansible/ansibullbot is where the bot we have now for PRs for core/extras lives
17:24:56 <bcoca> hotbot potato
17:25:12 <bcoca> lets archive the other one
17:25:17 <jimi|ansible> yeah just completely disregard the comments about ansible/ansibot, i don't think that code has been touched for 2 years
17:25:29 <jtanner> probably true
17:25:40 <jtanner> original code i wrote was unfriendly
17:26:10 <jtanner> tried to combine reporting and triaging into the same codebase ... boiled the ocean, twice
17:26:26 <svg> Ansibullbot should be renamed to just Ansibull
17:26:38 <jimi|ansible> that might be confusing :)
17:26:57 <rbergeron> #topic module api discusion
17:27:14 <svg> not sure, I still see a Gregdek bot doing things too.
17:27:33 <jimi|ansible> svg: that's because we haven't moved it to a dedicated account yet
17:27:45 <jimi|ansible> we will be doing that in the near future i think (it was commented on earlier by gregdek)
17:27:50 <bcoca> ansibot user is in 'testing ' right now
17:29:21 <svg> Did I hear bcoca saying Windows is a lost cause?
17:30:25 <bcoca> no, but yes
17:30:26 <resmo> hmm is powershell even a thing anymore since windows will get a bash?
17:30:36 <bcoca> atomic_move on windows is a lost cause
17:30:54 * svg was wishfully thinking
17:31:22 <svg> resmo: powershell is a lot more than just a shell actually
17:31:23 <bcoca> resmo: sadly ... yes
17:31:40 * resmo has no glue about win and stuff :)
17:31:49 <resmo> lol clue I meant
17:31:55 <bcoca> resmo: you'll live happier that way
17:32:15 <abadger1999> Everyone must talk to greg's chest
17:32:21 <bcoca> his real name is JSON Mac Error
17:32:30 <jimi|ansible> hah
17:32:43 <ryansb> bcoca++
17:33:43 <resmo> namespace maintainers?
17:33:54 <jimi|ansible> hah, love jhawkesworth's video feed right now
17:33:55 * svg found out it's actually Gregory
17:39:39 <resmo> Hmm I wonder when do we tag a module as stable?
17:39:46 <bcoca> i dont want to
17:40:15 <bcoca> what toshio said, we might not do that as we really cannot judge that well
17:40:32 <bcoca> stable/unstable might not be a good division, 'meets ansible core standards' vs not
17:40:33 <resmo> bcoca: agreed
17:40:49 <svg> problem with most modules is testing is hard
17:40:50 <jtanner> passing tests, issue open/closure balance
17:41:05 <ryansb> so more a "meets guidelines"?
17:41:18 <bcoca> kindof
17:41:26 <jtanner> we haven't required tests for modules
17:41:37 <bcoca> we have several levles of guidlines, for it to be 'core supported' we might add 'interface patterns'
17:41:57 <MichaelBaydoun> +1 for mocking
17:42:01 <svg> Management calls. It's supper time here. BBL.
17:42:01 <jtanner> who was that talking on the mic?
17:42:32 <jtanner> jason .. ?
17:42:42 <bcoca> mocking is limited though
17:43:12 <bcoca> lost voice
17:43:19 <ryansb> audio just drop for anyone else?
17:43:25 <resmo> no audio
17:43:26 <MichaelBaydoun> yes, audio out
17:43:33 <nitzmahone> ... and in some cases can dwarf the actual code- potentially VERY brittle and not testing anything useful. In the case of moto or other things where someone's already gone to the work to build a mock for something large, great, but many other cases where it's not practical.
17:44:11 <gregdek> Lost network on the audio workstation, hold please
17:44:12 <jimi|ansible> working on audio, computer doing that lost wireless...
17:44:31 <jtanner> so that's what irccloud looks like
17:44:38 <nitzmahone> irccloud rules
17:44:41 <gregdek> jtanner: SHUT UP MAN
17:44:44 <MichaelBaydoun> +1 for irccloud
17:44:46 <alikins> I'm on the TV!
17:44:57 * jimi|ansible needs to use that
17:45:00 <gregdek> lmk when you have audio again
17:45:01 <jtanner> asciiart party!
17:45:03 <jimi|ansible> i miss a lot of conversations on irc because of that
17:45:45 <jtanner> _______________
17:45:45 <jtanner> < irccloud rules! >
17:45:45 <jtanner> ---------------
17:45:47 <jtanner> \   ^__^
17:45:49 <jtanner> \  (oo)\_______
17:45:51 <jtanner> (__)\       )\/\
17:45:53 <jtanner> ||----w |
17:45:53 <ryansb> interrupted cow
17:45:55 <jtanner> ||     ||
17:45:57 <jtanner> 
17:46:05 <nitzmahone> moo
17:46:36 <bcoca> audio backish
17:46:40 <resmo> audio on
17:46:41 <gregdek> Thanks!
17:46:47 <rbergeron> .---. __
17:46:47 <rbergeron> ,         /     \   \    ||||
17:46:48 <rbergeron> \\\\      |O___O |    | \\||||
17:46:48 <rbergeron> \   //    | \_/  |    |  \   /
17:46:48 <rbergeron> '--/----/|     /     |   |-'
17:46:50 <rbergeron> // //  /     -----'
17:46:52 <rbergeron> //  \\ /      /
17:46:55 <rbergeron> //  // /      /
17:46:57 <rbergeron> //  \\ /      /
17:47:00 <rbergeron> //  // /      /
17:47:02 <rbergeron> /|   ' /      /
17:47:05 <rbergeron> //\___/      /
17:47:07 <rbergeron> //   ||\     /
17:47:10 <rbergeron> \\_  || '---'
17:47:12 <rbergeron> /' /  \\_.-
17:47:15 <rbergeron> /  /    --| |
17:47:17 <rbergeron> '-'      |  |
17:47:20 <rbergeron> '-'
17:47:25 <rbergeron> i guess this won't work on greg's web irc thing. lol
17:47:55 <jtanner> can't tell if giraffe or using early gen teleporters on a cow
17:48:05 <rbergeron> it's a beefy miracle.
17:48:13 <jtanner> aha
17:49:15 <jtanner> "curated" might also be necessary for module PRs without maintainers
17:49:58 <jtanner> we don't want to work on it, but someone has to do the merge
17:50:21 <notmorgan> rbergeron: amazing :)
17:50:45 <jtanner> ok, i gotta drop for a bit ... bbl
18:03:36 <gregdek> OK, about to get started for our 11am session
18:03:39 <gregdek> #topic Core Roadmap
18:04:50 <gregdek> https://github.com/ansible/ansible/blob/devel/docsite/rst/roadmap/ROADMAP_2_2.rst
18:09:39 <resmo> bcoca: is "Brian" you on the "vmware" roadmap? I would be also interested in these, could probably help out a bit.
18:12:33 <bcoca> 4.3
18:13:05 <bcoca> yes and no, i was helping, jtanner is doing heavy lifting, help appreciated
18:13:37 <bcoca> inventory script is done, now the vsphere_guest deprecation/substitution is the current bear
18:14:53 <resmo> I see, I'll come back to it
18:15:20 <resmo> btw great work about testing!
18:18:17 <bcoca> yeah, huge leap from 2 months back
18:21:11 <bcoca> PARTY!
18:21:43 <bcoca> RHEL/Centos 5
18:26:31 <MichaelBaydoun> btw, Thanks for making making this available online, for those of us that couldn't travel to CA.
18:26:44 <gregdek> You're welcome!
18:26:50 <svg> +1
18:26:57 <rbergeron> MichaelBaydoun: :) we are glad folks are here on the internets to join us!
18:27:31 <bcoca> dag is out
18:27:40 <rbergeron> he's on vacation :)
18:27:43 <rbergeron> i believe
18:27:46 <bcoca> i'll send him that part of the recording :-)
18:30:53 <resmo> gregdek: that is no funny :)
18:31:17 <svg> I thought a I heared an evil laugh.
18:31:25 <svg> Where's your white cat gregdek ?
18:31:49 <resmo> yes
18:32:06 <abadger1999> From ealier: yes, our new doc person is dharmabumstead when he's on here.
18:32:35 <resmo> I like rc on new minor versions, but I don't see much need about RCs on patch releases, any thought  about it?
18:33:19 <bcoca> sometimes the patches need patches
18:33:37 <resmo> just making a new patch release?
18:33:56 <svg> When RC"s catch stuff and delay e a release, I guess that is fine?
18:34:01 <bcoca> can change in future once 'module coverage' is better
18:34:09 <svg> It's what its for.
18:34:13 <resmo> ok,
18:34:28 <gregdek> patches of patches of patches
18:34:31 <gregdek> it's patches all the way down
18:34:40 <bcoca> rc5 vs 2.1.6
18:34:47 <jimi|ansible> ^^^
18:34:47 <resmo> gregdek: yes
18:34:47 <svg> If you want to avoid a release to be delayed, more time meeds to be calculated for the RC window I guess?
18:35:21 <jimi|ansible> i prefer rc5 to 2.1.6 because otherwise we're releasing buggy software, at least with RC's there's an expectation that there may be bugs
18:36:05 <ryansb> as an aside: OpenStack has a similar "merge window" problem which *always* results in a rush for the windo
18:36:18 <ryansb> and OpenStack tells people 7-9 months in advance
18:36:24 <notmorgan> ryansb: yep.
18:36:44 * svg suddenly realises "gundaluw-meeting" is the in room source
18:37:20 <notmorgan> well, I am going to say any case of a "code freeze" for an RC or some such, results in the same thing.
18:37:23 <bcoca> it is ALWAYS TOO LATE
18:37:34 <notmorgan> regardless.
18:38:10 <notmorgan> bcoca: ++
18:38:29 <bcoca> s/ship it/merge it/ as we are contemplating 'not shipping the merged'
18:38:35 <resmo> the main problem I see currently is,  PRs do not scale well.
18:39:13 <svg> resmo said a thing
18:39:14 <jimi|ansible> PRs have never been my problem, bug reports are where we spend a lot more time and pile up much higher
18:39:17 <notmorgan> I 100%  agree.
18:39:26 <bcoca> what is the alternative?
18:39:54 <svg> jimi|ansible: is improving the quality for bug reports needed?
18:40:15 <svg> hearing your voice right now, I'd say, yes.
18:40:23 <bcoca> ^ but not all PRs are equal, PR for systems we don't have access/cannot test ...
18:40:40 <resmo> gregdek: yes
18:40:43 <abadger1999> bcoca: +1
18:40:44 <jimi|ansible> svg: right yes having good info makes them much better, but even then like i said it can be very environment-specific
18:40:46 <bcoca> also  bugs are prioritized over new features
18:40:51 <rbergeron> svg: that's something we at least want to get to for modules. like, "at least tell us the module name or else we can't help you."
18:40:59 <rbergeron> but that's more on issues than PRs, obviously
18:41:01 <geerlingguy> bug reports kill me for a little project with 500 stars on github and two dedicated volunteers... they can really burn people out
18:41:09 <jimi|ansible> bcoca: correct, some PRs are still not 100% simple, but i would not say they are the bottleneck of the project
18:41:18 <bcoca> agreed
18:41:19 <rbergeron> geerlingguy: yeah.
18:42:06 <svg> I can relate, recently did a PR on a MYSQL module, it's hard to get things going for even such a standard widely used server
18:42:27 <resmo> gregdek: makes sense, +1
18:42:31 <jimi|ansible> that's still relatively easy compared to someone sending a PR for fact gathering on AIX
18:43:00 <svg> makes me think there should be a separate AIX repo
18:43:18 <svg> HI JEFF
18:43:27 <resmo> everyone knows jeff
18:43:29 <geerlingguy> HI!
18:43:40 <jtanner_> hrm ... networked died on me for a bit
18:43:57 <jimi|ansible> blue jeans occasionally kills my chrome tab (memory leak), i quit reopening it
18:44:16 * svg still confused about the 'Guy' part in his nick though
18:45:11 <resmo> gregdek: rofl
18:45:13 <jtanner> was thinking about allowing module maintainer to say "need_help"
18:45:21 <jtanner> to invite other collaborators
18:45:26 <svg> gregdek: I have a couple of modules I wrote, problem is not really burn out, but getting in a professional situation where maintenance is not easy anymore
18:45:27 <jimi|ansible> tag needs to be -> HALP!
18:45:30 <resmo> gregdek: right
18:45:35 <notmorgan> jimi|ansible: lol
18:45:39 <bcoca> some just run away in terror
18:45:45 <svg> jimi|ansible: how about 'F1'
18:45:47 <jtanner> jimi|ansible: HALP HALP ME RONDA
18:45:52 <geerlingguy> ++ to the split a thousand times; that's basically the way Drupal modules work, and they're maintained completely separate from Drupal core
18:46:00 <geerlingguy> has worked well; not perfect, but good enough
18:46:42 <svg> gregdek: not having access anymore to the infra to maihtain the module
18:47:02 <jtanner> svg: that's the current prob with vmware modules
18:47:13 <geerlingguy> Drupal's process definition: https://www.drupal.org/node/251466
18:47:21 <jimi|ansible> it's been the problem with most cloud and 3rd party modules
18:47:31 <svg> if it wasnt' happening with vmware it wasn't happening with any modules
18:47:34 <bcoca> drupal has an easy way to install those plugins, currently we do not have that for ansible plugins, only roles
18:47:37 <resmo> gregdek: 1 maintainers vs community, I should not be a problem if one disappears right
18:48:00 <svg> jimi|ansible: jtanner: again, recent example where I updated a closed PR for a mysql module
18:48:43 <svg> (fyi https://github.com/ansible/ansible-modules-extras/pull/2594)
18:49:01 <jimi|ansible> geerlingguy: that's kind of similar to how we handle it, but we don't have it well documented like that
18:49:02 <svg> and.. mysql is not some weird cloud thing
18:49:34 <svg> a specific mysql replication setup is apparently already weird enough
18:49:40 <svg> gregdek ^^
18:49:55 <jtanner> "hot garbage" ... official term?
18:50:00 <geerlingguy> documentation++ - it's always good to be able to point people there, or have it SEOable
18:50:06 <geerlingguy> key word is 'hot'
18:50:06 <notmorgan> jtanner: if it isn't it should be ;)
18:50:06 <bcoca> worksforme
18:50:21 <bcoca> drupal follows 'galaxy model'
18:50:46 <rbergeron> jtanner: totes!
18:51:11 <geerlingguy> bcoca: correct
18:51:16 <rbergeron> hoverboard batteries
18:51:20 <bcoca> honeybadger  module?
18:51:23 <bcoca> does it attack people?
18:51:24 <svg> OH: gregdek dissing 'battery included'
18:51:35 <gundalow> It's a great film
18:51:35 <ryansb> hahaha - batteries to *everything ever* included
18:51:43 <bcoca> there is 'batteries included' and there is 'nuclear power plant included'
18:51:44 <jimi|ansible> it's one of his favorite analogies (and it's very accurate)
18:51:51 <ryansb> bcoca: it's the module that don't care
18:52:27 <jtanner> don't nuke me bro
18:52:36 <jimi|ansible> i look forward to having 1000 nginx modules
18:52:48 <jtanner> 999th is the best module
18:53:02 <jtanner> 1000 was unnecessary refactor
18:53:05 * svg votes for 666
18:53:18 <rbergeron> #topic Lunch break! back in about 40m
18:53:54 <jimi|ansible> good timing jhawkesworth :)
18:53:59 <jimi|ansible> we're breaking for lunch
18:54:02 <svg> ;D
18:54:09 <jhawkesworth> Dang!
18:54:17 <jimi|ansible> back in 45 minutes (ish)
18:54:25 <jhawkesworth> Ok,
18:55:09 <gregdek> We're on break! See you in 35ish.
18:56:04 <svg> Hi jhawkesworth !
18:56:17 <svg> (we met in London IIRC)
18:56:20 <jhawkesworth> Hi!
18:58:54 <bcoca> voice communication works better when mute is off!
19:00:09 <svg> bcoca being helpfull
19:00:53 <bcoca> lies!
19:01:46 <svg> pondering doing some automated curl -I https://www.ansible.com/opentower
19:01:55 <svg> (did I get that url right?)
19:02:17 <bcoca> script on server side delays tower open sourcing 3 months per request
19:03:37 <svg> so if I have nagios doing a check every minute, gregdek will get in trouble at some point?
19:05:14 <MichaelBaydoun> I don't know, the 404 cow is fun to look at
19:06:20 * svg introduces MichaelBaydoun to cowsay
19:08:45 <bcoca> always thought ansible should put cowsay as dependency
19:17:30 <ryansb> maybe just an optional one
19:21:52 <bcoca> MANDATORY
19:23:53 <jtanner> THUNDERCOW
19:25:03 <jtanner> botname ^ ?
19:26:02 <bcoca> thundering cow problem?
19:26:49 <jtanner> when maintainer needs help, he/she has to comment "thunder... thunder... thundcows HO!"
19:27:15 <bcoca> you just made me spill juice through my nose
19:27:42 <jtanner> now you don't have to use a nettipot
19:30:32 <gregdek> Looks like folks aren't back from lunch, so we may start closer to 12:45 local time.
19:36:05 <svg> the problem with twitter is, someone already got https://twitter.com/thundercow
19:36:54 <jtanner> figures
19:37:03 <svg> At some point I expoect twitter to need to extendf their namespace. RIght now it's like an internet where you only get .com's
19:37:05 <MichaelBaydoun> There is apparently a sonic boom episode called cowbot
19:37:09 <jtanner> pretty sure we had this convo ~3 years ago
19:37:17 <bcoca> yes, yes we did
19:37:40 <svg> prolly, it keeps baffling me thou
19:38:24 <MichaelBaydoun> http://sonic.wikia.com/wiki/Cowbot
19:43:11 * jtanner submits proposal to s/shipit/moo
19:44:10 <MichaelBaydoun> +1
19:44:38 <jtanner> s/+1/hoofprint
19:44:39 <MichaelBaydoun> and s/worksforme/cowbell
19:44:57 <gregdek> OK, I'm now thinking :00, sigh.
19:45:04 <gregdek> And then we're starting, even if this room is empty.
19:45:32 <MichaelBaydoun> 30 minutes for lunch was optimistic
19:45:38 <jtanner> ring your cowbell, so they come back
19:45:43 <gregdek> Yes. :)
19:45:45 <gregdek> 'sok.
19:46:02 <gregdek> Just means less time for arguments about testing, LOL
19:46:23 <jhawkesworth> gregdek: needs a bullhorn ,surely
19:48:03 <MichaelBaydoun> but does the bullhorn come with batteries included?
19:48:22 <jtanner> not if you get one like this: https://upload.wikimedia.org/wikipedia/commons/d/d3/Alphorn_player_in_Wallis.jpg
19:48:51 <MichaelBaydoun> thats long enough to reach into the the other room
19:53:13 <bcoca> they are testing the limits of time in a lunch break
19:53:33 <jtanner> it is a festival ...
19:54:16 <jhawkesworth> Destructive testing I hope
19:55:26 * nirik needs to reboot the instance zodbot is on here at some point... would now be a good time since it's a lunch break?
19:55:49 <gregdek> nirik, can it be back in 5?
19:55:52 <gregdek> If so, go ahead
19:56:18 <nirik> it takes a while to rejoin... not sure if it's under 5min or not.
19:56:44 <gregdek> ehh... 10m?
19:56:58 <nirik> probibly. can try. ;)
19:57:00 <gregdek> More than 10m, would rather wait
19:57:18 <nirik> we can wait too... when do you think you'll be done/at another break?
19:57:39 <gregdek> We're done in another 3.5h
19:57:40 * nirik waves at everyone there at contibutor conference. ;)
19:57:44 <gregdek> No real break
19:57:56 <nirik> ok, lets wait and do it after that. ;)
20:00:31 <bcoca> i can hear
20:00:33 <jtanner> gregdek: yep
20:00:35 <gregdek> ok thx
20:00:37 <jhawkesworth> I can hear
20:00:48 <jhawkesworth> Cool
20:00:53 * abutcher waves
20:03:07 <jhawkesworth> No still hearing you
20:03:13 <jtanner> i hear them
20:03:22 <jtanner> the video froze though
20:03:35 <jhawkesworth> Yeah video back
20:03:56 <bcoca> there is a IT crowd joke there 'did anyone drop the black box?'
20:05:01 <geerlingguy-mba> Galaxy, hooray!
20:05:42 <bcoca> ansible-lint
20:05:51 <geerlingguy> https://github.com/ansible/galaxy-issues/issues
20:07:46 <geerlingguy> Robyn++
20:07:59 <jtanner> that'll be done by tomorrow right?
20:08:13 <geerlingguy> 'next AnsibleFest', so yep
20:08:26 <geerlingguy> </snark>
20:08:39 <geerlingguy> chouseknecht++
20:09:07 <geerlingguy> glacial pace is better than not moving :)
20:09:13 <bcoca> also docker modules, ansible-container and we are planning of using him to usher all ansible employee weddings
20:09:27 <jtanner> and my laundry is piling up
20:09:31 <bcoca> i forgot azure modules
20:09:34 <jimi|ansible> chouseknecht: if you're pace is described as glacial, i don't want to know what mine would be described as when i was in charge of it
20:09:44 <jimi|ansible> s/you're/your/
20:09:46 <bcoca> jimi|ansible: time stood stil
20:09:52 <jimi|ansible> :(
20:10:02 <geerlingguy> lol
20:10:32 <jtanner> what is geerlingguy's thoughts about galaxy's future?
20:10:45 <jimi|ansible> drybjed around?
20:11:30 <bcoca> https://github.com/ansible/proposals/issues/23
20:12:23 <jtanner> galaxy is a package manager that just needs some love
20:12:57 * svg needs  to catch sleep, thanks and keep up the good work, looking forward to read the reports! bye all!
20:12:57 <ryansb> talk about being on top of things
20:13:06 <jtanner> 'night svg
20:13:13 <jimi|ansible> bye svg
20:13:14 <svg> o/
20:13:20 <bcoca> dyes, this turns it into a package manager
20:13:44 <resmo> svg: bye
20:14:12 <jimi|ansible> it pretty much did that before, it just allowed one to be installed in a directory and we never allowed an "update" option
20:14:18 <jimi|ansible> it was just a forced replace
20:14:42 <alikins> 14th time is the charm
20:14:53 <resmo> jimi|ansible: just to be clear, the "more frequent releases" was referencing modules, not core. btw
20:15:01 <jimi|ansible> when i originally wrote it, ansible-galaxy was basically based on pip, so yes it's always been a bit of a package manager
20:15:18 <jimi|ansible> resmo: gotcha, but we keep them in lockstep so it'd imply a full release of core as well
20:15:31 <jimi|ansible> no NEVRA
20:15:50 <jtanner> we could also install a /usr/bin/agp -> ansible-galaxy to have our slick/easily-typed acronym too
20:15:53 <alikins> or, more accurately the 14.0.0-a_beta1_0-1 'th time is the charm
20:16:45 * jimi|ansible smacks alikins with a large trout
20:17:32 <drybjed> good evening
20:18:23 <jtanner> hey drybjed
20:18:32 <resmo> hi drybjed
20:18:45 <drybjed> hello :)
20:19:06 <geerlingguy> drybjed: hi!
20:19:20 <drybjed> how's the conference going?
20:20:56 <geerlingguy> "When referencing a role in a play, ansible-playbook should now also check if version is specified and use that if found, optionally falling back to the 'unversioned' name depending on config flag." I think that was throwing me off
20:21:02 <jimi|ansible> drybjed: https://public.etherpad-mozilla.org/p/ansible-summit-july-2016-galaxy
20:21:18 <jimi|ansible> ^ our current topi
20:21:20 <jimi|ansible> topic
20:21:53 <drybjed> I'm in :)
20:22:48 <drybjed> aand completely lost :)
20:22:54 <geerlingguy> https://github.com/ansible/ansible/pull/15444 ?
20:22:56 <drybjed> ok, listening in
20:23:04 <geerlingguy> auto role installation proposal / PR
20:23:22 <geerlingguy> versions are important :)
20:23:25 <jimi|ansible> yes currently talking about role versioning, whether in galaxy/the ansible-galaxy cli (and ansible-playbook) or both
20:23:36 <drybjed> ok, thanks
20:25:17 <resmo> not sure if I like ansible-galaxy tries to be that clever
20:26:04 <drybjed> can ansible-galaxy install custom repositories, like say, https://github.com/debops/debops-playbooks/? I use custom script just to be able to update that
20:26:51 <drybjed> well, my script pulls the debops-playbooks repo and then grabs the list of roles from there and pulls that...
20:27:14 <drybjed> basically, roles themselves aren't enough
20:27:17 <jimi|ansible> it's easy if you control the deps, not so much if you're using 3rd party deps
20:27:35 <jtanner> bcoca: you are having mic issues
20:27:40 <jimi|ansible> you can at least ensure there aren't deps of the same package but different versions in the graph
20:27:50 <rbergeron> bcoca: you're ... giving us the wah wah charlie brown thing
20:28:45 <jtanner> i wonder if ambient noise from the conference room is garbling bcoca
20:29:17 <jtanner> ... do i detect sarcasm in the room?
20:29:52 <jimi|ansible> not at ALL
20:30:03 <jtanner> just wanted to make sure there weren't crazy people
20:30:05 <tima_> @jtanner was thinking the same thing.
20:30:27 <rbergeron> no sarcasm here!
20:30:53 <jimi|ansible> galaxy.db
20:31:37 <jtanner> we're going to turn galaxy into maven
20:31:46 <geerlingguy> maven with npm's slowness, haha
20:32:02 <tima_> ugh. stop it you 2.
20:32:09 <abadger1999> bcoca: Yeah, I think if we do not do instalation of dependendencies I think it's possible.
20:32:51 <drybjed> what about role authentication? gpg with upload of role packages signed by authors?
20:33:11 <jimi|ansible> drybjed: i jokingly brought up signed roles in the room while on mute...
20:33:38 <jimi|ansible> though if we do have a checksum, you'd at least know if the rpm was different from installed
20:33:44 <drybjed> I'm signing commits and tags in git repositories, but that isn't enough
20:34:19 <drybjed> some more info here: https://docs.debops.org/en/latest/debops-policy/docs/code-signing-policy.html
20:34:36 <ryansb> I have bad news for you: no matter how good your package manager is, it's always hell for someone
20:35:12 <jimi|ansible> that's it, start writing .spec files for your roles
20:35:16 <jtanner> wait .... what?
20:35:20 <jhawkesworth> Anything which depends on something else that varies == possibility of some kind of hell
20:35:21 <jtanner> dep mapper for issues?
20:35:27 <bcoca> meta/spec.yml
20:35:33 <drybjed> spec?
20:35:38 <bcoca> rpm mthing
20:35:40 <jimi|ansible> spec = rpm
20:35:43 <drybjed> ah, right
20:35:44 <bcoca> think debian/ in .deb
20:36:25 <drybjed> uhhh, roles as separate .debs is not a very good idea, it would be like hundreds of .deb packages
20:36:40 <jimi|ansible> how's that different from other packages? :)
20:36:48 <drybjed> actually, debops-playbooks is packaged in Debian with all roles as 1 package, and can be updated after installation
20:37:37 <drybjed> jimi|ansible: there might be an idea to package say, mysql role with mysql package, but it doesn't really work when you use roles 1 on host to manage multiple other hosts
20:37:51 <drybjed> in that case you want mysql *package* and mysql *role* separate
20:38:28 <drybjed> yes
20:39:56 <ryansb> PSYCHED
20:40:12 <mordred> so psyched
20:40:22 <jtanner> THUNDERCOWS
20:40:38 <mattclay> I'm here.
20:42:05 <gregdek> Hi mattclay!
20:49:27 <gundalow> #topic Testing
20:49:47 <gundalow> #info Testing is cool, let's make it easier
20:50:22 <jtanner> need zuul demo video
20:50:47 <jtanner> with many ghostbusters references
20:54:37 <drybjed> what about docker/lxc containers for testing instead of full vms?
20:54:51 <drybjed> (unless zuul does that...)
20:55:11 <gundalow> I believe that's in the future
20:55:25 <bcoca> it should be able to do
20:57:14 <bcoca> it should be able to do it if winrm reqs get installed on 'zuul -> ansible controler'
20:59:09 <drybjed> hmm, travis has it
20:59:29 <MichaelBaydoun> pointer to the legal virtualization of mac just mentioned?
20:59:51 <resmo> MichaelBaydoun: running on apple hardware IMHO
20:59:52 <gundalow> drybjed: good point, not sure what that uses
21:00:07 <drybjed> https://docs.travis-ci.com/user/osx-ci-environment/
21:01:06 <gundalow> #action gundalow To remember that macos is a target
21:02:34 <jhawkesworth> Spinning up the windows vms on AWS described on @nitzmahone blog blog.rolpdog.com, btw
21:02:36 <nitzmahone> Travis' OSX support is pretty dodgy
21:02:43 <ryansb> hey, gotta drop off folks, cheers!
21:03:11 <nitzmahone> Ancient version of OSX, *very* slow boot. Feels a bit abandonware
21:05:47 <mordred> drybjed: definitely will have container targets - both single containers and also stretch goal things like kube
21:06:28 <geerlingguy> For OS X in a VM, I had success with https://github.com/geerlingguy/mac-osx-virtualbox-vm - but Mac OS X in VMs *is* dodgy, no matter what platform
21:06:39 <geerlingguy> best solution is having Mac OS X 'slaves' Jenkins-style
21:07:08 <geerlingguy> MacMiniColo is basically the answer to that
21:08:56 <mordred> geerlingguy: awesome. that'll be fun to deal with from a responding-to-scale perspective :)
21:08:58 <bcoca> early osx was 'legal' to virtualize on the same machine that  you bought
21:09:03 <haunted> I agree
21:09:11 <bcoca> that might be what they are using
21:09:46 <geerlingguy> mordred: "just buy a ton more Macs, Apple likes it that way" :)
21:09:47 <resmo> gregdek: version_added: when_merged_jackass
21:09:57 <resmo> :P
21:10:04 <gundalow> :D
21:10:09 <haunted> :)
21:10:09 <mordred> geerlingguy: good. I was worried there wouldn't be motivation to send more money to apple
21:10:34 <geerlingguy> macOS virtualization is... fragile
21:14:54 <notmorgan> geerlingguy not surprising
21:15:01 <alikins> if you notice it
21:15:20 <gundalow> #action gundalow TWG weekly report of new modules (raised & merged)
21:15:30 <alikins> (true with reviewed code as well of course...)
21:15:43 <bcoca> shippable vs stable
21:16:30 <bcoca> ^ we can bikeshed name later
21:16:39 <gundalow> :)
21:16:58 <bcoca> srvice module
21:18:26 <bcoca> so i can stop doing it!
21:19:46 <mordred> bcoca: service should totally have a srvice alias
21:22:02 <bcoca> svc already exists
21:23:48 <bcoca> verified/unverified/failed (to core team standards)
21:24:16 <bcoca> verified/unverified/not passed
21:24:21 <bcoca> failed seems harsh
21:26:09 <bcoca> to get out of 'crapbag' it requires testing for the module
21:26:30 <bcoca> ^ 1 requriement
21:31:47 <bcoca> klingong calendar?
21:38:36 <bcoca> live log? is this a callback? have you seen new junit callback?
21:38:36 <resmo> sounds interesting :)
21:38:51 <drybjed> still listening in ;)
21:38:51 <resmo> the zuul thing
21:38:53 <jhawkesworth> Faster testing seems like a solved problem to me
21:38:57 <bcoca> that is what IRC IS FOR!
21:39:13 <jtanner> zuullbulls
21:39:14 <bcoca> zull/ansible shirts
21:39:18 <jhawkesworth> As long as ship able stays sweet
21:39:35 <resmo> seems zuulable
21:39:44 <bcoca> zoiks!
21:40:04 <bcoca> keymaster/gatekeeper zuulbulls
21:40:11 <alikins> zuulballz
21:40:28 <bcoca> ansibuullz
21:40:42 <drybjed> will there be any videos from the conference?
21:41:00 <bcoca> afaik, sound + slides
21:41:42 <geerlingguy> WiFi here is not fun right now :P
21:41:48 <drybjed> yeah
21:42:07 <gundalow> Who would like to attend the Testing Working Group on IRC (so I can work out timezones for meeting),  please respond with +1
21:42:20 <gregdek> +1
21:42:22 <mattclay> +1
21:42:26 <linuxdynasty> +1
21:42:26 <karstensrage> +1
21:42:27 <gregdek> actually -1
21:42:36 <jtanner> no backsies
21:42:44 <gregdek> OH I GOT BACKSIES
21:42:44 <corvus> +1
21:43:34 <gundalow> thanks
21:43:40 <mordred> gundalow: +1
21:45:36 <bcoca> avoiding windows is my way of life
21:45:40 <jtanner> you shot windows? is it really dead?
21:45:48 <resmo> no windows here
21:45:50 <jhawkesworth> Just me
21:45:52 <jhawkesworth> Still here
21:45:56 * nitzmahone throws ansibull at jtanner
21:46:06 <jhawkesworth> No one else in.terested in Windows
21:46:12 <jhawkesworth> ?.
21:46:12 <gundalow> #action gundalow to setup TWG and doodlepoll gregdek rbergeron mattclay linuxdynasty karstensrage corvus
21:46:22 <gundalow> #topic Open Floor
21:46:57 <gundalow> #topic Windows
21:47:17 <jhawkesworth> I was hoping there might be enough of us to have a bit of a Windows working group
21:47:35 <drybjed> there should be a module to reinstall windows to linux, that will solve all kinds of problems ;)
21:47:45 <rbergeron> gundalow: add in mordred to that list
21:47:52 <nitzmahone> jhawkesworth: I'm thinking we need to make our little thing more public
21:47:54 <bcoca> irc meeting?
21:47:55 * resmo has to pull the plug, back to holidays... cu!
21:47:55 <jhawkesworth> In general
21:47:59 <jhawkesworth> Yes definitely
21:48:02 <bcoca> make a monthly one
21:48:24 <jhawkesworth> Throwing stuff at the screen now
21:48:25 <gundalow> resmo: Thanks for your time
21:48:31 <jtanner> windows users are used to waiting ...
21:48:34 <resmo> gundalow: ;)
21:48:40 * rbergeron hugs jhawkesworth
21:48:50 <jhawkesworth> I am laughing
21:49:17 <rbergeron> we owe you a nice gift basket.
21:49:19 <jhawkesworth> Yeah, but don't want to take up the time of anyone who not interested
21:49:19 <mattclay> I'm in for the Windows meeting, whenever it is.
21:49:30 <jhawkesworth> Worcestershire
21:49:33 <jhawkesworth> U.K.
21:49:40 <resmo> non-EU
21:49:55 <jhawkesworth> Home of led Zeppelin and Worcestershire sauce
21:49:58 <bcoca> probably not U for long either
21:50:01 <jhawkesworth> Yeah sure
21:50:08 <bcoca> he was at last one
21:50:14 <jhawkesworth> I spoke at both London. Ansiblefests
21:50:14 <gundalow> I should point out I have Ops rights on IRC, so careful resmo
21:50:24 <jhawkesworth> Thanks for listening :-)
21:50:31 <resmo> okayokay, I am off, late here :)
21:50:36 <bcoca> gn
21:50:52 <jhawkesworth> Yeah totally
21:51:22 <gundalow> #action setup Windows Working Group
21:52:26 <bcoca> well, ... its 2nd class OS
21:52:37 <MichaelBaydoun> gundalow: ping me when you get that setup
21:52:38 <jhawkesworth> It's. Been a huge boost having nitzmahone on board full time
21:52:48 * nitzmahone throws ansibull @ bcoca
21:52:48 <abadger1999> jhawkesworth: +1
21:52:49 <bcoca> it has, i never had time to pay proper attention
21:52:52 <drybjed> I'm off, good night
21:53:17 <gundalow> Meeting resumes in 10 minutes
22:07:25 <gregdek> OK, maybe more like 20 minutes, LOL
22:07:38 <gregdek> There are yummy pastries. Sorry remote friends :(
22:09:02 <jhawkesworth> Someone invent Pastry Over http, quick
22:11:18 <MichaelBaydoun> need to run, thanks all, enjoyed it
22:11:55 <gregdek> Thanks MichaelBaydoun!
22:12:21 <bcoca> pptp, pastery pushing tunnel protocol
22:12:45 <jhawkesworth> Hello
22:13:29 <jhawkesworth> PPTP ! Yes!
22:13:34 <geerlingguy> I can't *contain* my excitement
22:14:11 <geerlingguy> get it...
22:14:14 <geerlingguy> 'contain'
22:14:26 <bcoca> no, i let it go, it can die in peace
22:14:53 <bcoca> we wouold get a tuxedo?
22:17:24 <bcoca> sound going away
22:19:57 * bcoca raises hands
22:20:05 <jhawkesworth> Not me
22:21:23 <bcoca> go/go bang!
22:21:38 <bcoca> not reversi (very simple version of it)
22:22:50 <gundalow> #topic Containers
22:37:28 <geerlingguy> curl | sudo bash all the things! :D
22:37:38 <bcoca> openshack!
22:38:41 <karstensrage> jhawkesworth: youre not alone, not all of us like windows but we have to manage it and ansible is the most tolerable way of doing that
22:38:58 <bcoca> Kops?
22:39:00 <bcoca> cups?
22:39:03 <bcoca> Kups?
22:39:12 <geerlingguy> CUPS haha
22:39:17 <geerlingguy> print a new stack
22:40:12 <jhawkesworth> Thanks karstensrage . I could poke away in a terminal all day.. But I work at a Windows shop.
22:40:25 * karstensrage too
22:43:07 <bcoca> undercloud/overcloud ...... earth and sky are not good enough?
22:46:13 <bcoca> use mics, cannot hear most people except greg
22:47:38 <geerlingguy> I used mic!
22:50:02 <gundalow> Is the audio OK now?
22:52:28 <gundalow> # topic open floor
22:52:37 <gundalow> #topic open floor
22:54:41 <bcoca> sounds ok to me
22:56:26 <gundalow> #action gregdek to update ansible.com/community to point to agenda page
22:57:22 <gregdek> #endmeeting