#ansible-meeting: Ansible Public Core Meeting

Meeting started by abadger1999 at 15:12:15 UTC (full logs).

Meeting summary

  1. Roll call (abadger1999, 15:12:27)
  2. Open floor (abadger1999, 15:14:30)
  3. CloudRetry/AWSRetry backoff decorator with unit tests https://github.com/ansible/ansible/pull/17039 (abadger1999, 15:16:07)
    1. ACTION: bcoca, ryansb, abadger1999 to talk about https://github.com/ansible/ansible/pull/17039 tomorrow. linuxdynasty to continue prodding with with a progressively hotter poker. (abadger1999, 15:20:09)
    2. https://github.com/ansible/proposals/issues/22 < = there is even pr that started implementing this (bcoca, 15:22:56)
    3. For community members, he Core team is going to choose between https://github.com/ansible/proposals/issues/30 and https://github.com/ansible/proposals/issues/28 (The Module metadata proposals) next week. (abadger1999, 15:25:33)

  4. Define a standard way to document playbooks https://github.com/ansible/proposals/issues/19 (abadger1999, 15:31:32)
    1. https://github.com/ansible/proposals/commit/9d8c15811e200bb8918ca149d0d102cd489a8666 (jimi|ansible, 15:32:07)
    2. requirement: have a way to view documentation in playbooks that are on your current machine via a cli tool. (abadger1999, 15:46:44)
    3. Would like some use cases "Alice is a W and wants to document X in her playbooks. Bob uses Y to read the documentation so that he can Z." That way we can understand the problemspace we want to address. (abadger1999, 15:48:36)
    4. https://github.com/debops/ansible-environment < =drybed example, uses docs/ dir (bcoca, 15:48:48)

  5. Open floor (abadger1999, 15:54:22)
    1. https://github.com/ansible/proposals/pull/27 <= close as dupe of roles revamp? (bcoca, 15:54:46)

  6. https://github.com/ansible/proposals/pull/27 Make role re-use easier (abadger1999, 15:55:12)
    1. ACTION: bcoca to writeup new PR to clarify the points that proposal/27 is trying to address (abadger1999, 16:08:05)

  7. Open Floor (abadger1999, 16:08:09)


Meeting ended at 16:09:22 UTC (full logs).

Action items

  1. bcoca, ryansb, abadger1999 to talk about https://github.com/ansible/ansible/pull/17039 tomorrow. linuxdynasty to continue prodding with with a progressively hotter poker.
  2. bcoca to writeup new PR to clarify the points that proposal/27 is trying to address


Action items, by person

  1. abadger1999
    1. bcoca, ryansb, abadger1999 to talk about https://github.com/ansible/ansible/pull/17039 tomorrow. linuxdynasty to continue prodding with with a progressively hotter poker.
  2. bcoca
    1. bcoca, ryansb, abadger1999 to talk about https://github.com/ansible/ansible/pull/17039 tomorrow. linuxdynasty to continue prodding with with a progressively hotter poker.
    2. bcoca to writeup new PR to clarify the points that proposal/27 is trying to address
  3. linuxdynasty
    1. bcoca, ryansb, abadger1999 to talk about https://github.com/ansible/ansible/pull/17039 tomorrow. linuxdynasty to continue prodding with with a progressively hotter poker.
  4. ryansb
    1. bcoca, ryansb, abadger1999 to talk about https://github.com/ansible/ansible/pull/17039 tomorrow. linuxdynasty to continue prodding with with a progressively hotter poker.


People present (lines said)

  1. abadger1999 (61)
  2. bcoca (60)
  3. linuxdynasty (20)
  4. jimi|ansible (14)
  5. zodbot (6)
  6. gregdek (5)
  7. misc (4)
  8. Qalthos (1)
  9. shertel (1)
  10. ryansb (1)


Generated by MeetBot 0.1.4.