#ansible-meeting: Public Core Meeting

Meeting started by abadger1999 at 15:09:27 UTC (full logs).

Meeting summary

  1. Roll call (abadger1999, 15:09:57)
  2. Figure out how to represent missing python libraries in facts https://github.com/ansible/ansible/issues/16612 (abadger1999, 15:11:51)
    1. End user will see a printed warning but facts will stay the same. (abadger1999, 15:30:06)
    2. Trozz will look at using the existing "warnings" return value (a list) to implement this. (abadger1999, 15:31:33)
    3. Need to look at gather_facts to make sure it won't supress the warning output (abadger1999, 15:32:03)

  3. speed up async module execution by removing some sleeps https://github.com/ansible/ansible-modules-core/pull/4432 (abadger1999, 15:32:42)
    1. Windows async changes https://github.com/nitzmahone/ansible/blob/win_async/lib/ansible/plugins/action/async.py (abadger1999, 15:47:21)
    2. copy module is good thing to look at to tell if more files are being transferred (abadger1999, 15:47:58)
    3. further discussion in #ansible-devel and next meeting if necessary (abadger1999, 15:48:18)

  4. archive module parameters: https://github.com/ansible/ansible-modules-extras/pull/2323#issuecomment-237360607 (abadger1999, 15:48:39)
    1. https://github.com/ansible/ansible/pull/17351 (bcoca, 15:52:55)
    2. ACTION: abadger to apologize for lack of time and post idea to revert from 2.2 with the possibility of restoring it if proper parameters can be worked out in time. (abadger1999, 16:01:42)

  5. open floor (abadger1999, 16:01:46)
    1. https://www.ansible.com/blog/ansible-contributor-summit-brooklyn-2016 (gundalow, 16:04:19)
    2. Testing Working Group has started. Meeting today at 17:00 UTC (abadger1999, 16:04:49)
    3. Agenda + info on Docs Sprint (gundalow, 16:05:00)
    4. Agenda + info on Docs Sprint https://public.etherpad-mozilla.org/p/ansible-summit-october-2016 (gundalow, 16:05:08)
    5. Doc sprint happening at the next Ansible Contriubtor Summit: Early October in Brooklyn (abadger1999, 16:05:22)
    6. https://github.com/ansible/ansible/pull/17351 <= need to link that there too (bcoca, 16:06:42)
    7. https://github.com/ansible/ansible/pull/17351 Start of documentation of names of common and internal return values (abadger1999, 16:07:22)
    8. Trozz will get teh ball rolling on closing old issues by putting them on the meeting agenda for next week. (abadger1999, 16:16:07)


Meeting ended at 16:18:39 UTC (full logs).

Action items

  1. abadger to apologize for lack of time and post idea to revert from 2.2 with the possibility of restoring it if proper parameters can be worked out in time.


People present (lines said)

  1. abadger1999 (74)
  2. Trozz (29)
  3. gundalow (20)
  4. bcoca (12)
  5. sivel (10)
  6. caseylucas (8)
  7. zodbot (8)
  8. nitzmahone (8)
  9. docschick (4)
  10. mordred (3)
  11. mattclay (2)
  12. jimi|ansible (1)
  13. linuxdynasty (0)
  14. shertel (0)


Generated by MeetBot 0.1.4.