17:00:00 <gundalow> #startmeeting Testing Working Group
17:00:00 <zodbot> Meeting started Thu Sep 15 17:00:00 2016 UTC.  The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:00 <zodbot> The meeting name has been set to 'testing_working_group'
17:00:09 <gundalow> #chair gundalow mattclay
17:00:10 <zodbot> Current chairs: gundalow mattclay
17:00:10 <gundalow> #topic Roll call
17:00:10 <gundalow> Who is here?
17:00:10 <gundalow> Who is new this week?
17:00:46 * MichaelBaydoun is present
17:00:48 <gundalow> Joel: Welcome, could you give a quick intro to yourself (& your github id) and what your interest is
17:00:49 * mattclay waves
17:00:53 <shertel> hello
17:01:06 <gundalow> Hello all :)
17:01:32 <Joel> ansible (ab)user, maintain ec2_ami, improving my ability to develop! github id: jjshoe
17:02:47 <gundalow> excellent
17:03:09 <gundalow> agenda as always is https://github.com/ansible/community/issues/114
17:03:24 <gundalow> Joel: you may wish to hit the "subscribe" button on that page
17:04:30 <gundalow> Just reviewing the agenda as there doesn't seem to be anythign new on there
17:04:47 <gundalow> #topic Ansible Core Engineering update
17:05:15 <gundalow> Internally we are continuing work on towards the 2.2 release
17:05:59 * gundalow is working on adding tests in for the networking modules that have been added/extended in 2.2 github.com/ansible/test-network-modules
17:06:36 <gundalow> And Matt continues on improving the tests especially around Python 3 support
17:07:00 <bcoca> hmm, thsi meeting is not on the calendar
17:07:23 <gundalow> bcoca: the /community one?
17:07:33 <gundalow> #action gundalow add meeting to calendar
17:07:48 * skg-net Hey team
17:08:03 <gundalow> hey skg-net
17:08:37 <gundalow> Once 2.2 is done we will be taking a step back to work out how to best attack testing
17:08:49 <gundalow> https://public.etherpad-mozilla.org/p/ansible-testing-working-group is going to be one of the main drivers on that
17:09:39 <gundalow> Joel: Not sure if you've voted on the above, feel free to add your -1/+1's
17:10:49 <gundalow> And from the votes from you lovely people improving the docs is one of the bits we will most likely throw some decent effort at
17:10:57 <gundalow> #topic Open Floor
17:11:04 * gundalow notes he's been doing all the talking
17:12:20 <gundalow> Joel: Thank you for fleshing out lines 28-31 in https://public.etherpad-mozilla.org/p/ansible-testing-working-group
17:12:29 <gundalow> Joel: Was their anything you'd like to add
17:12:32 <gundalow> linuxdynasty: you around?
17:14:08 <Joel> gundalow, no that sums up my short term needs
17:15:01 <gundalow> Joel: Are you aware of https://www.ansible.com/blog/ansible-contributor-summit-brooklyn-2016 In person & online event to help shape the future direction of Ansible
17:16:52 <gundalow> I believe linuxdynasty is currently on vacation so hasn't had time to apply the indepth feedback that you've all provided to his PR
17:17:00 <Joel> gundalow, was not familiar with it, probably can't make that one, but I could make the next one
17:17:31 <gundalow> Joel: nod (where in the world are you, if you don't mind me asking) You can attend online, in this very channel :)
17:17:50 <Joel> Minneapolis
17:18:03 <skg-net> I am not able to get to the tests as promised, little tied up with the current module developments..
17:18:25 <skg-net> Hopefully next week, will be able to start...
17:18:35 <gundalow> skg-net: Thanks for the update. PR process always takes longer than expected
17:18:52 <skg-net> Thanks to @mattclay for providing support for setting up the test enviroment
17:19:25 <gundalow> skg-net: If you'd like extra eyes on the reviews, please add them to https://github.com/ansible/community/issues/114
17:20:02 <skg-net> ok
17:22:51 <gundalow> Do people think it would be helpful for me to add my initial thoughts of a task list/plan for a plan to https://public.etherpad-mozilla.org/p/ansible-testing-working-group ?
17:23:09 <Joel> absolutely
17:23:12 <gundalow> If so what type of thing would people like to see
17:25:15 <gundalow> for example would detailing the tasks of how we go from our current developing_modules.html to a much improved version
17:27:05 * gundalow will do so
17:27:15 <gundalow> Anyone got anything else?
17:27:27 * shertel has nothing
17:28:41 <Joel> nadda
17:29:05 <gundalow> cool
17:29:21 <gundalow> Things will pick up once the 2.2 crazyness is out the way :)
17:29:48 <gundalow> As always thank you for your time and if you see anything please do add it to https://github.com/ansible/community/issues/114 and/or https://public.etherpad-mozilla.org/p/ansible-testing-working-group
17:29:58 <gundalow> We can only improve what we know about
17:30:07 <gundalow> Thank you all for your time today
17:30:10 <gundalow> #endmeeting