#ansible-meeting: Testing Working Group

Meeting started by gundalow at 17:00:06 UTC (full logs).

Meeting summary

    1. Agenda, as always https://github.com/ansible/community/issues/114 (gundalow, 17:00:36)
    2. work continues on Network integration tests (gundalow, 17:01:57)
    3. Test infrastructure has been stabilizing over the last week. Shippable will be deploying another release this weekend to resolve issues with webhook failures. (mattclay, 17:02:50)
    4. ansible-test has been updated to handle changes to module_utils more efficiently, which should speed up CI on PRs which need to make module_utils changes. (mattclay, 17:03:53)

  1. ansible-test to ignore file not in git ansible/ansible#20944 (gundalow, 17:19:28)
    1. https://github.com/ansible/ansible/pull/20944 (gundalow, 17:19:43)
    2. Not as simply as it first seems - PR only works for code-smell portion of sanity (gundalow, 17:48:59)
    3. The builtin target finders ('walk_sanity_targets for ex, iirc) need to be updated as well. (gundalow, 17:49:22)
    4. There's no `.git` directory on the "remote" instances when running ansible-test. (gundalow, 17:49:33)
    5. ACTION: mattclay To spend some time to write down the various issues around making this work, so we can do it for more than just code-smell. (gundalow, 17:49:53)
    6. The files to ignore could be anywhere in the directory tree (gundalow, 17:50:41)

  2. Open Floor (gundalow, 17:56:32)


Meeting ended at 17:58:58 UTC (full logs).

Action items

  1. mattclay To spend some time to write down the various issues around making this work, so we can do it for more than just code-smell.


Action items, by person

  1. mattclay
    1. mattclay To spend some time to write down the various issues around making this work, so we can do it for more than just code-smell.


People present (lines said)

  1. gundalow (31)
  2. mattclay (22)
  3. dag (20)
  4. alikins (13)
  5. zodbot (4)
  6. nitzmahone (3)


Generated by MeetBot 0.1.4.