#ansible-meeting: Ansible Core Meeting

Meeting started by abadger1999 at 19:02:40 UTC (full logs).

Meeting summary

    1. Agenda, feel free to add things, esp if their any proposals you'd like to discuss tohttps://github.com/ansible/community/issues/150 (abadger1999, 19:04:30)

  1. Overall guidance on reformatting code that is *not* covered by pep8 (eg, Powershell). (abadger1999, 19:09:15)
    1. nitzmahone proposing that committers should currently strive not to rewrite powershell code to conform to any personal style (preserves attribution in git blame), just try to work with what's already there. Windows Working Group may make a proposal for set style guidelines in the future. (abadger1999, 19:15:07)
    2. +1: 4, 0:0, -1:0 for nitzmahone's proposal about powershell style-only changes. (abadger1999, 19:19:08)
    3. ACTION: nitzmah9one to write up decision on powershell coding style for the windows moduile checklist. (abadger1999, 19:19:49)

  2. open floor (abadger1999, 19:20:03)
  3. etc_hosts module (abadger1999, 19:20:47)
    1. ACTION: abadger will close PR with results ofthe vote that was taken on 09-Feb (abadger1999, 19:21:22)

  4. Wildcards inside of fileglob lookup: https://github.com/ansible/ansible/pull/19297 (abadger1999, 19:21:48)
  5. https://github.com/ansible/community/issues/150#issuecomment-277024953 win_file: fix error when creating an existing dir (abadger1999, 19:26:53)
    1. ACTION: nitzmahone to review ansible/ansible#19070 (win_file fix) this week (probably Thursaday) (abadger1999, 19:29:21)

  6. Extra metadata for non-module files (abadger1999, 19:30:50)
    1. abadger proposes that config files for dyn inventory use the same metadata as the dyn inventory script. (abadger1999, 19:33:38)
    2. there's one inventory script/config pair that doesn't match: consul.ini and consul_io.py (ryansb, 19:36:31)
    3. ACTION: ryansb rename consul.ini in repo, and search for both consul.ini and consul_io.ini in consul_io dynamic inventory (ryansb, 19:37:56)

  7. WIndows Working Group https://github.com/ansible/community/issues/150#issuecomment-280354753 (abadger1999, 19:44:30)
    1. Windows Working group will meet Monday afternoon and Friday morning US Pacific time (alternating weeks for the meeting times). (abadger1999, 19:47:32)
    2. ACTION: mattclay and nitzmahone to add time and dates to the public calendars (abadger1999, 19:47:54)

  8. Open Floor (abadger1999, 19:48:12)


Meeting ended at 19:51:47 UTC (full logs).

Action items

  1. nitzmah9one to write up decision on powershell coding style for the windows moduile checklist.
  2. abadger will close PR with results ofthe vote that was taken on 09-Feb
  3. nitzmahone to review ansible/ansible#19070 (win_file fix) this week (probably Thursaday)
  4. ryansb rename consul.ini in repo, and search for both consul.ini and consul_io.ini in consul_io dynamic inventory
  5. mattclay and nitzmahone to add time and dates to the public calendars


Action items, by person

  1. mattclay
    1. mattclay and nitzmahone to add time and dates to the public calendars
  2. nitzmahone
    1. nitzmahone to review ansible/ansible#19070 (win_file fix) this week (probably Thursaday)
    2. mattclay and nitzmahone to add time and dates to the public calendars
  3. ryansb
    1. ryansb rename consul.ini in repo, and search for both consul.ini and consul_io.ini in consul_io dynamic inventory
  4. UNASSIGNED
    1. nitzmah9one to write up decision on powershell coding style for the windows moduile checklist.
    2. abadger will close PR with results ofthe vote that was taken on 09-Feb


People present (lines said)

  1. abadger1999 (68)
  2. nitzmahone (23)
  3. bcoca (14)
  4. ryansb (14)
  5. zodbot (7)
  6. jtanner (7)
  7. mattclay (3)
  8. daBONDi (1)
  9. gundalow (1)
  10. shertel (1)
  11. Qalthos (0)
  12. jimi|ansible (0)
  13. rcarrillocruz (0)
  14. alikins (0)
  15. thaumos (0)


Generated by MeetBot 0.1.4.