#ansible-meeting: Network Working Group

Meeting started by gundalow at 16:02:11 UTC (full logs).

Meeting summary

    1. Agenda, feel free to add items (gundalow, 16:03:05)
    2. Agenda, feel free to add items https://github.com/ansible/community/issues/110 (gundalow, 16:03:14)

  1. Core Update (gundalow, 16:03:28)
    1. Ansible RC1 will be released very shortly, expect email to the Google Mailing lists in the next hour or so (gundalow, 16:04:02)
    2. Ansible 2.3 Networking: We’ve introduced new performance upgrades and additional vendor support. For more information about what’s new with Ansible Networking, take a look at https://www.ansible.com/blog/networking-features-in-ansible-2-3 (gundalow, 16:04:39)
    3. Lots of new Modules, 267 network modules, thanks to everyone that's help with that http://docs.ansible.com/ansible/list_of_network_modules.html (gundalow, 16:05:33)
    4. We are tracking a handful of issues for this release candidate that we expect to have fixed by the time we release version 2.3; you can monitor the list of known issues https://github.com/ansible/ansible/issues?utf8=%E2%9C%93&q=is%3Aissue%20is%3Aopen%20milestone%3A2.3.0%20label%3Anetworking (gundalow, 16:06:40)
    5. Please do test RC1 when it's released, *any* issues please raise in GitHub (gundalow, 16:07:01)
    6. Unless there is a bug raised, the issue doesn't exist :) (gundalow, 16:17:53)
    7. ACTION: gundalow to get some wording generated about how the new ephemeral state modules and why that means we split things into smaller modules (ios_config -> ios_banner) (gundalow, 16:22:43)

  2. Network Documentation (gundalow, 16:24:22)
    1. we know we've spent a lot of time in 2.3 improving how the modules can be used, though with a few late blocks of refactoring this has taken time away from adding in more documentation about how to use the modules (gundalow, 16:25:25)
    2. We have (hopefully) make the `provider:` option easier, this change https://gist.githubusercontent.com/gundalow/4bdc3669d696268328ccc18528cc6718/raw/98ce795a41035810133228ebc747ed201911ca21/nested-provider.png should be being live on docs.ansible.com later today (gundalow, 16:26:31)
    3. in 2.3 you don't need to give `provider`, we will support network modules, ssh keys & inventory files in the usual way we do with Linux machines (gundalow, 16:28:58)
    4. Network modules will need to be updated to take advantage of Persistent Connection (gundalow, 16:36:09)
    5. for 2.3 the modules that ship with Ansible will support Persistent Connect: eos_*, ios_*, iosxr_*, junos_*, and vyos_*. (gundalow, 16:38:19)
    6. sros_* also, but that's not in RC1 (gundalow, 16:38:36)
    7. Some of the nxos_* modules, but not all (their are a lot of them) (gundalow, 16:38:52)
    8. WIP for debug guide https://github.com/gundalow/ansible/blob/bcf6934c3eb1a85f607f4e1210c28c242c0bc767/docs/docsite/rst/network_debug_troubleshooting.rst (gundalow, 16:41:15)
    9. Default (without provider (or transport)) is ssh, you can still specify `transport: eapi` (or `provider:\n transport: eapi`) (gundalow, 16:43:03)

  3. Module changes (gundalow, 16:51:27)
    1. This (smaller specific modules) has always been the long term plan to start with the overall config first and then start to seed more specific stateful modules (gundalow, 16:52:29)
    2. Its a natural evolution of how we plan to support network devices, for some features (such as banners) we can better support it in a specific module as opposed to a more generic config module. (gundalow, 16:53:05)
    3. Longer term we want to be able to support a role call "banner" (for instance) that can abstract away the device os (gundalow, 16:53:26)

  4. Open Floor (gundalow, 16:54:39)


Meeting ended at 17:04:39 UTC (full logs).

Action items

  1. gundalow to get some wording generated about how the new ephemeral state modules and why that means we split things into smaller modules (ios_config -> ios_banner)


Action items, by person

  1. gundalow
    1. gundalow to get some wording generated about how the new ephemeral state modules and why that means we split things into smaller modules (ios_config -> ios_banner)


People present (lines said)

  1. gundalow (95)
  2. kennc (33)
  3. epicdean (19)
  4. rcarrillocruz (5)
  5. stacywsmith (4)
  6. zodbot (4)
  7. echou (3)
  8. skg-net (3)
  9. dkasberg (1)
  10. Qalthos (0)


Generated by MeetBot 0.1.4.