#ansible-meeting: Ansible Core Team Meeting

Meeting started by jtanner at 19:00:27 UTC (full logs).

Meeting summary

  1. using raw strings for documenation (jtanner, 19:04:59)
    1. ACTION: no requirements, but should add a hint in docs (jtanner, 19:08:12)

  2. Ansible Contributor Summit 4 (Part of AnsibleFest 2017 London) (jtanner, 19:08:40)
    1. Please add topics and final voting (+1/-1) to https://public.etherpad-mozilla.org/p/ansible-summit-june-2017 (gundalow, 19:10:36)

  3. https://github.com/ansible/ansible/pull/24822 (jtanner, 19:13:03)
    1. akasurde tested PR with downgrade + upgrade pattern (jtanner, 19:15:15)
    2. ACTION: akasurde to write integration test (jtanner, 19:15:32)

  4. https://github.com/ansible/ansible/pull/24867 (jtanner, 19:16:47)
    1. ACTION: decide on action for PR and provide sufficient reasoning (jtanner, 19:22:39)

  5. https://github.com/ansible/ansible/pull/24871 (jtanner, 19:23:21)
    1. ACTION: vote results were "yes" at last meeting (jtanner, 19:25:22)

  6. https://github.com/ansible/ansible/issues/25053 (jtanner, 19:26:05)
    1. https://github.com/ansible/ansible/issues/25092 (willthames, 19:26:43)
    2. https://github.com/ansible/ansible/issues/22397 (bcoca, 19:30:10)
    3. https://groups.google.com/d/msg/ansible-project/W_zIjyhCFPg/eLrTWO4XCgAJ (bcoca, 19:30:38)
    4. https://github.com/ansible/ansible/commit/4594bee65ae made it far worse (willthames, 19:34:54)
    5. ACTION: discussion tabled for the next meeting sivel is able to attend (jtanner, 19:44:07)
    6. https://github.com/ansible/ansible/pull/24974 (bcoca, 19:44:35)
    7. https://github.com/ansible/ansible/issues/22397 (bcoca, 19:44:46)
    8. https://groups.google.com/d/msg/ansible-devel/tjIpsz8VDtY/KEp1qwR6AAAJ (bcoca, 19:45:27)
    9. bcoca proposed merging 25092 (do not warn when a variable itself contains a template) now and discussing removal of warning at later meeting. (abadger1999, 19:47:09)
    10. ACTION: https://github.com/ansible/ansible/pull/25092 merged (jtanner, 19:49:03)
    11. ACTION: decide on action for PR and provide sufficient reasoning (jtanner, 19:50:44)

  7. https://github.com/ansible/ansible/pull/24846 (jtanner, 19:52:44)
    1. mikedlr wants PR feedback (jtanner, 19:52:56)
    2. apt module has no maintainers outside of the core team (jtanner, 19:57:20)
    3. related issue https://github.com/ansible/ansible/issues/24673 (jtanner, 20:08:26)
    4. related PR https://github.com/ansible/ansible/pull/24703 (jtanner, 20:09:06)
    5. ACTION: bcoca merged PR (jtanner, 20:09:59)
    6. ACTION: mikedlr to open bugs on refactoring possibilities so they can be marked needs_contributor (jtanner, 20:11:49)

  8. https://github.com/ansible/ansible/pull/24867 (jtanner, 20:13:49)
    1. cycling back to topic for dag (jtanner, 20:14:03)
    2. https://meetbot.fedoraproject.org/ansible-meeting/2017-05-25/ansible_core_meeting.2017-05-25-15.00.log.html from 15:16:00 onwards (willthames, 20:16:37)
    3. ACTION: dag to remove cosmetic changes in PR and follow up on ansible-devel (jtanner, 20:25:30)

  9. supported_by field in aws modules (jtanner, 20:27:12)
    1. willthames would like aws modules to be "community" supported (jtanner, 20:29:18)
    2. https://github.com/ansible/ansible/pull/24080 (willthames, 20:34:13)
    3. https://github.com/ansible/ansible/pull/25126 (willthames, 20:36:14)
    4. ACTION: abadger1999 to add willthames committer review to next internal team meeting (jtanner, 20:44:55)


Meeting ended at 20:49:18 UTC (full logs).

Action items

  1. no requirements, but should add a hint in docs
  2. akasurde to write integration test
  3. decide on action for PR and provide sufficient reasoning
  4. vote results were "yes" at last meeting
  5. discussion tabled for the next meeting sivel is able to attend
  6. https://github.com/ansible/ansible/pull/25092 merged
  7. decide on action for PR and provide sufficient reasoning
  8. bcoca merged PR
  9. mikedlr to open bugs on refactoring possibilities so they can be marked needs_contributor
  10. dag to remove cosmetic changes in PR and follow up on ansible-devel
  11. abadger1999 to add willthames committer review to next internal team meeting


Action items, by person

  1. abadger1999
    1. abadger1999 to add willthames committer review to next internal team meeting
  2. akasurde
    1. akasurde to write integration test
  3. bcoca
    1. bcoca merged PR
  4. dag
    1. dag to remove cosmetic changes in PR and follow up on ansible-devel
  5. mikedlr
    1. mikedlr to open bugs on refactoring possibilities so they can be marked needs_contributor
  6. sivel
    1. discussion tabled for the next meeting sivel is able to attend
  7. willthames
    1. abadger1999 to add willthames committer review to next internal team meeting
  8. UNASSIGNED
    1. no requirements, but should add a hint in docs
    2. decide on action for PR and provide sufficient reasoning
    3. vote results were "yes" at last meeting
    4. https://github.com/ansible/ansible/pull/25092 merged
    5. decide on action for PR and provide sufficient reasoning


People present (lines said)

  1. jtanner (188)
  2. bcoca (89)
  3. willthames (83)
  4. abadger1999 (26)
  5. mikedlr (24)
  6. dag (23)
  7. sivel (16)
  8. zodbot (14)
  9. shertel (14)
  10. gundalow (7)
  11. akasurde (5)
  12. dharmabumstead (3)
  13. Pilou (3)
  14. ryansb (1)
  15. funzo (1)
  16. nitzmahone (1)


Generated by MeetBot 0.1.4.