#ansible-meeting: Testing Working Group
Meeting started by mattclay at 17:02:34 UTC
(full logs).
Meeting summary
-
- :) (gundalow,
17:05:13)
- We have a new "import" sanity test in
ansible-test and CI now. It will detect imports of python modules
not in the standard library in either modules or module_utils which
are not protected by a try/except block. (mattclay,
17:06:02)
- We will be extending this test to cover plugins
as well. (mattclay,
17:06:29)
- We will be dropping testing of Fedora 24 and 25
with python 2 on Shippable and adding Fedora 25 and 26 with python
3. (mattclay,
17:07:00)
- Replacing pep8 with pycodestyle (https://github.com/ansible/ansible/pull/25947) (mattclay, 17:09:06)
- ACTION: mattclay to
merge PR once CI passes (mattclay,
17:21:15)
- Community Wiki (https://github.com/ansible/community/issues/114#issuecomment-310875236) (mattclay, 17:22:11)
- Testing Wiki exists at
https://github.com/ansible/community/wiki/Testing (gundalow,
17:25:51)
- Existing files which don't pass the import
sanity test:
https://github.com/ansible/ansible/blob/devel/test/sanity/import/skip.txt
(mattclay,
17:30:41)
- Open Floor (mattclay, 17:34:36)
- https://codecov.io/gh/ansible/ansible/src/devel/lib/ansible/modules/system/ping.py
(mattclay,
17:35:07)
- https://github.com/ansible/community/wiki/Testing%3A-progress-tracker/_edit#fixing-broken-imports
added (gundalow,
17:39:16)
Meeting ended at 17:58:53 UTC
(full logs).
Action items
- mattclay to merge PR once CI passes
Action items, by person
- mattclay
- mattclay to merge PR once CI passes
People present (lines said)
- mattclay (69)
- gundalow (24)
- Pilou (20)
- zodbot (6)
- jtanner (6)
- abadger1999 (5)
- spredzy (5)
Generated by MeetBot 0.1.4.