#ansible-meeting: Testing Working Group
Meeting started by mattclay at 17:01:09 UTC
(full logs).
Meeting summary
-
- Agenda
https://github.com/ansible/community/issues/248 (mattclay,
17:01:47)
- We're now using our own Docker container on
Shippable for tests where we previously used their standard build
container. (mattclay,
17:06:41)
- This container can be used locally as well with
the `--docker default` option to `ansible-test`, such as
`ansible-test sanity --docker default`. (mattclay,
17:07:32)
- The container supports Python versions 2.6,
2.7, 3.5 and 3.6 (by default) so you can also use the `--python`
option. (mattclay,
17:08:33)
- Docker images are now pinned so new versions
must go through CI before being used. Previously a rebuild on Docker
Hub would cause them to be used immediately. (mattclay,
17:10:02)
- Handling of python and pip versions in
ansible-test has been corrected for many scenarios where it did not
previously work properly. (mattclay,
17:11:52)
- The pylint tests are now split up to run on
different parts of the codebase with different configs. Configs are
now at `test/sanity/pylint/config/`. (mattclay,
17:13:10)
- I'll be on PTO Friday and all next week. For
testing related issues, see gundalow. (mattclay,
17:13:31)
- requests_mock in unit tests: https://github.com/ansible/community/issues/248#issuecomment-338604885 (mattclay, 17:16:56)
- ACTION: sivel to
review https://github.com/ansible/ansible/pull/30767 (mattclay,
17:34:28)
- Open Floor (mattclay, 17:34:38)
Meeting ended at 18:03:29 UTC
(full logs).
Action items
- sivel to review https://github.com/ansible/ansible/pull/30767
Action items, by person
- sivel
- sivel to review https://github.com/ansible/ansible/pull/30767
People present (lines said)
- mattclay (44)
- mikedlr (26)
- sivel (24)
- abadger1999 (9)
- Pilou (8)
- zodbot (5)
- maxamillion (3)
- gundalow (2)
Generated by MeetBot 0.1.4.