17:01:04 <mattclay> #startmeeting Ansible Testing Working Group
17:01:04 <zodbot> Meeting started Thu Mar 14 17:01:04 2019 UTC.
17:01:04 <zodbot> This meeting is logged and archived in a public location.
17:01:04 <zodbot> The chair is mattclay. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:04 <zodbot> The meeting name has been set to 'ansible_testing_working_group'
17:01:38 <mattclay> #info Agenda: https://github.com/ansible/community/issues/248
17:02:04 <mattclay> #topic Zuul (https://github.com/ansible/community/issues/248#issuecomment-471685707)
17:02:10 <mattclay> #chair gundalow pabelanger
17:02:10 <zodbot> Current chairs: gundalow mattclay pabelanger
17:02:22 <mattclay> pabelanger: You're up.
17:02:27 <pabelanger> thanks!
17:03:08 <pabelanger> I mostly wanted to bring up the topic of zuul, because there are some things in the near future that will be changing on the current setup
17:03:28 <pabelanger> And, not to keep people in the dark, figured this working group might be a good place to better share the information
17:03:57 <pabelanger> For humans that haven't been following, for the last 9months I would say ansible-network has been using zuul for testing
17:04:23 <pabelanger> #link https://ansible-network.softwarefactory-project.io/zuul/status
17:04:41 <pabelanger> today, zuul is provided to us by the awesome humans in the softwarefactory team
17:05:28 <pabelanger> however, as we've used zuul for testing, we've run into some issues with where zuul is running today. Specifically, it is hosted in rdocloud right now
17:06:09 <pabelanger> about 2 months ago, we in ansible-network set forth to try and do a POC control plane in a public openstack cloud (vexxhost)
17:06:43 <pabelanger> so far, we've been pleased with the results of hosting zuul there, and now looking to move to the next step
17:07:18 <pabelanger> starting soon (hopefully in the next day or so) I'll be starting to provision a new zuul control plane there
17:07:29 <pabelanger> the end goal, will be to move ansible-network into it
17:07:39 <pabelanger> eventually, moving aws project too
17:07:52 <mattclay> pabelanger: What is aws project?
17:08:06 <pabelanger> sorry, awx project
17:08:15 <mattclay> Ah, OK. That makes more sense. :)
17:09:05 <pabelanger> working with gdk and robyn, there is longer term discussion to maybe onboard more community roles on to zuul for galaxy testing, however that isn't really in the current scope
17:10:12 <pabelanger> ideally, as we get more projects onto the platform, some humans from each project will be interested in helping operate the new zuul
17:10:39 <dmsimard> ohai, I happen to be a human working with ansible, zuul and software factory too o/
17:10:43 <pabelanger> right now, everything is 99.9% driven via automation (ansible) so there isn't much need for people to SSH into systems.
17:11:11 <pabelanger> but, I wanted to open the discussion to people, as I have glossed over a lot of information
17:11:33 <mattclay> #chair dmsimard
17:11:33 <zodbot> Current chairs: dmsimard gundalow mattclay pabelanger
17:11:44 <dmsimard> pabelanger: is that new control plane going to be deployed using windmill ?
17:11:56 <pabelanger> dmsimard: yes
17:12:51 <pabelanger> however, there are longer term talks about maybe moving zuul into k8s or openshift. Which would mean the deploying tooling might change a little
17:13:08 <pabelanger> but for now, it is VMs running on openstack public cloud in vexxhost
17:14:06 <pabelanger> currently, I believe we'll be using the eng.ansible.com sub-domain for location of zuul, so an end user would potentially use https://zuul.eng.ansible.com to access the dashboard
17:15:39 <dmsimard> pabelanger: ack, I'm sure the SF folks would appreciate a retrospective on what worked well and what didn't with SF so we can improve -- I'll reach out off meeting :)
17:15:52 <pabelanger> mattclay: gundalow: a question for you, where on IRC do you think it would be best to answer questions humans may have around zuul? Should we look to create #ansible-zuul / #ansible-testing, or some other infra specific place
17:16:11 <pabelanger> or is ansible-devel a good enough place?
17:16:42 <dmsimard> It looks like #ansible-testing is sort of a thing but mostly empty
17:16:50 <dmsimard> (presumably after the name of the working group)
17:17:00 <pabelanger> dmsimard: yes, I also agree we should give feedback
17:17:05 <gundalow> #ansible-test hasn't ever been used, I can set it up if needed
17:17:17 <mattclay> gundalow: You mean #ansible-testing, right?
17:17:18 <gundalow> I'd void for ansible-test(ing) or #ansible-devel
17:17:26 <gundalow> yes
17:17:39 <gundalow> s/void/vote/
17:18:01 <pabelanger> ansible-testing also works for me
17:18:06 <mattclay> I'd probably go for #ansible-devel over #ansible-testing until there's enough discussion going on to warrant use of a separate channel.
17:18:11 <gundalow> -1 to #ansible-zuul as I think the same set of people would be interested in testing more generally, and I think we'd end up discussing similar things
17:18:16 <gundalow> mattclay: sound sgood
17:18:25 <pabelanger> sure, ansible-devel then
17:18:32 <mattclay> But when we do need a channel, I agree it should be #ansible-testing
17:19:16 <gundalow> #agreed We will continue to use #ansible-devel for all testing related discussion. If in the future we find there is a lot of discussion we can move to #ansible-testing
17:19:43 <pabelanger> so, next steps on myside is to rebuild the POC control plane into proper vexxhost account, and configure correct DNS entries. This likely will take a few days
17:19:50 <gundalow> Cool
17:20:26 <pabelanger> once that is finished, ansible-network will be the first projects to move into it. Once we validate everything is working correctly, we'll then work with awx team and migrate them
17:21:08 <pabelanger> lastly, we'll also be moving DCI tests for ansible-network into zuul, which will take some time, but should give us more feedback to new PRs that are being created in ansible/ansible
17:21:58 <pabelanger> I suspect there will be some questions from me over the coming days, so if gundalow, mattclay, you'd like to keep an eye out. It will mostly be around the possible creation of git repos, and new github app we'll be using
17:22:44 <gundalow> Sure
17:22:51 <pabelanger> And like I mentioned, I'm happy to sit down with other humans that would like to learn more about how to operate a zuul.
17:23:41 <pabelanger> that's all I had to share ATM, if no questions
17:26:32 <gundalow> pabelanger: FYI I have GitHub Org admin on gh/ansible-network but not gh/ansible that's mattclay. I do have admin on ansible-lint, molecule, galaxy. Though that's all lower priority
17:26:43 <gundalow> Thanks for doing all of this, really looking forward to it
17:27:19 <pabelanger> ++
17:27:34 <mattclay> Does anyone else have something they'd like to discuss?
17:27:51 <pabelanger> I did have a non zuul item I wanted help with
17:29:06 <pabelanger> One of the things we have been talking about in ansible-network, is what our functional testing stragegy is going to look like moving forward
17:29:34 <pabelanger> this is things like running tests against cisco_ios, juniper, etc, for partners
17:29:54 <mattclay> #topic ansible-network testing
17:30:34 <pabelanger> I wanted to see if maybe gundalow or mattclay were at all interested in being looped into some of this design discussion, because we are looking to apply it across the board to all role / modules / etc that partners would be creating
17:30:57 <gundalow> Yup, please loop me in
17:30:58 <pabelanger> the issue here, is that not all platforms support all the same things
17:31:15 <gundalow> FYI I'm looking at Testing for Collections as well as Certified Content
17:31:26 <pabelanger> so, it is almost like we need to create a minimal amount of functional testing that all vendors should do
17:31:47 <mattclay> Yes, I'd like to be included as well.
17:31:54 <pabelanger> okay great
17:32:32 <pabelanger> I'll go back to our team, and see who else is interested and maybe start work on a high level etherpad
17:33:46 <pabelanger> that is all I had for now
17:34:02 <mattclay> #topic Open Floor
17:34:07 <gundalow> Ace
17:34:10 <gundalow> Nothing else from me
17:34:20 <gundalow> Oh, though I guess semi-related
17:34:43 <gundalow> Molecule pre-release of 2.20 is out. Think we've got just two things to fix before 2.20 final
17:40:17 <mattclay> #endmeeting