15:09:41 <sdoran> #startmeeting Ansible Core Public IRC Meeting https://github.com/ansible/ansible/issues/64564
15:09:41 <zodbot> Meeting started Thu Nov 21 15:09:41 2019 UTC.
15:09:41 <zodbot> This meeting is logged and archived in a public location.
15:09:41 <zodbot> The chair is sdoran. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:09:41 <zodbot> The meeting name has been set to 'ansible_core_public_irc_meeting_https://github.com/ansible/ansible/issues/64564'
15:10:18 <sdoran> Paste buffer fail. :(
15:10:23 <sdoran> Anywho
15:10:28 <shertel> Hi
15:10:32 <sivel> that issue gets it's own meeting ;)
15:10:35 <sdoran> #topic https://github.com/ansible/ansible/pull/65014
15:10:54 <sdoran> felixfontein: are you around?
15:10:59 <sdoran> #chair shertel sivel
15:10:59 <zodbot> Current chairs: sdoran shertel sivel
15:12:34 <sdoran> Alright, we'll move on to miouge's PRs since felixfontein doesn't seem to be around.
15:12:42 <sdoran> #topic https://github.com/ansible/ansible/pull/55989
15:12:52 <Miouge> Great :)
15:13:11 <sdoran> Miouge: What would you like to discuss about these PRs?
15:14:12 <Miouge> Those 2 PRs are kind of stuck in lymbo. People recommended me to bring it up here to get things moving (get feedback, see what needs to change, and maybe eventually merging :D)
15:14:27 <shertel> Miouge: why isn't that using the constructed doc fragment?
15:15:13 <felixfontein> sorry, was afk, now I'm here :)
15:15:26 <sdoran> felixfontein: Ok, we'll get back to you in a bit.
15:15:28 <shertel> Ah, bcoca had a comment about that, which may have been true at the time. But you should be able to use constructed now
15:15:44 <felixfontein> sdoran: no worries, I originally thought I wouldn't be anywhere close to a keyboard right now anyway :)
15:16:24 <Miouge> Sure, I can rework the doc part to use constructed doc fragments (https://docs.ansible.com/ansible/latest/dev_guide/developing_modules_documenting.html#documentation-fragments I suppose ?). Anything else I should look into?
15:17:31 <sdoran> Do we have any way to add tests for these new inventory plugins?
15:17:58 <shertel> Miouge: Yes, that's it.
15:18:09 <sdoran> #action miouge to use constructed doc fragment in PR #55989
15:19:18 <Miouge> Don’t know about the CI of inventory plugins. the openstack one has the opendev zuul CI jobs triggering on ansible PRs that touch that file
15:21:42 <shertel> Miouge: It looks like this is this a plugin version of the packet_net.py contrib script?
15:21:58 <shertel> (https://github.com/ansible/ansible/blob/devel/contrib/inventory/packet_net.py)
15:22:39 <Miouge> Yes, I’m aware of that contrib script. I’ve been told that the inventory plugins was the way to go
15:23:18 <sdoran> Do we have any reservations  about merging a new inventory plugin with no tests?
15:23:20 <shertel> I don't think tower supports that contrib script, but we've had to rework some of the other plugins so that backward compatibility can be achieved
15:23:34 <sdoran> We end up being on the hook to support these, usually. At least that's how inventory scripts played out.
15:25:42 <shertel> Yes, that's how it plays out. If we need to keep backwards compatibility then we need tests. If it's greenfield, I'm not aware of a policy about not merging new inventory plugins until they have tests (tests are great though)
15:26:03 <sdoran> We don't have a policy, I was just bringing it up.
15:26:07 <Miouge> Regarding CI, I think Packet can provide test accounts with API keys etc… (they’ve done so in other projects), but that opens a bunch of other questions (usage limits etc…)
15:26:18 <sdoran> Yup.
15:26:54 <shertel> Miouge: we mocked the AWS api for the aws_ec2 inventory plugin, so that's a possibility
15:26:56 <shertel> https://github.com/ansible/ansible/tree/devel/test/integration/targets/inventory_aws_conformance
15:27:26 <Miouge> Oh, interesting!
15:29:11 <shertel> here's another example for the gcp plugin https://github.com/ansible/ansible/pull/54701
15:29:59 <Miouge> Sounds good, I can try that.
15:30:23 <shertel> +1
15:30:43 <sdoran> #action miogue to add integration tests that mock the Packet API for PR #55989
15:31:21 <sdoran> #topic https://github.com/ansible/ansible/pull/55965
15:31:29 <sdoran> Miouge: Anything in particular on this one?
15:32:23 <Miouge> Nothing special, just what else do I need to get it merged?
15:33:20 <shertel> did the openstacksdk version requirement change, or was it >= 0.28 before and just undocumented?
15:33:44 <Miouge> Not documented before, the all_project parameter was added in 0.28
15:34:17 <Miouge> See https://github.com/openstack/openstacksdk/commit/bc0cff52c002609f86b9046b01948d8a1be1fdf8
15:34:53 <shertel> Ok, cool. Looks good to merge to me, doing so.
15:35:06 <sdoran> 👍
15:35:20 <sdoran> #topic https://github.com/ansible/ansible/pull/65014
15:35:23 <sdoran> felixfontein: back to you
15:35:28 <Miouge> \o/
15:35:41 <felixfontein> yay :)
15:36:03 <felixfontein> I tried to describe the situation in the backport PR summary
15:36:34 <felixfontein> when we adjusted modules to use the same names for TLS connection parameters for Ansible 2.8, we accidentally destroyed a feature in pulp_repo
15:39:14 <felixfontein> the main question is: fixing the situation involves doing things that usually aren't backportable :)
15:39:26 <felixfontein> (sorry got side-tracked)
15:41:27 <felixfontein> the solution merged for 2.10 (i.e. in devel) adds new options (which take the old aliases, importer_ssl_*), and uses the standardized ssl names as a fallback. this way backwards compatibility is preserved (even with the broken behavior), but the user can use the new options to avoid breakage
15:41:46 <shertel> I would be okay with backporting that. The RM should probably be involved too.
15:41:47 <felixfontein> and when the module was used as in 2.7.x, it will still work with this PR
15:42:06 <felixfontein> shertel: I would have asked, but there currently is no specific one I think?
15:42:09 <felixfontein> brb
15:42:59 <shertel> two temporary RMs, but it's early still on the US west coast
15:49:01 <sdoran> I would leave that PR open and it can be discussed once the RM reviews it for merge.
15:49:28 <sdoran> #topic https://github.com/ansible/ansible/pull/59060
15:51:45 <sdoran> Anyone have thoughts on this one?
15:53:03 <shertel> still reading context
15:53:58 <felixfontein> sorry, had some RL interactions :)
15:55:42 <shertel> seems helpful, does it need reviews?
15:56:33 <sdoran> Seems ok to me.
15:56:44 <felixfontein> I'm sure it would be better if someone could review it :) but I think it should work (and it seems to work)
15:58:22 <sdoran> I'll review it. It looks mostly ok. I have a few minor questions.
15:58:42 <sdoran> #topic https://github.com/ansible/ansible/pull/64959
15:59:05 <sdoran> This issue has not been triaged yet, so it's probably premature to discuss it here.
15:59:13 <bidord> Hi
15:59:20 <bidord> ok
16:00:11 <felixfontein> sdoran: ok. when is the triage meeting usually?
16:00:26 <felixfontein> (in case it has a fixed time per week)
16:02:13 <sdoran> Tuesday at 1500 UTC and Thursday at 1900 UTC.
16:02:37 <sdoran> So we will look at that issue in a few hours.
16:02:44 <felixfontein> ok, sounds good :)
16:03:02 <sdoran> bidord: If you still would like to discuss it after we triage it and add comments, please add it to the meeting agenda again.
16:03:17 <bidord> sdoran: ok thanks, will do!
16:03:28 <sdoran> Thank you everyone for attending today.
16:03:30 <sdoran> #endmeeting