#ansible-meeting: Ansible Core Public IRC Meeting

Meeting started by Shrews at 19:00:50 UTC (full logs).

Meeting summary

    1. Agenda: https://github.com/ansible/community/issues/570 (Shrews, 19:01:05)

  1. Add filter dict (Shrews, 19:02:24)
    1. https://github.com/ansible/ansible/pull/72413 (Shrews, 19:02:30)
    2. https://docs.ansible.com/ansible/latest/user_guide/complex_data_manipulation.html#create-dictionary-from-list (bcoca, 19:13:42)
    3. AGREED: rejecting 72413 for inclusion in core, propose pushing to a collection (Shrews, 19:21:11)

  2. hosts: reference parent groups from children (makes copy/pastes easy) (Shrews, 19:21:22)
    1. zip filters can mostly do same (bcoca, 19:21:30)
    2. AGREED: suggest looking into a custom inventory plugin and research existing plugins (Shrews, 19:27:53)

  3. Empty value of --limit should raise an error (or at least be no-op) (Shrews, 19:28:01)
    1. AGREED: empty `limit` is valid and likely relied on by others. Suggest external validation for empty vars supplied to it. (Shrews, 19:32:58)

  4. Playbooks: Inventory variables should override playbook lever variables by default (Shrews, 19:33:12)
    1. https://github.com/ansible/ansible/issues/63668 (Shrews, 19:33:20)
    2. ansible_limit var is avaiable to play (bcoca, 19:33:21)
    3. one reason for this long established var precedence is to bootstrap the common user (Shrews, 19:40:09)

  5. Allow custom success/failure message (should work with no_log: true) (Shrews, 19:40:17)
  6. Roles: A variable should not be passed to a role unless specified in a “spec” file (Shrews, 19:49:03)
  7. update on internal `plugin_utils` discussion (Shrews, 19:53:43)
  8. Open floor (Shrews, 19:57:48)


Meeting ended at 20:00:26 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. bcoca (88)
  2. Stas55 (50)
  3. Shrews (49)
  4. nitzmahone (39)
  5. sivel (19)
  6. zodbot (7)
  7. felixfontein (5)
  8. mattclay (2)
  9. sdoran (2)


Generated by MeetBot 0.1.4.