#ansible-molecule: Ansible Molecule Working Group

Meeting started by gundalow at 19:00:01 UTC (full logs).

Meeting summary

    1. Firstly, thank you. I've been really impressed to see the continued level of discussion and helping in here, the PRs and mailing lists, etc (gundalow, 19:07:24)
    2. House Keeping (gundalow, 19:07:46)
    3. agenda https://github.com/ansible/community/issues/427 Feel free to add things as you see fit (gundalow, 19:08:03)
    4. This is meant to be informal and interactive, though we try and keep on one topic at a time to make it easier for people to follow (gundalow, 19:08:19)
    5. As some of you maybe new to the Ansible Community, I invite you to read the Code of Conduct https://docs.ansible.com/ansible/devel/community/code_of_conduct.html This community only works because you people. It's easy in text for things to come across in a way they were not intended. Go above and beyond to promote a collaborative and respectful community. (gundalow, 19:09:39)
    6. for example on a review saying `Would this be clearer if...` - invites discussion (gundalow, 19:09:46)
    7. For guidance on how to give good code reviews, I personally really like http://sage.thesharps.us/2014/09/01/the-gentle-art-of-patch-review/ (gundalow, 19:09:52)
    8. I know some people have been (previously) using Molecule as the unofficial Ansible Docker Image. We are having some discussions internally at the moment about how we want to do this, and move that out of Molecule (gundalow, 19:12:43)

  1. Molecule Releases (gundalow, 19:15:32)
    1. I know we haven't done a Molecule release since Red Hat became the maintainer. Lots of work has gone into adding CI and tidying up things (gundalow, 19:18:07)
    2. There isn't a date say for the next Molecule Release, though we are using https://github.com/ansible/molecule/milestones to track what's needed (gundalow, 19:18:30)
    3. ACTION: If people think their are unmerged PRs/Issues that should be included in that release please let me know (gundalow, 19:18:56)
    4. https://github.com/ansible/molecule/pull/1698 -- could fix recurrent travis fail due to timeout on python 2 builds (themroc, 19:19:35)
    5. We may get back to ~monthly releases. So it's a balance between what's blocking/adds a lot of value vs keep on pushing back the release (gundalow, 19:21:53)
    6. Every merge into `master` is available via PyPi (I just can't remember the syntax) (gundalow, 19:23:34)
    7. https://github.com/ansible/molecule/pull/1695 -- fix the actual lint errors (themroc, 19:24:35)
    8. https://github.com/ansible/molecule/pull/1691/files -- nice to have (themroc, 19:27:19)
    9. https://github.com/ansible/molecule/pull/1659 Disable YAML lint truthy rule by default (gundalow, 19:29:24)
    10. https://github.com/ansible/molecule/pull/1683 -- documentation (themroc, 19:29:37)
    11. ACTION: gundalow to make a note that we may need RHEL (without EPEL) specific install docs. `SCL`, gcc+ headers (gundalow, 19:42:03)
    12. ACTION: sdoran to fix test for 1659, gundalow will merge once green (gundalow, 19:43:36)
    13. AGREED: 160chars for all the linters then: flake8, yamllint, ansible-lint (gundalow, 19:46:55)
    14. https://github.com/ansible/molecule/issues/1699 (themroc, 19:49:15)

  2. Backlog (gundalow, 19:49:50)
    1. Some great work has been done already in https://etherpad.openstack.org/p/ansible-molecule on Triage (currently startong on line 28) (gundalow, 19:50:31)
    2. ACTION: If people have some spare time to have a look at the backlog of Issues and PRs that would be ace. There are most likely some older items that we can close (gundalow, 19:52:13)
    3. https://docs.ansible.com/ansible/devel/dev_guide/developing_python_3.html#minimum-version-of-python-3-x-and-python-2-x (gundalow, 20:06:15)

  3. Open Floor (gundalow, 20:11:06)
    1. This has been really good, thank you all for your time. I hope people have found it useful. Feel free to ping me in here (or directly) if you have any feedback, always looking for suggestions (gundalow, 20:12:16)


Meeting ended at 20:13:44 UTC (full logs).

Action items

  1. If people think their are unmerged PRs/Issues that should be included in that release please let me know
  2. gundalow to make a note that we may need RHEL (without EPEL) specific install docs. `SCL`, gcc+ headers
  3. sdoran to fix test for 1659, gundalow will merge once green
  4. If people have some spare time to have a look at the backlog of Issues and PRs that would be ace. There are most likely some older items that we can close


Action items, by person

  1. gundalow
    1. gundalow to make a note that we may need RHEL (without EPEL) specific install docs. `SCL`, gcc+ headers
    2. sdoran to fix test for 1659, gundalow will merge once green
  2. sdoran
    1. sdoran to fix test for 1659, gundalow will merge once green
  3. UNASSIGNED
    1. If people think their are unmerged PRs/Issues that should be included in that release please let me know
    2. If people have some spare time to have a look at the backlog of Issues and PRs that would be ace. There are most likely some older items that we can close


People present (lines said)

  1. gundalow (110)
  2. bcoca (34)
  3. themroc (31)
  4. ericsysmin (25)
  5. sdoran (21)
  6. loomsen (20)
  7. fabianvf (15)
  8. zodbot (10)
  9. tima (9)
  10. awcrosby (4)
  11. alongchamps (3)
  12. webknjaz (2)
  13. themr0c (1)
  14. newswangerd (0)


Generated by MeetBot 0.1.4.