19:00:20 <gundalow> #startmeeting Ansible Molecule Working Group
19:00:20 <zodbot> Meeting started Wed Feb  6 19:00:20 2019 UTC.
19:00:20 <zodbot> This meeting is logged and archived in a public location.
19:00:20 <zodbot> The chair is gundalow. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:20 <zodbot> The meeting name has been set to 'ansible_molecule_working_group'
19:00:20 <themroc> i am sorry that https://github.com/ansible/molecule/pull/1691 is breaking the ci by turning on skipped tests (because necessary libraries get installed)
19:00:47 <fabianvf> WOO LETS GO
19:00:58 <gundalow> Who's around?
19:01:11 <themroc> \o<
19:01:12 <decentral1se> me, made it this time :)
19:02:49 <gundalow> #chair themroc fabianvf Pilou decentral1se
19:02:49 <zodbot> Current chairs: Pilou decentral1se fabianvf gundalow themroc
19:03:00 <awcrosby> o/
19:03:06 <gundalow> #info https://github.com/ansible/community/issues/427
19:03:38 <gundalow> fabianvf: Do you have PR you'd like reviewed, or something to discuss?
19:03:57 <fabianvf> yep one sec
19:03:57 <gundalow> #topic Molecule CI
19:04:06 <gundalow> fabianvf: cool, will come to it after this topic
19:04:07 <decentral1se> yeah, there's a lot on the agenda
19:04:14 <decentral1se> but we should discuss CI again to try to close it off
19:04:17 <gundalow> +1
19:05:03 <gundalow> Please correct me if I get any of this wrong, is CI for PRs (ie not Cron) apart from testing `devel`https://github.com/ansible/molecule/issues/1727
19:05:03 <decentral1se> so, AFAIK, it's just setting allowed failures for things affected by ansible-devel issue
19:05:06 <decentral1se> and the PR from themroc?
19:06:41 <gundalow> So to address Compatibility with Ansible devel (2.8) broken #1727, do we want to do as Pilou suggested above and just disable it for the moment?
19:06:56 <decentral1se> +1
19:07:31 <fabianvf> It could be more useful to leave it enabled but not allow it to fail the build, in order to monitor the issue
19:08:32 * gundalow doesn't have a preference, anyone want to raise a PR for either solution?
19:09:01 <decentral1se> we can still monitor, but this will just make it easier for us to reason about the state of the CI for other contributions
19:09:41 <themroc> am sorry that https://github.com/ansible/molecule/pull/1691 is breaking the ci by turning on skipped tests (because necessary libraries get installed), better keep it unmerged for the moment
19:09:41 <gundalow> I think it's just commenting out https://github.com/ansible/molecule/blob/master/.travis.yml#L306-L367
19:10:29 <themroc> there is the fail to deploy to pip issue cf https://travis-ci.com/ansible/molecule/jobs/175744500
19:10:39 <decentral1se> well, we'd like it to still run, I suppose. I'll get a PR in for this and let's see
19:11:03 <fabianvf> this is the doc I was looking at: https://docs.travis-ci.com/user/customizing-the-build#rows-that-are-allowed-to-fail
19:11:30 <gundalow> decentral1se: you going to take the `devel` issue?
19:11:31 <themroc> gundalow: other possibility is desactivate the cron, as devel is only tested during cron ?
19:11:42 <decentral1se> gundalow: yep
19:12:08 <gundalow> themroc: good question, looking at Travis
19:12:21 <zbr> why devel is tested only with cron?
19:12:38 <gundalow> #chair zbr
19:12:38 <zodbot> Current chairs: Pilou decentral1se fabianvf gundalow themroc zbr
19:12:41 <decentral1se> probably to have some indication of issues
19:12:47 <decentral1se> it shouldn't fail builds though
19:12:53 <gundalow> Cron job: https://travis-ci.com/ansible/molecule/builds/99566825 looks like Ansible 2.5, 2.6, 2.7, devel
19:13:04 <zbr> i would find it more useful to have non-voting stage, but always running.
19:13:37 <gundalow> `devel` can be broken (it's not releases) so it can be "noisy" to have broken pre-released Ansible Devel causing issues on unreleated Ansible PRs
19:13:49 <zbr> because if you do not include it in a normal PR, there is a high risk that a change would break devel even more.
19:14:00 <gundalow> #action decentral1se to make `devel` none voting
19:14:43 <gundalow> Thanks for offering to do that decentral1se :)
19:15:01 <decentral1se> np
19:15:17 <gundalow> What other failing/instabilities are we seeing with CI at the moment?
19:15:56 <decentral1se> That's it, no?
19:16:05 <decentral1se> (there are a bunch of skipped tests, but we'll get there ...)
19:16:16 <gundalow> https://travis-ci.com/ansible/molecule/jobs/175744500
19:16:16 <gundalow> > /home/travis/build/ansible/molecule/.tox/metadata-validation/lib/python3.7/site-packages/readme_renderer/markdown.py:38: UserWarning: Markdown renderers are not available. Install 'readme_render[md]' to enable Markdown rendering.
19:16:20 <gundalow> from themroc
19:17:03 <themroc> "PyPI upload failed"
19:17:26 <decentral1se> ouch
19:17:44 <gundalow> oh, is what I pasted the warning,  appologies
19:17:54 <gundalow> hum, do we know why it failed, I don't see any logs
19:18:27 <decentral1se> Created https://github.com/ansible/molecule/issues/1730
19:18:30 <gundalow> NOTE: Try --verbose to see response content.
19:18:30 <gundalow> HTTPError: 400 Client Error: File already exists. See https://test.pypi.org/help/#file-name-reuse for url: https://test.pypi.org/legacy/
19:18:51 <gundalow> decentral1se: Thanks
19:19:22 <themroc> it failed twice, i restarted it today already
19:19:58 <gundalow> So that's coming from https://github.com/ansible/molecule/blob/master/.travis.yml#L369-L393
19:20:59 <gundalow> hum, wonder if and rerun failed as previous uploaded
19:21:22 <gundalow> Need to see if next merg works
19:21:26 <gundalow> OK, what's next?
19:22:33 <dachary> here
19:22:46 <gundalow> #chair dachary
19:22:46 <zodbot> Current chairs: Pilou dachary decentral1se fabianvf gundalow themroc zbr
19:22:49 <gundalow> dachary: Welcome :)
19:22:55 <themroc> for the ci: i tried to relaunch some builds for pr that failed previously, but maybe they need to be rebased first to get green ?
19:23:12 <gundalow> themroc: I *think* travis rebases before run
19:23:56 <gundalow> Anything else for CI?
19:24:21 <dachary> On the plus side https://github.com/ansible/molecule/commits/master shows one green commit.
19:24:23 <themroc> then all latest PR are broken https://travis-ci.com/ansible/molecule/pull_requests
19:24:47 <themroc> 510--515
19:25:48 <themroc> these are the PR in the need review column in https://github.com/ansible/molecule/projects/4
19:26:18 <gundalow> themroc: Thanks
19:26:23 <gundalow> #info PRs needing review https://github.com/ansible/molecule/projects/4
19:26:45 <themroc> and https://github.com/ansible/molecule/projects/2
19:27:40 <fabianvf> how would we request a PR get added to the milestone?
19:27:46 <gundalow> fabianvf: ask here :)
19:27:59 <gundalow> myself themroc and decentral1se have powers to add
19:28:12 <dachary> https://github.com/ansible/molecule/pull/1653
19:28:19 <fabianvf> I'd like to align https://github.com/ansible/molecule/pull/1714 to 2.21 unless there's an objection (it would go under in progress right now)
19:28:34 <dachary> https://github.com/ansible/molecule/pull/1653 needing review (already in the milestone)
19:29:34 <themroc> fabianvf, you're served
19:29:56 * singuliere rebasing  https://github.com/ansible/molecule/pull/1653 & resolving conflict
19:30:03 <fabianvf> awesome, thanks!
19:30:32 <decentral1se> https://github.com/ansible/molecule/pull/1728 is an easy merge
19:30:43 <decentral1se> oh, done :)
19:30:44 <gundalow> decentral1se: merged (and related PR closed)
19:31:01 <gundalow> hum, that should kick of a test.PyPi I think, so we can see if it works now
19:31:03 <gundalow> #topic PR review
19:31:39 <singuliere> rebased & re-force-pushed
19:32:19 <decentral1se> nice one
19:32:22 <decentral1se> https://github.com/ansible/molecule/pull/1526 looked good to merge
19:32:46 <decentral1se> also https://github.com/ansible/molecule/pull/1535
19:34:10 <themroc> yes basically after these 2 i believe it's time for some "make all arguments available for docker module available in molecule"
19:34:14 <gundalow> 1526 is failing CI due to syntax error, review added
19:34:58 <decentral1se> good catch
19:35:11 <gundalow> Problem with failing CI, need to check why
19:35:27 <gundalow> I miss ansibulbot copying the failing text into a GitHub comment :(
19:35:52 <themroc> oh that would be awesome!
19:35:57 <decentral1se> Is there much more we ask from https://github.com/ansible/molecule/pull/1604?
19:37:43 <gundalow> In Travis-CI is there a way to rerun only failing tests?
19:37:54 <decentral1se> Don't think so :/
19:37:55 <themroc> yes
19:38:02 <gundalow> ah, click rerun inside the job
19:38:07 <decentral1se> \0/
19:38:10 <themroc> yes
19:38:51 <gundalow> 1535: Rerunning CI
19:39:03 <gundalow> So if CI should be green now we need to ensure it is before hitting merge
19:40:01 <decentral1se> nice one
19:40:30 <decentral1se> watching https://travis-ci.com/ansible/molecule/jobs/175827471 (pypi release on latest master build ...)
19:41:19 <gundalow> decentral1se: think you'll have to wait 45mins for the tests to finish before that job starts
19:42:14 <decentral1se> oh dear
19:44:45 <gundalow> fabianvf: Would you like to go though yours?
19:44:50 <gundalow> what's the PR link?
19:44:58 <fabianvf> https://github.com/ansible/molecule/pull/1714
19:45:15 <gundalow> #topic [WIP] Add Ansible verifier #1714
19:45:19 <gundalow> fabianvf: floor is yours
19:45:32 <gundalow> #info https://github.com/ansible/molecule/pull/1714  [WIP] Add Ansible verifier
19:46:03 <fabianvf> so the PR in it's current state is pretty much a POC, but it seems pretty easy to add, since it's basically just a passthrough to the verify.yml which is already used by the other verifiers
19:47:00 <fabianvf> I've added the bits I have left to the TODO list in the PR, if anyone has a cycle or two any assistance (or even comments on the PR for the proper places to look) would be much appreciated
19:47:43 <fabianvf> I'm hoping to steal some time in the next week or so to bring it closer to a finished implementation
19:48:25 <themroc> you'll need an option when you create a template
19:48:45 <themroc> when you create a role or a scenario sorry
19:48:59 <fabianvf> added
19:50:07 <gundalow> Anyone else able to take a look atthis?
19:50:54 <decentral1se> Happy to review as it progresses fabianvf! Not much cycles to spare otherwise
19:51:25 <themroc> I cannot promise anything ATM, I wish I could, it could be quite useful for some of our usecases.
19:53:25 <fabianvf> no promises necessary, only if it's convenient. I can definitely wrap this up on my own
19:53:54 <gundalow> Thanks all
19:53:58 <gundalow> fabianvf: anything else on that?
19:54:08 <fabianvf> gundalow: I think that's it for me
19:55:12 <themroc> a point on release 2.20 ?
19:57:42 <themroc> could we release 2.20 without https://github.com/ansible/molecule/issues/1616 and https://github.com/ansible/molecule/issues/1609 ? should someone try before to run all the tests that are skipped in travis from a workstation (including all cloud related tests)?
19:58:26 <decentral1se> Blockers were: #1723 (fix waiting) and #1725 (is it really?)
19:58:37 <gundalow> #topic release 2.20
19:59:07 <decentral1se> We can skip waiting longer on #1616, no? It's only meta information that is nice to have?
19:59:21 <gundalow> I tried docker build locally and it failed
19:59:29 <gundalow> oh, upstream pip bug
19:59:36 <themroc> https://github.com/ansible/molecule/projects/2 only 2 items in the todo
19:59:41 <gundalow> so hopefully that will be fixed by the time we are ready
20:00:13 * gundalow is happy to skip 1616
20:00:27 <themroc> +1
20:00:30 <decentral1se> Cool
20:01:18 <themroc> -> 2.21
20:01:45 <decentral1se> So just 1723 and 1725 and we're ready to rip?!
20:01:48 <gundalow> so should https://github.com/ansible/ansible-lint/pull/478 be v2.20 as well as the bug 1723
20:02:46 <decentral1se> +1
20:04:25 <gundalow> erm,taht's a lint PR
20:04:37 <themroc> https://github.com/ansible/molecule/issues/1725 - probably the Dockerfile needs to have the extras referenced in pip package, but the package need to be uploaded first
20:05:00 <gundalow> awcrosby: Not sure if you are still around, looks like https://github.com/ansible/ansible-lint/pull/478 is important to us in Molecule land
20:05:43 <awcrosby> gundalow should be good to merge for 4.1.0, to be release in the next few days
20:05:58 <gundalow> Thanks, added 4.1.0 milestone
20:06:04 <decentral1se> solid!
20:07:55 <decentral1se> themroc: ah, I see that now
20:09:49 <decentral1se> building locally now ...
20:10:30 <gundalow> cool, that's the hour (and a bit)
20:10:39 <gundalow> Anything else before I #endmeeting?
20:11:07 <decentral1se> :) right, all clear from my side
20:11:14 <themroc> a little celebration for the CI green just during the community update talk at cfgmgmtcamp ?
20:11:14 <fabianvf> awesome work on this project from everyone
20:11:32 <decentral1se> woot woot
20:11:33 <gundalow> Aye, really impressed, good work all :)
20:11:46 <gundalow> #endmeeting