#ansible-network: Network Working Group

Meeting started by gundalow at 16:00:14 UTC (full logs).

Meeting summary

  1. General Updates (gundalow, 16:06:36)
    1. Agenda as always, https://github.com/ansible/community/issues/110 (gundalow, 16:06:57)
    2. We will create a fresh agenda after 2.4.0 has been released (gundalow, 16:07:23)
    3. Great to see many at Contributor Summit and AnsibleFest people last week. Videos of presentations are being processed, will let you know when they are available online (gundalow, 16:07:34)
    4. 2.4RC3 will be released today/tomorrow. Please take the time to test this. We are very close to releasing 2.4.0. We can only fix what we know is broken. (gundalow, 16:07:39)

  2. 2.5 Planning (gundalow, 16:08:21)
    1. Draft Network roadmap https://github.com/ansible/community/wiki/Network:Core-roadmap-2.5 (gundalow, 16:08:28)
    2. The above will be moved to https://github.com/ansible/ansible/tree/devel/docs/docsite/rst/roadmap once created (likely this week). (gundalow, 16:08:34)
    3. Will stay in DRAFT status for a few weeks, we welcome your feedback in #ansible-network (gundalow, 16:09:07)
    4. ACTION: everybody please review the draft roadmap and give feedback via #ansible-network (gundalow, 16:09:14)
    5. As discussed in Contributors Summit Proposals will be created for the large blocks of network work. This will form as a place to track the spec (including user interface) and provide a framework for discussion. (gundalow, 16:09:51)
    6. Proposals haven't been created yet, they will be added as comments on to the meeting agenda (please ensure you've subscribed) (gundalow, 16:09:55)

  3. Use of Proposals (gundalow, 16:22:24)
    1. As stated earlier we (Core Network Team) will use proposals to capture spec & discussion for larger blocks for work for 2.5 (gundalow, 16:23:00)
    2. Ideas for larger blocks of what that the Community has can also be raised as Proposals for consideration for Ansible 2.6+. I'd suggest that before creating a proposal however you add it onto the meeting agenda so we can discuss it a bit first (gundalow, 16:24:05)
    3. AGREED: Community will raise feature ideas in IRC meeting then after short discussion create in github.com/ansible/proposals/ and reference in meeting agenda (gundalow, 16:26:26)
    4. AGREED: Core Network Team will use Proposal process to allow discussion before coding starts (gundalow, 16:26:58)
    5. AGREED: Proposals will be discussed in weekly in IRC. (gundalow, 16:27:30)

  4. Keeping track of Medium and long term goals (gundalow, 16:46:49)
    1. So we've agreed on Proposals, though how would people to go through these (gundalow, 16:47:12)
    2. AGREED: Weekly IRC meetings will focus on issues & proposals for the current release (gundalow, 16:56:40)
    3. AGREED: Monthly meetigns will focus on reviewing proposals for future releases (gundalow, 16:57:04)

  5. deprecation of top level credentials & transport (gundalow, 17:04:16)
    1. As most of you know use of username:, password:, transport:, timeout: at the top-level (i.e. not under `provider:`) will trigger a deprecation notice. (gundalow, 17:05:11)
    2. We currently haven't told people when that will be removed (gundalow, 17:05:28)
    3. AGREED: top-level credentials will be supported untill 2.8 and deleted in 2.9 (gundalow, 17:14:00)
    4. ACTION: ganeshrn to update deprecation message to add in removed version paramater (gundalow, 17:14:22)

  6. bugfix timeline for 2.4.0rc3 andf.4.0 final (abadger1999, 17:15:04)
    1. https://github.com/ansible/ansible/pull/30293 (ogenstad, 17:18:55)
    2. https://github.com/ansible/ansible/pulls?utf8=%E2%9C%93&q=is%3Aopen%20is%3Apr%20label%3Anetworking%20milestone%3A2.4.0%20%20nxos (gundalow, 17:21:32)
    3. AGREED: RC3 will go out today as planned (gundalow, 17:31:07)
    4. AGREED: mikewiebe to provide #ansible-network with a list of other PR that need milestone:2.4.0 adding (gundalow, 17:31:33)
    5. AGREED: RC4 will be cut on Saturday which will include the next set of NXOS fixes (gundalow, 17:32:05)

  7. Open Floor (gundalow, 17:33:50)
  8. 29018 Issue with Persistent Connection for Enos_facts.py - Connection is NOT reliable. Succeeds only 1/4 (gundalow, 17:36:04)
    1. https://github.com/ansible/ansible/issues/29018 (gundalow, 17:36:10)

  9. NXOS (gundalow, 17:50:27)
  10. Open Floor: Last Call (Qalthos, 18:04:08)


Meeting ended at 18:06:30 UTC (full logs).

Action items

  1. everybody please review the draft roadmap and give feedback via #ansible-network
  2. ganeshrn to update deprecation message to add in removed version paramater


Action items, by person

  1. ganeshrn
    1. ganeshrn to update deprecation message to add in removed version paramater


People present (lines said)

  1. gundalow (175)
  2. privateip (39)
  3. ogenstad (28)
  4. ganeshrn (27)
  5. Qalthos (22)
  6. abadger1999 (21)
  7. saichint (18)
  8. Anil_ (16)
  9. mikewiebe (16)
  10. ktbyers (15)
  11. rcarrillocruz (13)
  12. zodbot (12)
  13. Anil (10)
  14. stacywsmith (9)
  15. bearrito (9)
  16. pdellaert (7)
  17. rcarrillocruz-we (4)
  18. kedarX (3)
  19. trishnag (2)
  20. skg-net (2)
  21. caphrim007 (2)
  22. dag (2)
  23. KeeranM (2)
  24. mcgonagle (1)
  25. itdependsnetwork (1)
  26. z3nbr3w (1)
  27. jmcgill298_ (1)


Generated by MeetBot 0.1.4.