#ansible-network: Network Working Group

Meeting started by gundalow at 16:00:09 UTC (full logs).

Meeting summary

    1. Agenda https://github.com/ansible/community/labels/network (gundalow, 16:07:48)

  1. 2.5 update (gundalow, 16:08:43)
    1. `connection: network_cli` is LIVE. The issues with `authorize: true` (eos & ios) have been resolved (gundalow, 16:09:26)
    2. NO MORE `unable to open shell` (gundalow, 16:09:39)
    3. NO MORE `unable to open shell` even when using `connection: local` (gundalow, 16:09:49)
    4. ACTION: EVERYONE We'd really welcome testing on the devel branch, this is a HUGE change (gundalow, 16:10:10)
    5. Error messages are show in ansible-playbook output: fatal: [vyos01.example.net]: FAILED! => {"msg": "host key mismatch for vyos01.example.net"} (gundalow, 16:11:02)
    6. NOTE: `connection: local` & `provider:` is still needed for eapi & nxapi (gundalow, 16:11:52)
    7. If you set `connection: network_cli` YOU MUST also set `network_os: $platform` (where platform is the three module prefix, e.g. eos, ios, nxos, vyos) (gundalow, 16:14:24)
    8. For general 2.5.0 status please see https://github.com/ansible/ansible/projects/10 (gundalow, 16:17:30)
    9. Note that connection: (eapi, nxapi) are strech goals for 2.5 (that means there is lots of other stuff that needs doing before that, and it might end up in 2.6) (gundalow, 16:18:17)
    10. 2.5 Roadmap is live https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_5.rst (gundalow, 16:19:05)
    11. notes dates in ROADMAP_2_5.rst are FINAL dates, even PRs raised before hand are NOT guaranteed to get in. Sooner the better :) (gundalow, 16:23:17)

  2. Open Floor (gundalow, 16:23:21)


Meeting ended at 16:35:13 UTC (full logs).

Action items

  1. EVERYONE We'd really welcome testing on the devel branch, this is a HUGE change


People present (lines said)

  1. gundalow (36)
  2. Anil (10)
  3. zodbot (6)
  4. Qalthos (5)
  5. st8less (2)
  6. trishnag (1)
  7. rcarrillocruz (1)
  8. jmcgill298 (1)
  9. bearrito (1)
  10. funzo (0)
  11. privateip (0)
  12. kedarX (0)
  13. ganeshrn (0)


Generated by MeetBot 0.1.4.