#ansible-network: Network Working Group

Meeting started by gundalow at 16:00:05 UTC (full logs).

Meeting summary

    1. Agenda https://github.com/ansible/community/labels/network (gundalow, 16:02:45)

  1. Network_cli developer documentation (gundalow, 16:09:16)
    1. We now have documentation for *developers* on how to use the `connection: network_cli` work that's part of Ansible 2.5 (gundalow, 16:10:12)
    2. https://github.com/ansible/community/blob/master/group-network/network_dev_network_cli.rst (gundalow, 16:10:22)
    3. If anything isn't clear please ask in #ansible-network and we will improve the documentation (gundalow, 16:11:01)
    4. From Ansible 2.6 we will not be accepting new platforms that use top-level nor `provider:`. New network modules will need to support network_cli (gundalow, 16:15:35)
    5. ACTION: rcarrillocruz to add link to abstract class platform specific inherit to https://github.com/ansible/community/blob/master/group-network/network_dev_network_cli.rst (gundalow, 16:18:34)

  2. Network Become (gundalow, 16:21:57)
    1. Building on connection: network_cli, Ansible 2.5 also allows Playbook writers to use `become:` (rather than `authorize:` & `auth_pass`). (gundalow, 16:22:53)
    2. Documentation for Network Become: (reviews welcome) https://github.com/ansible/ansible/pull/33367 (gundalow, 16:23:22)
    3. ACTION: Qalthos to specific caveats for netconf in network_dev_network_cli.rst for skg-net (gundalow, 16:37:09)

  3. Open Floor (gundalow, 16:38:59)
    1. https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_5.rst (andriusb, 16:41:21)
    2. 2.5 timeline & roadmap https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_5.rst (gundalow, 16:44:33)

  4. NXOS (gundalow, 17:14:27)
    1. Will discuss NXOS in tomorrows call (gundalow, 17:17:21)

  5. Open Floor (gundalow, 17:17:26)


Meeting ended at 17:19:20 UTC (full logs).

Action items

  1. rcarrillocruz to add link to abstract class platform specific inherit to https://github.com/ansible/community/blob/master/group-network/network_dev_network_cli.rst
  2. Qalthos to specific caveats for netconf in network_dev_network_cli.rst for skg-net


Action items, by person

  1. Qalthos
    1. Qalthos to specific caveats for netconf in network_dev_network_cli.rst for skg-net
  2. rcarrillocruz
    1. rcarrillocruz to add link to abstract class platform specific inherit to https://github.com/ansible/community/blob/master/group-network/network_dev_network_cli.rst
  3. skg-net
    1. Qalthos to specific caveats for netconf in network_dev_network_cli.rst for skg-net


People present (lines said)

  1. gundalow (92)
  2. Anil (11)
  3. samerd (11)
  4. zodbot (11)
  5. privateip (11)
  6. Qalthos (10)
  7. itdependsnetwork (9)
  8. skg-net (8)
  9. caphrim007 (8)
  10. rcarrillocruz (7)
  11. dt-arista (5)
  12. smolz_ (5)
  13. jmcgill298 (4)
  14. mikewiebe (2)
  15. Topner (2)
  16. andriusb (1)
  17. funzo (1)
  18. trishnag (1)
  19. kedarX (1)
  20. bearrito (1)


Generated by MeetBot 0.1.4.