16:02:09 <pabelanger> #startmeeting Ansible Network Working Group
16:02:09 <zodbot> Meeting started Wed Mar 13 16:02:09 2019 UTC.
16:02:09 <zodbot> This meeting is logged and archived in a public location.
16:02:09 <zodbot> The chair is pabelanger. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:09 <zodbot> The meeting name has been set to 'ansible_network_working_group'
16:02:34 <pabelanger> #topic Core Updates
16:02:48 <pabelanger> Not a lot going on this week
16:03:52 <pabelanger> we are in the process of rebuilding out testing infrastucture, so in the coming weeks we'll be doing a migration of the tests from system A to system B. We don't expect this to be a major effort or change to how testing is done
16:04:21 <pabelanger> As a reminder
16:04:29 <pabelanger> #link https://github.com/ansible/community/labels/network is where you can find our agenda
16:05:10 <pabelanger> #topic Lenovo cnos static route #53736
16:05:18 <pabelanger> #link https://github.com/ansible/ansible/pull/53736
16:05:50 <pabelanger> If I recall properly, we talked about this today in our bug triage meeting
16:06:21 <pabelanger> I cannot remember the exact details at this moment, but Qalthos will be looking more into it
16:06:49 <Anil_Lenovo> I have raised PR today few hours back only
16:07:36 <pabelanger> Anil_Lenovo: yah, it was picked up today for review
16:07:46 <pabelanger> so I suspect this coming week you'll get more feedback on it
16:07:54 <Anil_Lenovo> can u share what has been discussed?
16:08:17 <Anil_Lenovo> ok..
16:08:40 <pabelanger> Anil_Lenovo: sadly, I cannot remember the details. But I'll go back into my notes and try to updated you after meeting, if that is okay
16:09:21 <Anil_Lenovo> No issues, if Qalthos is looking into it, thats fine for me
16:09:28 <pabelanger> great
16:09:49 <pabelanger> #topic Open discussion
16:09:51 <Anil_Lenovo> Based on his guidance only I develop modules
16:10:30 <pabelanger> There wasn't anything else posted on the agenda today, so if anybody else has things they would like to discuss
16:11:22 <Anil_Lenovo> What is the new module PR freezing date as of now ?
16:11:48 <pabelanger> for ansible 2.8?
16:12:10 <Anil_Lenovo> Yes for 2.8. I have 3 more modules to be added for cnos.
16:12:59 <pabelanger> That is a good question, I believe we are in feature freeze now for 2.8
16:13:07 <pabelanger> gundalow: are you able to confirm?^
16:14:59 <pabelanger> #action pabelanger confirm new module PR freeze date for ansible 2.8
16:15:19 <pabelanger> Anil_Lenovo: I'll have to get back to you on that, I've made a note to ask
16:16:19 <pabelanger> actually
16:16:21 <pabelanger> https://docs.ansible.com/ansible/devel/roadmap/ROADMAP_2_8.html
16:16:23 <Anil_Lenovo> From today to 21 I have only one weeks time, I am just wondering how can I go in with 3 modules by this time.
16:16:42 <gundalow> hi
16:16:47 <pabelanger> #link https://docs.ansible.com/ansible/devel/roadmap/ROADMAP_2_8.html
16:16:54 <gundalow> https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_8.rst
16:16:57 <gundalow> hehe
16:17:04 <Anil_Lenovo> So just wishing if it extends..
16:17:15 <pabelanger> Anil_Lenovo: yah, i think at this time it a review process (bandwidth issue)
16:17:37 <pabelanger> Anil_Lenovo: which 3 modules are you hoping to have include for 2.8?
16:17:51 <gundalow> #info The dates in https://github.com/ansible/ansible/blob/devel/docs/docsite/rst/roadmap/ROADMAP_2_8.rst are when the PRs must be *merged* by. Please note that it takes time for people to review & add feedback
16:17:52 <pabelanger> if you can share the PRs, I can follow up with team
16:17:54 <Anil_Lenovo> cnos_system, cnos_vrf and cnos_user
16:18:22 <Anil_Lenovo> I have not yet raised PRs..
16:18:42 <pabelanger> okay, the first step will be to raise the PRs so we can get humans to do review
16:19:00 <pabelanger> but agree with gundalow, it takes time to review and give feedback
16:19:21 <Anil_Lenovo> good, I think I got the idea.
16:20:24 <pffs> I was going to ask about 52926, but looks like it actually was just assigned two hours ago
16:21:21 <pabelanger> pffs: yah, I also remember that one from review this morning
16:22:30 <pffs> I have a slow rollout using that right now, mostly avoiding by setting the delay to higher than should be needed value, but get hit about 10% of the time on failures because of it
16:24:15 <pabelanger> yah, look like justjais should be picking up the issue
16:24:33 <pffs> cool
16:24:38 <pffs> justjais: if you need testing on it, let me know
16:25:34 <gundalow> Realistically if you haven't raised feature PRs yet, they are very unlikely to get in
16:29:54 <pabelanger> okay, if there is nothing else, we can close out here in a minute and get 30mins back
16:42:57 <pabelanger> #endmeeting