15:59:59 <Qalthos> #startmeeting Ansible Network Working Group
15:59:59 <zodbot> Meeting started Wed Aug 25 15:59:59 2021 UTC.
15:59:59 <zodbot> This meeting is logged and archived in a public location.
15:59:59 <zodbot> The chair is Qalthos. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:59 <zodbot> The meeting name has been set to 'ansible_network_working_group'
16:00:07 <Qalthos> #chair GomathiselviS nilashishc
16:00:07 <zodbot> Current chairs: GomathiselviS Qalthos nilashishc
16:00:35 <Qalthos> #topic Agenda https://github.com/ansible/community/issues/542
16:00:57 <Qalthos> #link https://github.com/ansible/community/labels/network is where the current agenda can always be found
16:01:04 <Qalthos> #topic Core Updates
16:04:28 <Qalthos> #info August's release is mostly a mainteneace release, so not a lot of features to call out, but
16:06:15 <Qalthos> #info Reminder that the EOS cli syntax update will be included in this release, please log any issues with modules not using the correct syntax or behaving as expected to the arista.eos collection
16:08:15 <Qalthos> #info There have been a few plumbing updates to the netcommon collection, specifically the network action plugin and network_cli. These changes should be entirely transparent to the end user, but feel free to log issues if behavior changes
16:09:07 <Qalthos> #info AnsibleFest is now just over a month away, and more details for the Contributor Summit happening before and after the event are now available
16:13:48 <Qalthos> #info The day before the event on September 28th, there will be a more hands-on day with established developers helping to onboard people wishing to get involved or looking for a deeper understanding of how things work
16:14:55 <Qalthos> #info The day after the event, on October 1, will be the more traditional Contributor Summit with discussions with the community on the future of Ansible
16:15:35 <Qalthos> #link https://hackmd.io/@ansible-community/contrib-summit-202109 is the usual hackmd note with all the details
16:16:07 <Qalthos> (I think that covered everything)
16:17:07 <Qalthos> #info And of course, AnsibleFest itself is coming up in between, on September 29-30
16:17:26 <Qalthos> #link https://www.ansible.com/ansiblefest to register for that and see more details
16:17:38 <Qalthos> I think that's everything I have for this week
16:17:47 <Qalthos> #topic Open Floor
16:18:02 <Qalthos> Does anyone have enything else they want to discuss?
16:21:28 <wayt> cisco.asa - it doesn't seem to be based no the tools to generate resource modules. is this just historical and should it be refactored to go that way?
16:21:38 <wayt> particularly around generating docs
16:26:02 <Qalthos> I'm not sure what you mean... the docs are all generated by the same tools we use in the other collections, and the old-style asa_acl and asa_og modules have both been deprecated in favor of resource modules that appear to be of the standard variety
16:29:53 <Qalthos> wayt: Do you have something specific you can point to that seems out of date?
16:30:15 <wayt> qalthos the use of 192.0.3.0/24 is not a valid documentation subnet as an example
16:30:26 <wayt> the 192.0.2.0/24 is TEST-NET1
16:30:33 <wayt> and there are 2 more but at different addresses
16:32:17 <Qalthos> Ah, okay, that sort of issue. That's unfortunately not something any of the tooling reminds us to do, but if you want to raise an issue, using publicly routable IPs is definitely a docs error
16:34:15 <Qalthos> I can probably have a script to move all uses of 192.0.3.0/24 to TEST-NET-2 in a few minutes
16:42:20 <wayt> cool - i saw something in the resource module builder
16:42:45 <wayt> didn't know if that metadata would make it easier to maintain the different doc areas
16:43:02 <Qalthos> wayt: https://github.com/ansible-collections/cisco.asa/pull/130 work for you?
16:44:41 <Qalthos> Hmm, it looks like we're already using TEST-NET-2 in some areas as well.
16:46:39 <wayt> lol i can take a peek and patch everything up as needed too. the main question was around whether i should migrate into the resource-builder tool and just get that done
16:47:01 <wayt> if it's just beating down some text in various files and points then that's easy enough
16:47:14 <wayt> that was fast though :)
16:47:47 <Qalthos> sed makes things like this go quick, but does need a human eye to verify
16:48:02 <wayt> and for the asa resource modules i didn't see the entries in the resource module repo's
16:48:19 <wayt> don't know if they were created before that or if it was just late and tired eyes didn't see things
16:49:57 <Qalthos> I'm not sure what you're not seeing. acls and ogs are both in the README (https://github.com/ansible-collections/cisco.asa#modules) and the docs they link to look complete
16:50:41 <wayt> https://github.com/ansible-network/resource_module_models/tree/master/models ... no asa :(
16:51:11 <Qalthos> Ohh, you mean the models
16:51:34 <Qalthos> Those do not oalways get pushed... or merged promptly
16:52:04 <Qalthos> I can ping somebody to see if they can get up there
16:52:38 <Qalthos> #action Qalthos Make sure asa models get pushed to resource_module_models
16:53:09 <wayt> ah cuz in those models you can put the metadata for doc's that is consumed by https://github.com/ansible-network/cli_rm_builder to put everything in the right place right? or is that strictly for create only (it says maintain in the body of README)
16:54:22 <wayt> i'll learn the lingo one day
16:55:26 <Qalthos> It has been a while since I was involved in building modules from the models, I'm not sure what the current state of the art is, and it depends on how old those modules are
16:56:24 <wayt> i'd be curious to know that so i get it right now and going forward - sure seems like a good idea to only have to do the examples once and have it put into the rst's and docstrings automagically though
16:58:02 <Qalthos> So updating existing modules doesn't need to go through that. https://github.com/ansible-network/collection_prep is the tool that regenerates documentation files based on the module files after they are built
16:58:17 <Qalthos> (Amongst other things that it can do)
16:59:10 <Qalthos> And if you use pre-commit, it is actually automatically run for every commit for you, so you should never have to think about the rst files
16:59:29 <Qalthos> Or the README for that matter
17:01:20 <Qalthos> ...and I never put anything about pre-commit in the README files either. I will see what I should do about that.
17:01:47 <Qalthos> #action Qalthos Put something about pre-commit in the collection README files
17:02:21 <Qalthos> wayt: Anything else I can help you with?
17:02:58 <wayt> awesome thanks i'll look at collection_prep and go from there. i'll also check that PR and add to if needed
17:03:04 <wayt> thx for chatting
17:03:18 <Qalthos> Thanks for coming by!
17:03:22 <Qalthos> #endmeeting