16:01:23 <akasurde> #startmeeting Ansible VMware Working Group Meeting
16:01:23 <zodbot> Meeting started Mon May 14 16:01:23 2018 UTC.
16:01:23 <zodbot> This meeting is logged and archived in a public location.
16:01:23 <zodbot> The chair is akasurde. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:23 <zodbot> The meeting name has been set to 'ansible_vmware_working_group_meeting'
16:01:23 <zodbot> akasurde: Error: Can't start another meeting, one is in progress.
16:01:35 <dericcrago> Hi akasurde
16:01:35 <akasurde> Hello everyone
16:01:41 <akasurde> #chair dericcrago
16:01:41 <zodbot> Current chairs: akasurde dericcrago
16:01:53 <akasurde> Hi dericcrago
16:03:14 <akasurde> dericcrago, let us wait for sometime for other people to join
16:03:59 <dericcrago> ok, jtanner was around
16:05:06 <akasurde> #chair jtanner
16:05:06 <zodbot> Current chairs: akasurde dericcrago jtanner
16:12:40 <akasurde> I want to discuss - https://github.com/ansible/community/issues/233#issuecomment-388781808
16:14:29 <kaneda-fr> Hi
16:14:37 <akasurde> #chair kaneda-fr
16:14:38 <zodbot> Current chairs: akasurde dericcrago jtanner kaneda-fr
16:14:41 <akasurde> kaneda-fr, hi
16:15:48 <kaneda-fr> flying from west coast back to Europe, was working with the vmware service providers folks
16:16:22 <akasurde> oh, nice
16:16:45 <kaneda-fr> they show python as one of their main language support for API SDK
16:17:07 <kaneda-fr> and pyvcloud is high on their radar, so we can only expect more and more integration coming up
16:17:24 <akasurde> Cool
16:17:42 <kaneda-fr> so just need to start working on integrating the new pyvcloud into ansible
16:19:01 <akasurde> definitely
16:22:42 <akasurde> I would like to discuss - https://github.com/ansible/ansible/pull/39339
16:22:54 <dericcrago> ok
16:23:08 <akasurde> PR adds facts related to disk in vmware_guest_facts
16:23:46 <jtanner> hello
16:23:52 <akasurde> There is already a new module called vmware_guest_disk_facts which does the same, I am in favor of not adding this change
16:23:55 <akasurde> hi jtanner
16:24:06 <jtanner> i'm very distracted
16:24:12 <akasurde> np
16:24:16 <dericcrago> would something like a module_utils version of vmware_facts be a good idea?
16:26:09 <akasurde> Like discussed in last meeting, we should have separate small modules instead on one big module which will do everything
16:26:23 <akasurde> What everyone things about this ?
16:26:29 <jtanner> we can do that
16:26:41 <jtanner> we can also continue to pursue breaking up the module_utils into a folder
16:26:42 <kaneda-fr> yeah, I'm in favor of breaking into smaller modules
16:26:59 <akasurde> +1 for smaller modules
16:27:27 <akasurde> jtanner, yes definitely
16:27:47 <dericcrago> I like that idea jtanner "breaking up the module_utils into a folder"
16:29:27 <akasurde> Yes, one of the step in achieving this is PyVmomi class
16:31:58 <kaneda-fr> can we also discuss https://github.com/ansible/ansible/pull/19886 ?
16:33:15 <pdellaert> sorry i missed the start, i do need to run, but keep tagging me
16:38:18 <akasurde> #chair pdellaert
16:38:19 <zodbot> Current chairs: akasurde dericcrago jtanner kaneda-fr pdellaert
16:40:01 <akasurde> pdellaert, hi
16:40:12 <pdellaert> hi, akasurde
16:40:52 <pdellaert> and yes, +1 for more small modules and less monolithic modules :)
16:41:03 <pdellaert> kaneda-fr: what do you want to discuss on that PR?
16:41:43 <pdellaert> akasurde: on 39339 > If there is a disks facts module and it contains all info, i feel like that should be used...
16:43:03 <akasurde> pdellaert, yes. Thats what I suggested, but author suggested  that the vmware_guest_disk_facts returns complicated datastructure
16:43:13 <akasurde> but we discussed that in last meeting
16:44:31 <pdellaert> `it would be better if they shared the same keys` > that is a valid remark
16:44:57 <pdellaert> anyway, really have to run, sorry
16:45:46 <akasurde> pdellaert, np
16:46:48 <akasurde> kaneda-fr, I am ok with changes, I don't have setup so can't test
16:46:58 <akasurde> Let me know if it works for you then we can merge
16:49:25 <akasurde> #action akasurde Create a playbook to use vmware_guest and vmware_guest_disk_facts together and update documentation
16:49:46 <akasurde> #link https://github.com/ansible/ansible/pull/40075
16:50:07 <akasurde> We have started working on new scenario based documentation related to VMware
16:51:15 <akasurde> This is part of effort to demystify all options and their usage
16:51:33 <dericcrago> yeah, I started looking at that earlier
16:51:39 <dericcrago> good work akasurde
16:52:04 <akasurde> Let me know your views and comments and suggestions
16:52:06 <akasurde> dericcrago, thanks
16:54:15 * jtanner is about to head to airport
16:54:33 <akasurde> dericcrago, jtanner is also main part of this effort
16:54:48 <akasurde> jtanner, have a safe journey
17:03:29 <akasurde> Does anyone have anything else to discuss ?
17:03:36 <dericcrago> yes
17:03:46 <akasurde> dericcrago, yes go ahead
17:05:13 <dericcrago> akasurde, jtanner, mattclay - I'm been working on updating vcsim to the latest, not sure how much this needs to be coordinated, I *think* I could just submit a PR to the vcenter-test-container repo, once that's good and tagged, create a PR against ansible with the new tag in vcenter.py and the handful of changes to the tests
17:06:11 <akasurde> yes I think this is a correct procedure
17:06:22 <jtanner> probably really only needs someone to get mattclay to do the build + tag, then make sure the full set of tests run with the ansible/ansible PR
17:06:31 <dericcrago> in the midst of preparing this, I noticed what I think is a bug around the networks vlan parameter being both a name or an id
17:07:04 <dericcrago> this highlights what I'm talking about - https://github.com/ansible/ansible/compare/devel...dericcrago:vcsim_latest#diff-ed147163551d1eaa084b21f6bab29f96
17:07:40 <dericcrago> it seems likely that someone passes the vlan as a name and then it tries to int("some name") which fails
17:08:35 <akasurde> 1. vim.dvs.VmwareDistributedVirtualSwitch and vim.DistributedVirtualSwitch are both required
17:09:01 <dericcrago> the version of vcsim in vcenter.py doesn't catch that, the new version that I was testing did catch that
17:09:49 <akasurde> Some version of vCenter has VmwareDistributedVirtualSwitch and others has DistributedVirtualSwitch
17:10:18 <dericcrago> sorry akasurde - right now I'm just talking about the changes highlighted in vmware_guest.py
17:10:24 <akasurde> OK
17:10:55 <akasurde> vlan of int and str was added recently to fix "Unable to find VLAN id " error
17:11:08 <dericcrago> I'm willing to go back and investigate VmwareDistributedVirtualSwitch vs DistributedVirtualSwitch
17:11:23 <dericcrago> I understand what they were trying to do
17:11:38 <dericcrago> it seems like it was only tested for the happy path
17:12:09 <dericcrago> as if you pass a "name" instead of a 10 then it tries to int("name") which doesn't work
17:12:34 <dericcrago> that's why I flipped it to comparing strings instead of ints
17:12:36 <akasurde> ohk
17:12:57 <akasurde> dericcrago I guess we need to blame jinja templating here
17:13:38 <akasurde> someone must be passing "10" even though it is referring to 10 vlanid it is passed as "10"
17:13:43 <dericcrago> I can pull out *just* that change into a PR if we agree that it's a bug that we should fix
17:13:57 <dericcrago> sure, in that case the original pr works
17:14:12 <dericcrago> what happens when you pass "vlan name" ?
17:14:26 <akasurde> Yes, that what I thought
17:14:33 <akasurde> yes vlan name will fail
17:14:36 <dericcrago> :)
17:14:38 <dericcrago> ok
17:14:55 <dericcrago> should I create a PR for that?
17:15:27 <akasurde> yes definitely
17:15:30 <dericcrago> ok
17:15:39 <akasurde> thanks for bringing that up
17:15:58 <dericcrago> no problem, I wouldn't have caught it if it wasn't for the new vcsim :)
17:16:10 <dericcrago> so slightly improved testing is coming :)
17:16:20 <akasurde> Cool
17:16:49 <dericcrago> ok, I'll create a PR for the network vlan arg
17:17:13 <dericcrago> and I'll look into VmwareDistributedVirtualSwitch vs DistributedVirtualSwitch a bit further before I create the "update to vcsim latest" PR
17:17:42 <akasurde> Try will older vcenter version
17:18:01 <dericcrago> minimum vCenter is 5.5, right?
17:18:22 <akasurde> yes
17:18:30 <dericcrago> I wanted to check if it was a vCenter 5.5 or pyVmomi 5.5
17:18:48 <dericcrago> also as part of the PyCon sprints, I'm working on contributing a VMware Connection Plugin
17:27:08 <akasurde> dericcrago, Before submitting PR please submit a proposal here - https://github.com/ansible/proposals/issues
17:28:07 <dericcrago> akasurde - which things need new proprosals?
17:28:42 <akasurde> dericcrago, Connection plugins or any major changes
17:28:45 <dericcrago> ok
17:29:16 <dericcrago> thanks, I was unaware of that
17:30:03 <akasurde> Np
17:30:31 <akasurde> dericcrago, This is a good example of connection plugin proposal - https://github.com/ansible/proposals/issues/103
17:31:26 <dericcrago> awesome, thanks akasurde
17:31:37 <akasurde> dericcrago, you start with proposal I will edit it
17:32:13 <akasurde> dericcrago, np, advantage with this proposal is we will get good and constructive suggestions
17:33:32 <akasurde> We are over the time for this meeting
17:33:50 <akasurde> I will close this meeting now.
17:33:56 <akasurde> #endmeeting