16:03:13 <akasurde> #startmeeting Ansible VMware Working Group Meeting
16:03:13 <zodbot> Meeting started Mon Oct 15 16:03:13 2018 UTC.
16:03:13 <zodbot> This meeting is logged and archived in a public location.
16:03:13 <zodbot> The chair is akasurde. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:13 <zodbot> The meeting name has been set to 'ansible_vmware_working_group_meeting'
16:03:18 <akasurde> #chair ckotte
16:03:18 <zodbot> Current chairs: akasurde ckotte
16:03:20 <akasurde> ckotte, hi
16:03:37 <ckotte> hi, do we have audio for the meeting?
16:04:27 <dericcrago> hi
16:04:31 <moshloop_> hi
16:04:56 <akasurde> #chair dericcrago
16:04:56 <zodbot> Current chairs: akasurde ckotte dericcrago
16:05:00 <akasurde> #chair moshloop_
16:05:00 <zodbot> Current chairs: akasurde ckotte dericcrago moshloop_
16:05:06 <akasurde> hi everyone
16:05:22 <akasurde> ckotte, nope we don't have audio video for this meeting :(
16:06:36 <ckotte> I could host a WebEx next time
16:07:06 <ckotte> or we could just use Skype, etc...
16:07:49 <akasurde> Not sure if that is necessary
16:08:03 <akasurde> ckotte, btw thanks for the new PRs and reviews
16:08:34 <akasurde> I am testing and reviewing stuff so it may take a little more time
16:08:35 <ckotte> Isn't it easier to discuss thing?
16:08:58 <ckotte> I will update several other modules as well
16:09:21 <moshloop_> Are their any plans to get an integration testing environment up running vcenter ?
16:09:25 <ckotte> need to focus on the host, switch, and cluster modules first
16:09:42 <akasurde> moshloop_, I am working on the same
16:09:58 <akasurde> once that is stable and robust, will make in public
16:10:21 <akasurde> ckotte, I would recommend to focus on vmware_guest
16:10:52 <akasurde> As per my knowledge, community people uses vmware_guest more than any other modules and we have lot of things pending on that module
16:10:55 <ckotte> @aksurde I need to implement host automation first
16:11:09 <moshloop_> should we just submit integration tests marked as unsupported than ? What connection vars do we use?
16:11:22 <ckotte> I know. there are a lot of issues about vmware_guest, but I don't have time for this now
16:11:35 <akasurde> #info http://ansibullbot.eng.ansible.com/ansibot/metadata/byfile_sorted.html
16:11:59 <akasurde> ckotte, If you see vmware_guest is at top number 1 for weeks now
16:12:20 <akasurde> moshloop_, unsupported depends upon vcsim only
16:12:45 <akasurde> going forward once real vCenter is in place then will have conditional to handle all testcase
16:12:53 <akasurde> *testcase
16:12:57 <akasurde> *testcases
16:13:18 <moshloop_> Just trying to understand how I can help your testing burden
16:13:53 <moshloop_> i.e.  Commit an integration test, that you then manually run, until vcenter testing is part of the normal testng cucle
16:14:02 <ckotte> aksurde, it's on top yes, but I need to implement infrastructure automation for my customer first
16:14:15 <akasurde> moshloop_, Wow, thanks for asking. We need real hardware to test all testcases. I have tested most of them but I would love if someone takes another stab at this
16:14:34 <ckotte> how can you "focus" someone. Didn't use IRC since early 2000...
16:15:24 <akasurde> we can start one topic and discuss that first and once that is finish we move on to next one
16:15:35 <akasurde> #topic prioritise vmware_guest
16:15:39 <akasurde> like this
16:15:43 <ckotte> like this "ckotte, If you see vmware_guest is at top number 1 for weeks now"
16:16:18 <akasurde> let us discuss on prioritise vmware_guest issues and PRs
16:17:07 <ckotte> no. I mean. If I want to send a message and "highlight" your username
16:17:51 <akasurde> What is your IRC client ?
16:17:59 <ckotte> LimeChat
16:18:04 <ckotte> just use it the first time
16:18:06 <dericcrago> depends on your client ckotte, most of them have autocomplete / highlighting of usernames
16:18:13 <ckotte> sorry for the noob questions :)
16:18:23 <ckotte> ok
16:18:34 <akasurde> if it is xchat then, just type my name and hit tab and your reply
16:18:39 <dericcrago> I think there's several people using https://www.irccloud.com/
16:18:45 <akasurde> limechat follows same
16:18:49 <akasurde> #chair dericcrago
16:18:49 <zodbot> Current chairs: akasurde ckotte dericcrago moshloop_
16:18:55 <akasurde> dericcrago, welcome
16:19:38 <ckotte> is it possible to use IRC with http/https? IRC is blocked in the company network
16:19:57 <akasurde> ckotte, yes
16:20:00 <dericcrago> that's https://www.irccloud.com/ ;)
16:20:14 <akasurde> https://webchat.freenode.net/
16:20:28 <ckotte> ok. will try next time. thanks
16:22:54 <ckotte> So, whats the plan regarding the vmware_guest modules?
16:23:40 <akasurde> Right now there is no plan as such but I would love to see fix existing PRs and issues
16:23:56 <akasurde> 1. Disk management
16:23:58 <pdellaert> o/, sorry i'm late
16:24:03 <akasurde> 2. Datastore management
16:24:06 <akasurde> #chair pdellaert
16:24:06 <zodbot> Current chairs: akasurde ckotte dericcrago moshloop_ pdellaert
16:24:33 <ckotte> Some PRs are open for a long time
16:24:40 <akasurde> pdellaert, hi, we are discussing about prioriting vmware_guest issues and PRs
16:24:42 <ckotte> e.g. vmware_vswitch
16:24:48 <ckotte> I already have new improvements
16:24:54 <pdellaert> ok, i'll catch up
16:25:07 <akasurde> yes, old PRs are waiting on reviews and testing
16:25:57 <ckotte> should we start with the oldest PRs and issues or doesn't it matter?
16:26:04 <akasurde> pdellaert, tcernomax and dericcrago has done a great job of review PRs
16:26:44 <akasurde> ckotte, it does not matter, depends on severity and number of people hit
16:26:50 <akasurde> with the bug
16:27:46 <pdellaert> this is the one thing we kind of miss in github issues: priorities, or are there labels that can highlight priorities?
16:29:40 <akasurde> yes there are labels, but those are tightly attached to ansible release cycle
16:29:46 <akasurde> like P1 and P2 etc.
16:29:53 <ckotte> "depends on severity and number of people hit": where do you see this information?
16:30:32 <akasurde> If I add P1 then it block Ansible release something like that
16:30:40 <akasurde> P1 is highest priority
16:30:59 <akasurde> we can use Projects - https://github.com/ansible/ansible/projects
16:31:30 <akasurde> more specific like https://github.com/ansible/ansible/projects/20
16:31:42 <akasurde> Network automation team using it for their tracking
16:31:51 <pdellaert> akasurde: i like that idea!
16:32:26 <ckotte> I like it too
16:32:48 <akasurde> there is a drawback to GitHub Project though - only People under Ansible can move the tickets
16:34:26 <akasurde> pdellaert, I can create columns with priority and start working on the classification on issues
16:38:45 <akasurde> Are we agree on this ?
16:41:27 <ckotte> You can create a project, and then we can see if it is useful as intended?
16:43:58 <akasurde> Yes sure
16:44:27 <akasurde> #action Akasurde To create vmware related project in GitHub project and decide priorities of issues and PRs
16:48:22 <moshloop_> coming back to the vcenter integration testing
16:48:30 <pdellaert> akasurde++
16:49:08 <moshloop_> Does RedHat have a vcenter cluster / hardware available or is this something we need to get VMWare or another company to sponsor ?
16:49:35 <akasurde> #topic vcenter integration testing
16:49:47 <pdellaert> moshloop_: the problem with that is that we need a full vCenter with multiple DC's, clusters, hosts, datastores, ... etc. Which is expensive, and which is unlikely to be available, additionally, testing all kind of setup combinations is going to be really hard
16:50:29 <ckotte> a vCenter standard license doesn't cost that much ;)
16:50:33 <akasurde> moshloop_, RedHat has limited hardware and no licenses so I rely on Eval copy
16:50:49 <akasurde> We are open to hardware sponsers
16:51:05 <pdellaert> I doubt VMware will be eager to sponsor/provide such a setup entirely, they are supporting Ansible a bit, but not significantly enough to sponsor hw and sw
16:51:07 <akasurde> We just need test status
16:51:10 <dericcrago> at one point in time, there were some people from VMware that joined this meeting, I'm not sure what happened with that
16:51:47 <ckotte> did you ask VMware? I guess they want to push vRealize Automation and Orchestrator or PowerCLI instead of Ansible
16:51:52 <akasurde> ckotte, as a community project we can not afford it
16:51:58 <moshloop_> We are a decent enough size Redhat and VMWare customer, so I will try push on that sude
16:52:37 <moshloop_> VRA / VRO are integrating into ansible these days - so I don't see why they wouldn't want to support it
16:52:43 <pdellaert> ckotte: a standard vcenter licens is not that expensive, but eventually you'd need about 9 ESXi licenses as well, if you want to test dvSwitches, you also end up with Enterprise Plus licenses :)
16:52:43 <ckotte> maybe more people will use Ansible and later buy support or use Ansible Tower if the vmware modules are better
16:52:44 <akasurde> dericcrago, I met bunch of VMware folks in both VMworld and AnsibleFest, they are planning to support HW
16:52:47 <akasurde> let us see
16:53:08 <pdellaert> ah, that's good news :)
16:53:21 <akasurde> pdellaert, agree
16:53:37 <ckotte> here at my customer, the TAM wants to push vRA/vRO and nowadays also Lifecycle Manager....
16:53:43 <akasurde> ckotte, Thats the target
16:54:24 <ckotte> Unfortunetly, lots of (new) VMware products are buggy. With Ansible, I can fix it by myself. With VMware, the ticket disappears in the "void"
16:55:03 <moshloop_> I think we just need to apply enough pressure as customers to the bean counters at vmware
16:56:21 <akasurde> moshloop_, Do you have infrastructure which can be utilize to run existing and new testcase then we are happy to talk
16:56:39 <ckotte> aksurde What do you mean with "they are planning to support HW". HW = hardware??
16:57:41 <moshloop_> We do have some capacity now - let  me see what I can do
16:58:06 <moshloop_> What type of  memory allocation do you think we will need ?
16:58:42 <ckotte> I have some capacity too for integration tests, but we cannot connect from outside..
16:59:32 <ckotte> We have 30++ HP G8 blades doing nothing
16:59:47 <ckotte> in one site... plus more in other sites
17:00:31 <dericcrago> for anyone eager to test something, I just submitted a PR for a couple of vmware_tools connection plugins
17:00:36 <moshloop_> In theory we don't need inbound ? Only outbound to poll and comment on the PR's ?
17:00:37 <dericcrago> use at your own risk ;)
17:01:02 <dericcrago> https://github.com/ansible/ansible/pull/47072
17:01:24 <akasurde> ckotte, HW == hardware
17:01:34 <akasurde> moshloop_, that would be great
17:01:50 <ckotte> I have enough free hardware
17:02:04 <ckotte> I wanted to implement integration testing for my stuff anyway
17:02:24 <akasurde> moshloop_, ckotte we just need info if tests passed or not
17:02:35 <ckotte> I also planned to spin up ESXi and vCenter servers after every commit in my Ansible repo
17:02:48 <akasurde> and not breaking anyhting which is available already there
17:02:54 <akasurde> dericcrago, bravo
17:02:56 <ckotte> haven't have time yet to implement CD/CI
17:03:32 <akasurde> ckotte, gitlab CI is nice to start with - easy and very intuitive
17:03:51 <ckotte> aksurde sure, but time is the problem
17:04:32 <akasurde> ckotte, ok
17:05:36 <moshloop_> So we will try and setup some infra, publish the test results somewhere and just manually comment on the PR's for now ?
17:05:54 <pdellaert> If there is HW available, internal or external, with some CD, you could easily track the existing ansible repo, reformat the tests a little bit in the repo, and execute them on real HW instead of against vcsim. But there will be some significant work to be done in automating all of that ... All for it, but let's be realistic that accept for akasurde, we are all vounteers with a full time day job
17:06:00 <pdellaert> (well, some of us more ...
17:06:02 <pdellaert> ... than full time, i think)
17:06:28 <pdellaert> moshloop_: that would be good, indeed. But it is also important to document how the infra is set up and how the tests get executed :)
17:07:05 <moshloop_> What is the mechanism that is used for AWS to inject credentials ?
17:07:18 <pdellaert> s/accept/except (previous statement)
17:07:20 <akasurde> I am not sure about AWS
17:09:32 <moshloop_> https://github.com/lamw/vghetto-vsphere-automated-lab-deployment Seems like a good start ?
17:09:39 <akasurde> but ask
17:11:23 <pdellaert> i have to run, sorry. akasurde if you have a project setup, it would be great, i can/am willing to help out in the project mamagement if you need/want some help. (First suggestions for lists/collumns in the project tracker: Have a list of open issues (Todo), a list of high priority issues and a list of open PRs to be reviewed (in review). Other collumns can be those to indicate which need
17:11:29 <pdellaert> backporting to different releases ...
17:11:32 <pdellaert> ... and maybe a 'working on' list so people now somebody has commited on working on those)
17:12:38 <ckotte> backporting to older Ansible releases? Is that really necessary? there's so much todo...
17:12:56 <akasurde> generally backporting is on demand
17:13:03 <akasurde> people ask for backprot
17:15:13 <ckotte> because they can't use the devel version on their servers?
17:15:51 <akasurde> yes, another reason being people use tower
17:15:51 <ckotte> I use the CentOS Ansible version and link the new modules to my repo in the library folder
17:16:21 <pdellaert> ckotte: a lot of professional deployments really do not allow you to run any kind of dev version
17:16:29 <ckotte> ok. want to try the opensource version of tower soon. not sure if I need to rewrite my Ansible playbooks etc. pp....
17:16:47 <pdellaert> i know places where they are running 2.3 because they do not want to go to a newer release
17:17:13 <ckotte> with the current state of the modules... sorry to say that.. I don't think you can do a professional deployment
17:17:23 <pdellaert> the mentality of 'if it is not broken, do not try to fix it' is very much engraved in many stable professional deployments
17:17:35 <ckotte> you need to wait for Ansible 2.8 with lots of fixes. maybe then it's enterprise ready
17:17:47 <pdellaert> ckotte: i know places where they use them, very happily
17:17:55 <ckotte> ok
17:18:12 <ckotte> I found lots of issues when I started to replace existing PowerCLI automation
17:18:15 <pdellaert> it fits their use cases, they just don't want to jump through every release, because they would need to change their playbooks with every release :)
17:18:52 <ckotte> ok. lets see where we need backporting
17:20:43 <akasurde> ckotte, you can file an issue if you find it because it will create public record and people might want to work on it
17:21:30 <ckotte> aksurde Thats why I fix all modules I (want) to use
17:21:35 <ckotte> cannot wait for someone else
17:21:52 <ckotte> (want to)
17:22:05 <akasurde> ckotte, sure you are always welcome to fix them
17:22:15 <akasurde> thats how community grows
17:22:44 <akasurde> people help each other to solve their common problem and share their knowledge with each other
17:23:03 <moshloop_> Speaking of fixes - I have a couple PR's that are still waiting to be merged
17:23:33 <moshloop_> 44885  and 44832
17:24:59 <akasurde> We are little over meeting time, but we can still discuss after this meeting
17:25:10 <akasurde> moshloop_, let me check
17:28:15 <akasurde> #endmeeting