16:01:57 <Goneri> #startmeeting ansible_vmware_working_group
16:01:57 <zodbot> Meeting started Mon Mar 23 16:01:57 2020 UTC.
16:01:57 <zodbot> This meeting is logged and archived in a public location.
16:01:57 <zodbot> The chair is Goneri. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:57 <zodbot> The meeting name has been set to 'ansible_vmware_working_group'
16:03:45 <mariolenz> do you guys have anything to discuss today? i would.
16:04:19 <Goneri> I've something that I want to introduce quickly.
16:05:04 <mariolenz> sure
16:05:06 <Goneri> for the last 3 weeks, I've been working on the vmware_rest modules. I've prepared a PoC to autogenerate most of the modules, I should be able to do an introduce next weeks.
16:05:26 <Goneri> They are based on the REST API (vs SOAP/pyVmomi)
16:05:34 <Goneri> That's all for me, mariolenz go ahead
16:06:41 <mariolenz> nothing much, but i've opened https://github.com/ansible-collections/vmware/issues/59 and would just like to have a second opinion.
16:08:53 <Goneri> mariolenz, yes, I agree with you. The logic of the module is a bit over simplistic.
16:09:39 <Goneri> #topic https://github.com/ansible-collections/vmware/issues/59
16:10:01 <mariolenz> ok, then i'll start working on a pr. just wasn't sure if failing is the best approach or if someone has a better idea.
16:10:20 <Goneri> #agreed the status of the module should be more consistent.
16:11:05 <Goneri> I don't use this module, and we don't test it in the CI.
16:11:51 <Goneri> Funny thing, I was mentioning the lack of testing of this module like 30 minutes ago :-)
16:12:28 <Goneri> if we want to properly test it we need an AD, which is a bit cumbersome. Especially for one single module.
16:13:24 <Goneri> mariolenz, anything else?
16:15:21 <mariolenz> no, not from me. anyone else?
16:18:46 <pbidkar> Hi Goneri
16:19:19 <Goneri> pbidkar, Hi. As I mention before. I'm working on a script that autogenerate a set of modules.
16:19:52 <Goneri> The input are the Swagger files of the VMware API, and the output, a collection of vmware modules, that are based on the REST API.
16:21:42 <pbidkar> oh! great!
16:22:19 <pbidkar> is it possible to provide some more details
16:22:39 <Goneri> absolutely
16:24:21 <Goneri> there is something called HttpApi, it's a transport layer that  allow a module to reuse an existing HTTP connection
16:24:44 <Goneri> as a result, the different tasks of a playbook are much faster.
16:25:20 <Goneri> The person who did this is Paul Knight. He've also built a couple of demo modules.
16:25:43 <Goneri> pbidkar, e.g: https://github.com/ansible-collections/vmware_rest/blob/master/plugins/modules/vmware_appliance_health_info.py
16:26:34 <Goneri> since these modules are tightly associated with the end point, I started to investigate to see if we can autogenerated them.
16:27:00 <Goneri> pbidkar, my branch is here: https://github.com/goneri/vmware_rest/tree/WIP-automagically-refresh-the-modules
16:27:59 <Goneri> it's still super raw, like a PoC should be :-) But it works and I'm now cleaning everything.
16:28:28 <pbidkar> Ok great progress
16:28:44 <pbidkar> Which framework you are using?
16:29:33 <Goneri> nothing in particuler. I just load the Swagger file, and generates the Python with some template+AST.
16:30:06 <Goneri> pbidkar, do you have anything in mind?
16:36:29 <mariolenz> goneri: the vsphere automation sdk still isn't available through pypi (and i gave up hope that it ever will be) so i think it would be a good idea to migrate the modules that depend on this package to your solution. not now, but when you think your solution is stable enough.
16:41:46 <Goneri> mariolenz, If we validate the PoC, I believe, the two sets of modules will coexist for a while.
16:42:18 <Goneri> for instance, the /rest API of 6.7.0 cannot recreate cluster, just list them.
16:53:54 <mariolenz> i'm thinking of modules that depend on the vsphere automation sdk for the rest stuff. i think there's one for tag management that needs this sdk because there's no tagging supported in the soap api iirc. getting rid of the vsphere automation sdk would be great, it's hell to install in typical enterprise environments. there are very few modules in this category, i think.
16:55:19 <Goneri> Oh indeed. Yes, those are somewhat dumb modules that actually just consumn a REST end-point
16:55:54 <Goneri> the HttpApi module configuration is different, so this is something to take into account too.
17:00:18 <Goneri> #endmeeting