#ansible-windows: Windows Working Group

Meeting started by nitzmahone at 20:01:14 UTC (full logs).

Meeting summary

    1. agenda: https://github.com/ansible/community/issues/153 (nitzmahone, 20:01:51)

  1. Windows setup facts (jborean93, 20:04:50)
    1. https://github.com/ansible/community/issues/153#issuecomment-312738930 (jborean93, 20:04:51)
    2. ACTION: jborean93 to implement gather_subset for windows facts (jborean93, 20:11:54)

  2. https://github.com/ansible/community/issues/153#issuecomment-312966236 backup support (jborean93, 20:12:12)
    1. ACTION: We make a list of possible missing/new facts in the Wiki (dag, 20:18:55)
    2. ACTION: nitzmahone to work on module_utils plugin loader before next week (jborean93, 20:22:06)

  3. https://github.com/ansible/community/issues/153#issuecomment-312974050 windows sprint (jborean93, 20:30:50)
    1. ACTION: @richardcs to propose shared backup code in win_xml PR via powershell.ps1 - we'll hold off merge until shared module_loader is available then rebase and move to separate file handling module_util file (nitzmahone, 20:31:01)
    2. https://github.com/ansible/community/wiki/Windows:-sprints (dag, 20:32:57)

  4. https://github.com/ansible/community/issues/153#issuecomment-313378484 (nitzmahone, 20:49:22)
  5. paths and windows (jborean93, 20:49:22)
    1. ACTION: Dag will make a PR out of this if he finds the correct location to put the pieces (dag, 20:55:09)

  6. https://github.com/ansible/community/issues/153#issuecomment-313718853 -LiteralPath (jborean93, 20:55:46)
    1. ACTION: Look at impact/scope on Windows modules of globs in paths (not using -LiteralPath) (dag, 21:11:14)
    2. ACTION: jborean93 to work on diagnostic script for WinRM (jborean93, 21:20:35)

  7. https://github.com/ansible/community/issues/153#issuecomment-314325343 SID utils (jborean93, 21:22:09)


Meeting ended at 21:34:50 UTC (full logs).

Action items

  1. jborean93 to implement gather_subset for windows facts
  2. We make a list of possible missing/new facts in the Wiki
  3. nitzmahone to work on module_utils plugin loader before next week
  4. @richardcs to propose shared backup code in win_xml PR via powershell.ps1 - we'll hold off merge until shared module_loader is available then rebase and move to separate file handling module_util file
  5. Dag will make a PR out of this if he finds the correct location to put the pieces
  6. Look at impact/scope on Windows modules of globs in paths (not using -LiteralPath)
  7. jborean93 to work on diagnostic script for WinRM


Action items, by person

  1. jborean93
    1. jborean93 to implement gather_subset for windows facts
    2. jborean93 to work on diagnostic script for WinRM
  2. nitzmahone
    1. nitzmahone to work on module_utils plugin loader before next week
  3. UNASSIGNED
    1. We make a list of possible missing/new facts in the Wiki
    2. @richardcs to propose shared backup code in win_xml PR via powershell.ps1 - we'll hold off merge until shared module_loader is available then rebase and move to separate file handling module_util file
    3. Dag will make a PR out of this if he finds the correct location to put the pieces
    4. Look at impact/scope on Windows modules of globs in paths (not using -LiteralPath)


People present (lines said)

  1. dag (128)
  2. nitzmahone (84)
  3. jborean93 (78)
  4. jhawkesworth_ (42)
  5. bcoca (7)
  6. zodbot (4)
  7. pablodav (4)
  8. jhawkesworth (0)


Generated by MeetBot 0.1.4.