20:03:55 <nitzmahone> #startmeeting Ansible Windows Working Group
20:03:55 <zodbot> Meeting started Tue Apr 24 20:03:55 2018 UTC.  The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:03:55 <zodbot> The meeting name has been set to 'ansible_windows_working_group'
20:04:04 <jhawkesworth_> hello
20:04:18 <nitzmahone> Good $greeting_in_your_timezone
20:04:35 <jhawkesworth_> you too
20:04:43 <nitzmahone> #chair jhawkesworth_
20:04:43 <zodbot> Current chairs: jhawkesworth_ nitzmahone
20:05:13 <chopraaa> so uh, how does this work?
20:05:35 * nitzmahone looks at agenda
20:05:40 * chopraaa is confused.
20:06:01 <nitzmahone> https://github.com/ansible/community/issues/294
20:06:26 <nitzmahone> Looks like the only new item is Jordan asking about some changes to Convert-ToSID
20:06:32 <jhawkesworth_> chopraaa: link above is the agenda for the meeting
20:06:56 <nitzmahone> It's a public holiday in Australia today, so Jordan won't be here, but the idea sounds good to me
20:07:01 <jhawkesworth_> I think I kept jordan up late discussiong win_package paths
20:07:26 <nitzmahone> So I guess:
20:07:29 <nitzmahone> #topic open floor
20:07:39 <chopraaa> i posted again
20:08:06 <jhawkesworth_> I have no opinion on having the SID magic.
20:08:25 <nitzmahone> #topic https://github.com/ansible/community/issues/294#issuecomment-384062697
20:08:34 <nitzmahone> (splitting up win_disk_X modules)
20:08:46 <nitzmahone> I'm all for it
20:09:06 <chopraaa> there's a win_disk_mgmt module PR going on
20:09:23 <nitzmahone> That's one of the reasons win_disk_management has been sitting out there
20:09:25 <chopraaa> made me throw up a bit
20:09:36 <nitzmahone> IMO it's trying to do too much
20:09:57 <nitzmahone> I think there hasn't been a consensus that it's something we want to ship in its current state.
20:10:18 <chopraaa> im all up for splitting it into 2 or 3 modules
20:10:27 <nitzmahone> The disk facts I could go either way on, since it's already out there (and IIRC it doesn't take significantly longer to collect all that stuff than to have separate modules for it)
20:10:32 <chopraaa> same for the disk_facts module
20:10:52 <nitzmahone> The difference there being that it's already been shipped
20:10:52 <jhawkesworth_> I haven't had a need to manage windows disks, but prefer smaller modules that do 1 thing well
20:10:58 <nitzmahone> +1000
20:11:17 <jhawkesworth_> yeah no harm in having the existing disk facts module.
20:12:10 <chopraaa> this is what i did that works for me https://gist.githubusercontent.com/chopraaa/18062f052ca3001a807ec038c2f2c0fc/raw/a98df39901a6c2f9e1aaa55c1192c7a6b9398f0d/win_vol.ps1
20:12:43 <jhawkesworth_> if something better can be done I'd rather either see existing disk_facts module enhanced or different facts modules created.  Once they are merged we can think about deprecating others
20:13:13 <chopraaa> the idea was to be able to use params like get-vol uses
20:13:29 <chopraaa> and return more data, using wmi/cim
20:13:31 <nitzmahone> Yeah, I don't think we need to split the disk facts- if there are things missing, feel free to add them to what's there
20:13:46 <chopraaa> sounds good
20:13:47 <nitzmahone> But on the management side for sure
20:14:02 <chopraaa> it's the disk_mgmt module thats the turd in the punch bowl for me
20:14:12 <nitzmahone> Also: be careful about asserting admin rights- you don't necessarily have to be in the admins group to do those thigns
20:14:43 <nitzmahone> Yep, IIRC that PRs been out there for a long time because none of us are big fans either
20:15:22 <jhawkesworth_> I guess win32_Voume has been around for a while - supporting older windows versions (down to S2008 at the moment) is something to bear in mind when working on modules
20:15:23 <chopraaa> when i spoke to dag he said something about being able to include functions like test-admin
20:16:11 <chopraaa> yeah, the current disk_facts module uses get-volume i think
20:16:25 <nitzmahone> Sure, that's what module_utils are for, but you can do those things without being an admin
20:16:33 <chopraaa> which uses msft_volume, for 2012+
20:16:34 <jhawkesworth_> I guess we could have something in module_utils ... but it may be that its dependent on privileges, rather than users
20:16:36 <nitzmahone> So that test is overly restrictive in nearly all cases
20:16:36 <chopraaa> gotcha
20:17:21 <chopraaa> so whats the way to go if a module is using a combination of cmdlets that use/dont use admin privs?
20:17:33 <nitzmahone> Anyway, sounds like you've got several of us that would be willing to review and work with you on more granular disk management modules if you want to get the ball rolling
20:17:52 <nitzmahone> Easiest is to just let the underlying stuff fail if the privilege is missing
20:17:58 <nitzmahone> It's ugly, but it works.
20:18:14 <nitzmahone> Once you know what the privileges are, you can assert them yourself directly if you want
20:18:34 <chopraaa> alright
20:18:34 <nitzmahone> But I'd rather delegate to the underlying system protections than place overly restrictive tests that are unnecessary
20:18:55 <nitzmahone> "Access denied" is usually pretty descriptive ;)
20:19:21 * jhawkesworth_ hates seeing "access is denied" so much
20:19:25 <nitzmahone> (though if you know what the more granular tests are, it's nice to fail with a prescriptive "do you have priv X?"
20:19:55 * chopraaa scratches head.
20:19:57 <jhawkesworth_> but yeah, please catch it and return a message that gives the user a clue how to fix the issue if you can
20:20:02 <chopraaa> no habla engles
20:20:11 <chopraaa> ok i got this ^
20:21:10 <nitzmahone> OK, anything else for today?
20:21:12 <jhawkesworth_> so yeah, go ahead, make some PRs
20:21:33 <nitzmahone> #agreed chopraaa to hack on more granular disk management modules
20:21:35 <chopraaa> so its cool if i switch things around right?
20:21:52 <chopraaa> and replace the get-vol get-disk stuff with cim
20:22:03 <nitzmahone> Do whatever you like for the new stuff, but don't break existing functionality in stuff that's already shipped (eg win_disk_facts)
20:22:06 <chopraaa> since we're talking about support for 2003+ then
20:22:21 <nitzmahone> Well, 2008+, since Ansible's not supported on anything less
20:22:25 <jhawkesworth_> fortunately ansible won't talk to 2003
20:22:40 <chopraaa> i'll keep the output the same, just use cim or wmi
20:22:58 <chopraaa> and add more facts since i use them myself
20:23:09 <jhawkesworth_> but yes CIM/WMI more likely to be compatible with older windows, so go ahead
20:23:12 <nitzmahone> Sounds like a plan- looking forward to seeing them
20:23:16 <chopraaa> and i guess anyone dealing with webhosting would bump into the same issues i did
20:23:54 <jhawkesworth_> perhaps, I have no experience of webhosting
20:24:02 <chopraaa> and about jordan's pypsexec module
20:24:21 * chopraaa is curious about it's status.
20:24:30 <jhawkesworth_> maybe best to wait till jordan is around to quiz him on that
20:24:31 <nitzmahone> I just approved for 2.6
20:24:35 <chopraaa> Is that getting added or did i miss the merge?
20:24:35 <jhawkesworth_> cool
20:24:40 <chopraaa> cool
20:25:00 <chopraaa> well thats it for me
20:25:12 <nitzmahone> I think he was going to tweak a couple more little things, but yeah, I :thumb
20:25:30 <nitzmahone> gave it the thumbs up yesterday
20:25:40 <jhawkesworth_> nothing from me, book stuff is parked so started looking at issues and PRs again this week
20:25:46 <chopraaa> yeah it's great
20:25:48 <nitzmahone> OK, short and sweet. 2.5.2 ships next week.
20:26:14 <nitzmahone> (and future 2.5 releases will be every 2 weeks for awhile)
20:26:36 <nitzmahone> Thanks all!
20:26:37 <jhawkesworth_> great.
20:26:40 <nitzmahone> #endmeeting