20:00:00 <nitzmahone> #startmeeting Ansible Windows Working Group
20:00:00 <zodbot> Meeting started Tue Nov 10 20:00:00 2020 UTC.
20:00:00 <zodbot> This meeting is logged and archived in a public location.
20:00:00 <zodbot> The chair is nitzmahone. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:00 <zodbot> The meeting name has been set to 'ansible_windows_working_group'
20:00:03 <nitzmahone> bam
20:00:09 <nitzmahone> #chair jborean93
20:00:09 <zodbot> Current chairs: jborean93 nitzmahone
20:00:18 <jborean93> hey
20:00:34 <nitzmahone> #link agenda https://github.com/ansible/community/issues/517
20:00:48 <briantist> 👋
20:00:48 <nitzmahone> There's actually something on it today!
20:00:56 <nitzmahone> hey briantist
20:01:06 <nitzmahone> #topic https://github.com/ansible/community/issues/517#issuecomment-724853726
20:01:30 <nitzmahone> #topic should we move IIS modules to a dedicated collection?
20:01:36 <briantist> hey hey, today's topic comes from mhunsber in the convo right above this meeting! Welcome mhunsber
20:01:39 <nitzmahone> mhunsber: you around?
20:01:52 <mhunsber> yes
20:02:16 <mhunsber> hello!
20:03:06 <nitzmahone> So you're proposing a dedicated collection for the IIS modules, but they're already in `community.windows`
20:03:28 <nitzmahone> Usually things move to a dedicated collection when there's an active community that wants to release things on a different schedule
20:04:23 <nitzmahone> I don't think there'd be any objection to making changes/additions to the existing modules in their current home, nor if someone wants to take a more active role as a maintainer
20:04:52 <nitzmahone> But moving to a dedicated collection without a group to maintain seems premature
20:05:19 <nitzmahone> (or maybe I'm missing the point of what you were asking?)
20:05:36 <jborean93> yea we would need to see that there is going to be an active community around it before we would consider moving it
20:05:40 <mhunsber> No, that makes sense to me.
20:06:09 <jborean93> right now it's mostly just me trying to find some time to do the reviews on community.windows
20:06:51 <nitzmahone> Community validation on that kind of thing is always welcome, whether it's "this change works for me" or code review, or whatever ;)
20:07:38 <jborean93> yep, right now it's mostly just me looking at the code and making sure it conforms to newer standards with tests if possible
20:07:55 <briantist> mhunsber: what would you say were the things that most made you consider a separate collection? Or maybe better question is what would you like to do most urgently (new modules, updates to existing, etc.)?
20:08:54 <mhunsber> Originally I was just going to have my own collection to be able to experiment easier. Mostly new modules is what I was hoping to add.
20:09:34 <nitzmahone> You can absolutely do that anyway :D
20:09:35 <mhunsber> To backtrack, I started this conversation by asking how I could run the windows integration tests in my own shippable account
20:10:56 <mhunsber> I was told it'd have to be from the community.windows repository in order to do that.
20:11:38 <nitzmahone> Well, it doesn't *have* to be, but that's the easiest way. Otherwise you'd need to set up your own CI resource provider to create cloud Windows nodes from your own AWS account
20:12:37 <mhunsber> sure. I'm totally okay with them staying in community.windows. I was under the impression that new iis modules wouldn't be received well, but that could have just been the sentiment before collections were realized
20:12:38 <jborean93> that's always been a major problem with testing Ansible content against windows
20:13:25 <jborean93> definitely was the way things were before collections, I wouldn't be opposed to adding any more as long as they have tests
20:14:18 <nitzmahone> Yeah, the point of splitting the supported / community stuff out of Ansible itself was to allow everything to evolve more quickly
20:14:41 <jborean93> plus not having the expectations that we will support the community stuff
20:14:45 <nitzmahone> (but especially the community stuff, where we can now relax the rules a bit since those bits aren't being shipped in a Red Hat supported package anymore)
20:15:31 <briantist> fwiw I run the existing integration tests locally with `ansible-test` against hosts I stood up in my own environment. It's not the best, since I have to manage/provision the hosts outside the testing process, and the only way to supply the  list of hosts and credentials is through the `inventory.winrm` file. But if you take care of that, actually running the tests is easy
20:16:23 <jborean93> yea same thing, it's just the CI part that's not really easy to do unless you have our credentials
20:16:28 <nitzmahone> if you're doing a lot of maintenance/testing on existing modules, you might also be able to talk us out of API keys for ansible-test that would let you do local runs against our cloud resources... Just sayin' (and no guarantees, but it's been done)
20:16:51 <briantist> 👀
20:18:03 <briantist> I don't think I do enough to warrant that yet but I'll remember that as a possibility :)
20:18:33 <mhunsber> I probably won't be doing enough tests to warrant that, I can definitely provision my own hosts. I'm still experimenting on/off with ansible in our environment, so I'll write modules when I need them.
20:18:35 <nitzmahone> Dunno what kind of bar mattclay might want to set on such a request, since he's the one that has to pay the sizeable bill each month (for now anyway) ;)
20:20:56 <nitzmahone> So we all good with that topic mhunsber?
20:20:59 <bcoca> well, not him him. but he is responsible for it
20:21:20 <mhunsber> yeah! I am glad that with collections the rules are a little more flexible
20:21:28 <mhunsber> thank you
20:21:40 <nitzmahone> Cool, we'll be awaiting your PRs to Improve All The Things! ;)
20:22:05 <nitzmahone> (and if you're really passionate about it and crank out good stuff, we're also always looking for maintainers)
20:22:35 <nitzmahone> #agreed IIS modules stay in current collection, mhunsber may start contributing
20:22:39 <nitzmahone> #topic open floor
20:23:45 <jborean93> I'm all good
20:23:53 <nitzmahone> (will close in 2min if nothing else)
20:24:02 <briantist> same, nothing new from me
20:24:17 <jhawkesworth> hey, sorry forgot time change, but I have nothing again
20:24:23 <nitzmahone> hey Jon!
20:24:26 <jhawkesworth> heya
20:25:17 <nitzmahone> OK then, til next week- thanks all!
20:25:21 <nitzmahone> #endmeeting