19:59:59 <nitzmahone> #startmeeting Ansible Windows Working Group
19:59:59 <zodbot> Meeting started Tue Oct 25 19:59:59 2022 UTC.
19:59:59 <zodbot> This meeting is logged and archived in a public location.
19:59:59 <zodbot> The chair is nitzmahone. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:59:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:00 <zodbot> The meeting name has been set to 'ansible_windows_working_group'
20:00:03 <nitzmahone> bah
20:00:09 <nitzmahone> #chair jborean93
20:00:09 <zodbot> Current chairs: jborean93 nitzmahone
20:00:17 <nitzmahone> #info agenda https://github.com/ansible/community/issues/644
20:00:17 <jborean93> yo
20:00:31 <nitzmahone> #topic next c.w release
20:01:01 <jborean93> I've been meaning to get to it, fest now my imprisonment in the hotel has delayed me a bit but will look at pushing a new release next week
20:01:17 <nitzmahone> noice
20:01:37 <nitzmahone> #action jborean93 to work toward new c.w release next week
20:01:54 <nitzmahone> and with that, the agenda's empty, so
20:01:57 <nitzmahone> #topic open floor
20:02:07 <nitzmahone> we'll wait until 5 after for any new topics
20:02:22 <jborean93> I've got nothing important, just doing the Python 3.11 rounds on my modules with C extensions
20:03:22 <nitzmahone> 🤞 all the wheels  I released on 3.11 pre-releases have no issues with GA version, though I imagine I'd have heard something by now if they did
20:03:48 <jborean93> it doesn't help that GHA deprecated node 12 and most actions I have need to be updated at the same time
20:03:50 <nitzmahone> Do you build for any of the "exotic" arches, or just Intel?
20:04:00 <jborean93> intel and arm on macOS
20:04:11 <nitzmahone> (cross compile with no tests, I assume?)
20:04:18 <jborean93> pretty much unfortunately
20:05:18 <nitzmahone> Whenever I get my webhook receiver cleaned up, you're welcome to add any of your projects onto the MacStadium setup I have for that...
20:05:35 <jborean93> I probably should, it's just more moving parts in CI :(
20:05:57 <nitzmahone> Right now it requires one instance of the worker host per org/user, which doesn't scale very well :D
20:06:29 <nitzmahone> The webhook receiver can have tokens for as many orgs as we want though, and the worker doesn't start until the job asks for it
20:07:07 <nitzmahone> Reminds me I also need to upgrade everything to Ventura now that it's released
20:07:28 <jborean93> oh and fun, 3.11 on GHA for macOS isn't out yet
20:07:40 <nitzmahone> at all, or it's still on an RC?
20:07:53 <jborean93> https://github.com/actions/setup-python/issues/531
20:08:09 <nitzmahone> meh, that's what cibuildwheel is for :D
20:08:21 <jborean93> yea I'm just going to skip it for now on the test stage
20:08:24 <nitzmahone> They're usually up to date within a few hours of a release
20:08:26 <jborean93> cibuildwheel works at least
20:09:40 <nitzmahone> Testing off the built wheels for everything is kinda my default now- the overhead of building the wheels is relatively negligible, and it's really nice to know that the final package artifact has actually been put through its paces.
20:10:13 <jborean93> yea all my CI stuff is set up to build the sdist, then the wheel from that sdist and finally run the test on the wheels/sdist
20:10:26 <nitzmahone> (ie cibuildwheel does pretty much 100% of my tests under it, so I just have the one Python version everywhere that hosts cibuildwheel)
20:10:45 <jborean93> so you use cibuildwheel to run the tests?
20:10:48 <nitzmahone> yeah
20:11:07 <nitzmahone> So I don't care what's available on GHA, cibw grabs a manylinux container or installs from Python.org or whatever anyway
20:11:49 <jborean93> probably something I should move towards at some point, reducing as much as I can from GHA is always a good thing IMO
20:12:10 <nitzmahone> Dunno if they finally fixed the "bring your own Python" on the Mac stuff- they had a couple PRs open for it, but that was the main reason I couldn't get 3.8 builds working for the XCode Python 3.8
20:12:51 <nitzmahone> It's a bit of extra hassle initially to get the test stuff configured for cibw since you have to set it all up via envvars, but once it's going, it's quite nice
20:13:05 <nitzmahone> (since then the whole build basically works the same no matter where you run it)
20:13:09 <jborean93> yea, plus more easily runnable locally
20:13:15 <nitzmahone> exactly
20:13:33 <nitzmahone> Made life a lot easier for the things I still have to let Travis do
20:13:44 * nitzmahone spits
20:14:07 <jborean93> yea I don't have people clamoring for "estoric architecture"
20:14:38 <nitzmahone> and as predicted as soon as I had musllinux Intel wheels, people are asking for ARM versions of those as well
20:14:52 <jborean93> no rest for the wicket
20:14:55 <jborean93> wicked*
20:15:09 <nitzmahone> no good deed goes unpunished
20:15:39 <nitzmahone> Not adding ARM builds for those until either GHA has ARM Linux workers or I finish the generic webhook receiver
20:15:57 <nitzmahone> (then we can do Windows on ARM builds too, yay)
20:16:29 <nitzmahone> welp, gonna hang it up for today- til next week!
20:16:31 <nitzmahone> #endmeeting