16:52:33 <meskarune> #startmeeting #archlinux-women
16:52:33 <zodbot> Meeting started Sat Sep 12 16:52:33 2020 UTC.
16:52:33 <zodbot> This meeting is logged and archived in a public location.
16:52:33 <zodbot> The chair is meskarune. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:52:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:52:33 <zodbot> The meeting name has been set to '#archlinux-women'
16:52:53 <meskarune> #chair jy2wong
16:52:53 <zodbot> Current chairs: jy2wong meskarune
16:52:58 <jy2wong> ooh shiny
16:52:59 <meskarune> #chair NetSysFire
16:52:59 <zodbot> Current chairs: NetSysFire jy2wong meskarune
16:53:35 <meskarune> fedora is sponsoring the bot for us
16:54:03 <NetSysFire> as mentioned in https://archwomen.org/wiki/meetings:2020_august
16:54:04 <phrik> Title: 63rd IRC meeting [Arch Women Wiki] (at archwomen.org)
16:54:50 <meskarune> #meetingtopic Rebooting AW
16:55:49 <meskarune> #topic announcements
16:56:34 <jy2wong> fancy
16:56:47 <meskarune> #info We are at 7 years running now \o/
16:57:42 <meskarune> #info The server and dokuwiki software has been kept up to date and currently at latest versions
16:58:24 <meskarune> But later on we will talk about wiki content updates
16:58:38 <meskarune> people with chair can also do those commands
16:58:49 <meskarune> I think XD
16:59:21 <meskarune> #info Fedora is sponsoring a meeting bot for us which saves logs and notes
16:59:45 <meskarune> #link https://fedoraproject.org/wiki/Zodbot about the meeting bot
16:59:46 <phrik> Title: Zodbot - Fedora Project Wiki (at fedoraproject.org)
17:00:41 <meskarune> #info tigrmesh is on hiatus from irc and we wish her the best
17:01:13 <meskarune> do we have more announcements?
17:01:40 <NetSysFire> we need to overhaul some of the stuff
17:01:57 <NetSysFire> many things are outdated and we are working on it
17:02:21 <jy2wong> meskarune: something about dokuwiki updates?
17:03:14 <meskarune> #topic dokuwiki
17:04:07 <meskarune> so we need a plan to get the wiki docs organized
17:04:27 <NetSysFire> and to eliminate the dozen todolists
17:04:43 <meskarune> Yes lol
17:04:46 <jy2wong> #info NetSysFire notes the many, many todo lists
17:04:57 <meskarune> Hehe :D
17:05:05 <NetSysFire> its meta todo at this point
17:05:18 <NetSysFire> Luyin said maybe a kanban board is better for todo stuff
17:05:24 <NetSysFire> i also think so btw
17:05:27 <meskarune> NetSysFire made headway on the wiki and really did alot of work
17:05:38 <jy2wong> shall we use the riseup to put down explicit action items?
17:06:08 <jy2wong> or use zodbot?
17:06:08 <meskarune> the bot also has #action tags
17:06:15 <jy2wong> neat
17:06:42 <jy2wong> do we need a pad any more then? lol
17:06:43 <meskarune> and link, idea, accepted and rejected
17:06:53 <NetSysFire> #commands
17:06:53 <zodbot> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #rejected #restrictlogs #save #startmeeting #topic #unchair #undo #unlurk
17:07:21 <meskarune> jy2wong: the idea was that the bot would automate meeting note so we wouldn't need to find people to take notes and make logs
17:07:38 <jy2wong> rad
17:08:10 <meskarune> So I agree the Wiki is not really great fortitude lists
17:08:25 <meskarune> *to-do lists
17:08:53 <meskarune> I also like kanbans or ticket things
17:09:42 <NetSysFire> kanban is really really nice
17:09:47 <meskarune> But it should be easy to admin too, and I'm hard no on anything in ruby lol
17:09:49 <NetSysFire> we could self-host it with wekan
17:10:36 <meskarune> Specifically ruby on rails, its annoying to keep updated
17:11:25 <NetSysFire> i also saw that someone made a kanban board with a game engine
17:12:37 <NetSysFire> but yeah, we should probably think about possible todo-list solutions. kanban boards, tickets something like this
17:12:40 <meskarune> I don't know much about the current kanban offerings
17:13:11 <jy2wong> I see that wekan has a docker image available, but the warnings about it are ehhhhh
17:13:20 <meskarune> #action research kanban and ticket systems for a todo list so it is moved off the wiki
17:13:48 <jy2wong> "If yu use Standalone Wekan on public Internet, it's better to get automatic security updates with Snap and restore from backup when needed, than to leave old vulnerable manually updated Docker Wekan running.
17:13:50 <jy2wong> With Docker Wekan you still need at least daily backups, if some bug causes Wekan board to not load."
17:14:19 <NetSysFire> wekan with docker is awful
17:16:46 <meskarune> Maybe there is something that uses sqlite or a flat file so I don't have to admin mysql server and setup db backups
17:17:07 <meskarune> We used to do that and moved away from it
17:17:25 <NetSysFire> i know that wekan can also use mongodb it seems?
17:18:01 <meskarune> Oh I see. Are db dumps simple with mongo?
17:18:25 <meskarune> But maybe we are getting off topic though we can spend the next month to do some research and play around with self hosted Solutions
17:18:27 <NetSysFire> should be
17:18:35 <meskarune> Right now we should get a list of actions to do for the month
17:18:55 <NetSysFire> but the host running wekan (in docker) suffered a power outage, and mongodb didnt like this at all
17:19:09 <NetSysFire> so there was some data loss because we didnt have backups
17:19:32 <meskarune> So then the plan for updating the wiki pages, should we have a wiki cleanup every 2 weeks or some kind of sprint or event?
17:20:25 <meskarune> #idea wekan kanban software
17:20:58 <NetSysFire> i wonder if it would make sense to start fresh. import all the stuff like meetings ofc but many things that are documented dont exist anymore
17:21:40 <meskarune> Maybe I can make an archive namespace and move old stuff into the archive?
17:21:50 <NetSysFire> that would be an idea
17:22:04 <meskarune> There are a lot of link backs to Wiki pages so I don't know if I can just wholesale remove things
17:22:13 <NetSysFire> yeah we need to keep that
17:22:23 <NetSysFire> and we need to plan this before we do this
17:22:29 <NetSysFire> but i dont know how it looks from the server side. there can be leftover configs and plugins, etc
17:22:54 <meskarune> #idea move documents for old software and projects to an archived namespace on the wiki
17:23:38 <meskarune> the plugins and things should be cleaned up now
17:24:19 <meskarune> all of the backend is updated, just wiki theme
17:24:57 <meskarune> #action update the wiki theme - meskarune
17:25:40 <NetSysFire> i recently tried to reverse engineer the infrastructure because missing docs, sangy tried to help me a bit
17:25:43 <meskarune> Maybe we can have a separate meeting for the Wiki updates
17:25:55 <NetSysFire> i also asked yar but they said they werent involved too much
17:26:01 <meskarune> So its organized sprint
17:26:13 <NetSysFire> yeah, another meeting would make sense
17:27:25 <meskarune> yar does alot of irc wrangling and can fix the server when its down
17:28:31 <meskarune> I have mostly been doing the server admin
17:29:16 <meskarune> The main thing we need to get updated is the website content
17:29:39 <meskarune> Then maybe focus on projects like mentorship and classes
17:30:02 <meskarune> It's currently a small number of contributors so we have to choose a small Things each month to work on
17:30:22 <NetSysFire> https://archwomen.org/wiki/aw-tech:vms:web:start https://archwomen.org/wiki/aw-tech:vms:data:start i made some pages for the vms and added you as the maintainer. i didnt find much on the wiki that describes which one is responsible for what
17:30:23 <phrik> Title: Webserver VM [Arch Women Wiki] (at archwomen.org)
17:30:39 <NetSysFire> so you are also the "maintainer" of the classes and mentorship projects?
17:31:01 <meskarune> NetSysFire:  no those are group things
17:31:20 <meskarune> In the past people have taken turns teaching classes and such
17:32:55 <meskarune> So for the next action item can we set next Saturday as a date for Wiki clean up? Or maybe thurs
17:33:36 <NetSysFire> i would be available on both
17:34:45 <meskarune> Ok, maybe I can ping you thurs and if I am sicker at the doctors and we can go to Saturday
17:35:21 <meskarune> #action wiki sprint on thurs with sat backup date
17:35:29 <NetSysFire> sounds good to me
17:36:13 <meskarune> #topic flask site
17:36:38 <meskarune> #info some information also needs updating
17:36:55 <meskarune> It's not as behind us 2 Wiki so maybe that can be a good thing for next month?
17:37:06 <meskarune> omg speech-to-text fail
17:37:23 <NetSysFire> the git mirror is still broken afaik?
17:37:44 <NetSysFire> i know that Luyin has created a PR regarding some outdated information
17:37:49 <meskarune> I looked into it and it seems like getting a public key error for the user to get hub
17:38:04 <meskarune> NetSysFire: the pr was merged but not mirrored to get hub
17:38:43 <meskarune> lol get hub.  sorry it's the speech-to-text
17:39:31 <meskarune> #action on the next monthly meeting discuss plan for updating the flask site further
17:39:59 <NetSysFire> the flask site also needs better docs so contributing to it will be easier
17:39:59 <meskarune> okay so we change topic to projects?
17:40:09 <meskarune> NetSysFire: yeah heh
17:40:24 <NetSysFire> should also be here: https://archwomen.org/wiki/aw-org:todo4real
17:40:25 <phrik> Title: Todo [Arch Women Wiki] (at archwomen.org)
17:40:30 <meskarune> atm its git repo witth markdown
17:41:24 <meskarune> #topic projects
17:41:48 <meskarune> #idea revive mentoring program
17:42:43 <meskarune> I think there is a private wiki page that lists mentors with skills. Previously the idea was that somebody could message the IRC or mailing list requesting a mentor and then we could look at the list to recommend someone.
17:43:20 <NetSysFire> its still permission denied for me
17:43:39 <meskarune> Mentor program is specifically for mentoring female identified folks
17:43:50 <meskarune> NetSysFire: the only people who have access are in the mentoring group
17:43:54 <NetSysFire> ah alright
17:44:02 <NetSysFire> how do you "identify" people?
17:44:11 <meskarune> basically we didn't want to have a list of people for trolls to use to dox
17:44:17 <meskarune> so having it public wasn't an option
17:44:43 <NetSysFire> yeah that would be pretty bad
17:45:34 <meskarune> I think before it can be revived Wiki needs to get cleaned up
17:46:15 <NetSysFire> so its crucial to clean the wiki up, so we can continue to revive other projects
17:46:27 <meskarune> #info wiki needs cleaning up before mentorship can be revived
17:47:41 <meskarune> #commands
17:47:41 <zodbot> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #rejected #restrictlogs #save #startmeeting #topic #unchair #undo #unlurk
17:48:18 <meskarune> Okay so should we move to the last topic which is arch conf?
17:49:02 <meskarune> I think we have a list of actions now to take into next month or so
17:50:14 <meskarune> #topic community
17:50:30 <meskarune> #info Arch Linux is hosting an online conference
17:50:55 <meskarune> #info they are also looking for contributors
17:51:12 <meskarune> #action make a post on Twitter to advertise this
17:51:19 <meskarune> #link https://conf.archlinux.org/posts/arch_conf_online_2020/
17:51:21 <phrik> Title: Arch Linux (at conf.archlinux.org)
17:51:34 <meskarune> #topic open floor
17:51:59 <meskarune> Okay now we can do some open for discussion we can have some new ideas listed and any relevant links and things that might be useful
17:52:44 <meskarune> I want to say welcome to all the new people and it has been amazing to meet you all
17:53:19 <NetSysFire> one thing that would certainly be useful to new people in the future are translated (wiki) pages
17:53:28 <NetSysFire> especially stuff like the "how to help" pages etc
17:53:36 <meskarune> #idea translated wiki pages
17:54:07 <meskarune> Also in general I think we should try to do some more outreach
17:54:22 <NetSysFire> you mentioned ical files so people can have meetings and other things in their calendar
17:54:32 <meskarune> #idea do more outreach
17:54:52 <meskarune> NetSysFire: those are on the server now but I just have to add a link
17:55:26 <NetSysFire> nice!
17:55:36 <meskarune> https://archwomen.org/media/archwomen.ics
17:55:58 <meskarune> The event list on the front page is generated from that file
17:56:17 <meskarune> I can be imported into Thunderbirds lightning or another calendar software
17:56:27 <NetSysFire> what about https://lists.archlinux.org/listinfo/arch-women?
17:56:28 <phrik> Title: arch-women Info Page (at lists.archlinux.org)
17:57:17 <meskarune> That's listed on the front page now
17:57:39 <meskarune> My goal is to post meeting agendas on there before the meetings
17:57:53 <meskarune> And maybe have some pre meeting discussions
17:59:53 <NetSysFire> so we also revive the ml
18:01:42 <meskarune> #idea use mailing list more with organizing meeting agenda and projects
18:02:20 <meskarune> Is there anything else for the open floor?
18:02:44 <meskarune> If not I can end the meeting
18:03:04 <NetSysFire> i have some stuff about infrastructure, but this doesnt have to be in the meeting i guess
18:03:34 <meskarune> loke questions or ideas?
18:04:16 <meskarune> I think you can add ideas since you are a chair :P
18:04:17 <jy2wong> do we have an action item for documenting infra?
18:04:17 <NetSysFire> its about the missing documentation. as i already mentioned, i tried my best to reverse engineer the infrastructure to contribute some documentation
18:04:39 <meskarune> jy2wong: yeah there is going to be a Wiki Sprint on Thursday with Saturday as backup date
18:06:22 <NetSysFire> i asked yar but they said "i haven't really been involved and don't know the answers offhand, but i do have shell access. i can give shell access to others."
18:08:08 <meskarune> NetSysFire: maybe you can post a list of your questions in the death Channel and then I can get to them when I'm evil
18:08:17 <meskarune> omfg lol
18:08:32 <meskarune> death/dev and evil/able
18:08:43 <meskarune> Maybe both work lol
18:09:18 <NetSysFire> yeah sounds like a plan
18:09:26 <meskarune> ok :D
18:10:08 <NetSysFire> i mean i also asked you this but you didnt feel good at this time. i will compose a list of things that need to be documented
18:10:23 <meskarune> ok thanks so much
18:10:38 <meskarune> I am having a very bad health week ><
18:10:49 <meskarune> hopefully it gets sorted out soon
18:11:09 <meskarune> fun of being disabled
18:11:26 <meskarune> Is there any more topics to add or should I end the meeting now?
18:11:33 <NetSysFire> i tried to reverse engineer as much as possible but there are many things i couldnt find out
18:11:41 <NetSysFire> i hope you will feel better soon
18:11:50 <meskarune> thanks :)
18:11:55 <NetSysFire> oh and should we also mention that archwomen.org is now on the hsts preload list?
18:12:10 <meskarune> #topic announcements
18:12:27 <meskarune> NetSysFire: you can add that other info item
18:12:46 <NetSysFire> #info archwomen.org is now on the HSTS preload list
18:12:56 <meskarune> \o/
18:13:15 <meskarune> ok
18:13:24 <meskarune> #topic open floor
18:13:32 <NetSysFire> oh and we also improved the ssl config
18:13:53 <meskarune> I think that can dispute document it into Wiki
18:14:10 <NetSysFire> speech to text fail?
18:14:18 <meskarune> yes
18:14:21 <meskarune> lol
18:14:37 <meskarune> I have a migraine and I can barely read atm or type
18:15:00 <NetSysFire> yeah thats alright, most of it is readable but i dont know what dispute should mean
18:15:39 <meskarune> can be documented
18:15:55 <meskarune> no clue how it got dispute from that lol
18:16:10 <meskarune> Okay I will go ahead and end meeting
18:16:17 <NetSysFire> yes
18:16:31 <meskarune> #endmeeting