14:32:33 <jzb> #startmeeting Atomic CentOS SIG
14:32:33 <zodbot> Meeting started Tue Oct 28 14:32:33 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:32:33 <centbot> Meeting started Tue Oct 28 14:32:17 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:34 <centbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:33:01 <jzb> here's what I know right now - Ian got pretty far along on a test build system.
14:33:13 <jzb> Sent credentials/login info to me, jbrooks and walters
14:33:30 <jzb> Evolution: AFAIK, we're still waiting on a CentOS system, though
14:33:45 <walters> my high level status is: hoping to figure out how to maintain srpms, watching the CBS ad-hoc upstreams discussion
14:33:46 <jzb> Evolution: any idea how we can make sure that's ready to go by Monday when he returns from PTO?
14:34:07 <jzb> walters: what's the missing info on maintaining SRPMs?
14:34:23 <walters> how multiple people can collaborate on them
14:34:33 <walters> a dist-git like model is one approach
14:35:07 <jzb> #action jzb get info on SRPM collaboration.
14:35:28 <Evolution> jzb: nope. the box hasn't been reprovisioned yet, and I'm not really active on that side of the centos bits. that'd be more kb
14:35:55 <jbrooks> Here's a Q: we now have some pkgs in the CBS that we need for our images, such as a updated docker -- what's the repo where these can live?
14:35:56 <Evolution> afaik ian's working on a system local to him, so he shouldn't be completely blocked.
14:36:20 <jzb> Evolution: Right, we're just still way outside the CentOS build system.
14:36:22 <Evolution> jbrooks: there's a wider discussion going on about that on the -devel list right now.
14:36:22 <jbrooks> So we can include them in our trees
14:36:59 <jbrooks> Evolution, ok
14:37:00 <Evolution> jbrooks: currently you can use the unsigned packages via http://cbs.centos.org/repos/ but that's not really 100% proper.
14:37:20 <Evolution> but we're having a broader discussion about signing/distributing community packages on the list
14:38:02 <jbrooks> Evolution, ah, got it -- this does work for now, though
14:38:19 <jzb> Evolution: http://lists.centos.org/pipermail/centos-devel/2014-October/012157.html <-- that?
14:39:08 <jbrooks> http://cbs.centos.org/repos/atomic7-testing/x86_64/os/Packages/
14:39:09 <Evolution> yep.
14:39:12 <jbrooks> for instance
14:39:47 <jzb> #info discussion about signing/distributing community packages: http://lists.centos.org/pipermail/centos-devel/2014-October/012157.html
14:40:04 <jzb> Evolution: so - how do things like that get decided?
14:40:22 <jzb> Evolution: that is, curious how long it will take to reach a decision/consensus.
14:40:45 <jbrooks> I think that that overarching SIG stuff would be for the board, right?
14:42:15 <jbrooks> Another high-priority item is identifying a place for updates to live -- test updates for the test images
14:43:22 <jbrooks> "Official" updates and images should wait for the signing to be settled, but we don't have to hold everything for that
14:44:01 <jzb> what about the space where kbsingh was uploading previously?
14:44:56 <jzb> http://cloud.centos.org/centos/7/devel/
14:44:58 <jzb> I believe
14:45:12 <Evolution> that's going to be restructured/redone.
14:45:30 <jzb> Evolution: oh... what's the plan there?
14:46:16 <jzb> Evolution: are you talking about just cloud.centos.org?
14:46:32 <Evolution> both.
14:46:55 <jzb> Evolution: so, pending discussion tomorrow?
14:47:03 <Evolution> correct.
14:47:13 <jzb> Evolution: ok, so ... how to get a permanent URL for landing Atomic images by next week?
14:47:17 <jzb> and trees?
14:47:37 <jbrooks> yeah, the trees is what we don't have at all right now
14:48:24 <Evolution> the trees I would assume is on imcleod
14:48:36 <jzb> Evolution: providing or storage?
14:48:40 <Evolution> the packages from the build system are up at the url mentioned above.
14:48:56 <jzb> Ian should be providing the trees once we get the first image, etc. sure.
14:49:17 <Evolution> ian's making the images isn't he?
14:49:20 <jzb> in fact, we probably want to have a update pretty dang quickly after the first image is out so people can test that functionality.
14:49:27 <jzb> Evolution: yeah.
14:49:42 <jbrooks> Evolution, when you type rpm-ostree upgrade, or whatever, you need to reach some web server w/ the updates
14:49:53 <Evolution> jbrooks: ah, I see now.
14:50:17 <jzb> Evolution: we'll give you the bits, we just need somewhere to stash them :-)
14:50:27 <walters> this is the largest scope item probably - for example, i think we'd want instances in AWS to hit the CentOS mirrors there
14:51:01 <Evolution> but we don't want to burden *all* mirrors with atomic images either.
14:51:08 <Evolution> I'm unsure how we would carve that out.
14:51:17 <walters> there are images and trees
14:51:23 <walters> trees are pre-composed packages
14:51:24 <Evolution> this is something we'd have to discuss with fabian
14:52:18 <jzb> Evolution: I know MM updates are also on Ian's radar after we get images
14:52:35 <jzb> so: Image -> tree -> signing -> mirrors
14:52:43 <Evolution> jzb: right, but we're not currently using MM, and I'm not aware of any plans to move to it.
14:52:47 <jzb> generally the schedule I have mentally.
14:53:04 <jzb> Evolution: O RLY? My bad. I thought CentOS did.
14:53:09 <jzb> Evolution: what does CentOS use then?
14:53:46 * jzb thought Mirror Manager was one of the few universally used pieces.
14:53:53 <Evolution> msync I believe. this is why I mentioned needing to discuss with fabian.
14:54:19 <Evolution> we couldn't use mirrormanager due to missing features in it for a number of years.
14:54:26 <jzb> huh. OK.
14:54:42 <jzb> this is probably an action for Ian, but I'm going to put it down for myself just to make sure.
14:54:48 <Evolution> the patchset was finally resolved late last year I believe, but by that point.. we're already well away from it.
14:54:55 <jzb> #action jzb follow up with Ian & fabian on msync/mirroring.
14:55:09 <jzb> Evolution: gotcha.
14:55:56 <jzb> Evolution: can I tag you with the action on finding storage for images/trees?
14:56:02 <jzb> pending cloud.centos.org discussion?
14:56:18 <Evolution> sure.
14:56:36 <jbrooks> Evolution, just needs to be a web server spot we can rsync to
14:56:47 <jzb> #action Evolution update on storage for images/trees in the interim before Atomic is fully mirrored, etc.
14:56:49 <Evolution> yeah. it looks like mdomsch makde the fix to mm on 18 Dec of last year.
14:56:51 <jbrooks> Or that someone can
14:56:56 <Evolution> -k
14:57:12 <jzb> what else do we need to touch on this week?
14:57:26 <jzb> walters: you're in limbo on the git discussion. Anything else?
14:58:02 <walters> for image generation, just keep using the internal server and migrate to cbs later?
14:58:47 <jbrooks> Today I'm planning to push a needed syntax change to the json files in our repo on github, and push the repo files needed to build the tree there, as well
14:59:15 <jzb> walters: yes
14:59:46 <jbrooks> I'm using the upstream (fedora and centos) jsons in my updated byo atomic howto: https://github.com/jasonbrooks/byo-atomic
15:00:16 <jbrooks> that also tells ppl how to build their own updates in a container
15:00:24 <jzb> Evolution: btw - Carl asked me this morning if we had a decision on the name.
15:00:38 <jzb> Evolution: AFAIK we've always planned on "CentOS Atomic Host"
15:00:52 <jzb> am I misremembering/forgetting something or was there some discussion we needed to have on naming?
15:01:27 <jbrooks> jzb, we should add that to a pre-launch-decisions checklist
15:02:05 <Evolution> jzb: the name is really whatever you guys decide. that's fine by me, and I like that it lines up with CAH (cards against humanity)
15:02:07 <jbrooks> also, any mods to the pkg list? and how will we consider/choose those -- another pre-official checklist item
15:02:36 <jbrooks> CAH is fine w/ me though
15:02:45 <jzb> Evolution: oooh. Too bad producing media (CDs/DVDs) is effectively dead. I'd love to have a sleeve with the CAH design.
15:03:06 <jzb> maybe we could do a t-shirt
15:03:43 <Evolution> jzb: artwork, or splash page design for wiki and/or cloud.centos landing page.
15:03:44 <jzb> #action jzb send out pre-launch checklist, including final check on name.
15:03:46 <Evolution> (possibly)
15:04:26 <jzb> OK, anything else this week?
15:05:40 <jzb> going once, twice, thrice...
15:05:54 <jzb> OK, thanks all - will send out meeting notes momentarily.
15:05:59 <jzb> #endmeeting