16:04:16 <andreasn_> #startmeeting Cockpit meeting 2014-12-15
16:04:16 <zodbot> Meeting started Mon Dec 15 16:04:16 2014 UTC. The chair is andreasn_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:29 <andreasn_> #meetingname Cockpit
16:04:29 <zodbot> The meeting name has been set to 'cockpit'
16:04:36 <andreasn_> #chair mvollmer stefw sgallagh andreasn
16:04:36 <zodbot> Current chairs: andreasn andreasn_ mvollmer sgallagh stefw
16:04:48 <andreasn_> .hellomynameis andreasn
16:04:49 <zodbot> andreasn_: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
16:04:59 <mvollmer> .hello mvo
16:05:00 <zodbot> mvollmer: mvo 'Marius Vollmer' <marius.vollmer@gmail.com>
16:05:20 <sgallagh> .hello sgallagh
16:05:21 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:05:37 <stefw> .hello stefw
16:05:38 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
16:06:00 <andreasn_> anyone else?
16:06:16 <andreasn_> all right, lets move on
16:06:21 <andreasn_> #agenda
16:06:23 <subin> stefw: sorry the connection became very poor
16:06:27 <stefw> no worries
16:06:38 <stefw> * subin would like to introduce himself
16:06:53 * stefw notes that this is an agenda point
16:07:00 <andreasn_> sure
16:07:04 <andreasn_> what else on the agenda?
16:07:24 <andreasn_> * new journal layout
16:07:34 <stefw> * merging metric channels?
16:07:45 <andreasn_> * server roles
16:07:47 <stefw> * dashboard status
16:08:05 <andreasn_> * problem reporting
16:08:17 <stefw> * RHEL 7.0 build
16:08:18 <subin> Hi folks , I am Subin .Just got started on cockpit. Very interesting so far.Need to invest some time on dbus. Glad to be here.
16:08:26 <stefw> hey subin o/
16:08:30 <stefw> * Debian build and packaging
16:08:46 <andreasn_> subin: hi subin! great to meet you!
16:09:00 <mvollmer> subin, hi!
16:09:12 <mvollmer> subin, what do you want to do with cockpit?
16:09:48 <stefw> he wants to help :)
16:09:53 <stefw> yay
16:09:54 * stefw dances
16:10:01 <mvollmer> nice!
16:10:50 <andreasn_> subin: did you manage to compile it already?
16:11:44 <subin> Nope , I am still reading abt it. I will install today play with sometime
16:12:11 * stefw notes that Fedora 21 Server is the easiest way to install and get started with a stable version
16:12:15 <andreasn_> subin: sounds good
16:12:28 <andreasn_> let us know if you need any help getting it up and running
16:12:46 <subin> still a novice . yep i have f21 now. Sure Thanks.
16:13:55 <stefw> should we start with the agenda?
16:14:00 <andreasn_> yes
16:14:01 <stefw> oh, this is the first point
16:14:14 <andreasn_> lets move to the second then :)
16:14:25 <andreasn_> #new journal layout
16:14:42 <andreasn_> https://github.com/cockpit-project/cockpit/issues/1378
16:15:08 <andreasn_> this is based on a mockup by lhinson
16:15:21 <andreasn_> and then a bunch of back and forth we stefw and myself
16:15:28 <sgallagh> #topic new journal layout
16:15:44 <andreasn_> ugh, sorry
16:15:56 <stefw> i think the design is ready ... so the question of implementation ...
16:16:02 <stefw> in general we should try not to have design sit and rot
16:16:21 <stefw> but i imagine this will have to wait until the new year, right?
16:16:33 <andreasn_> yeah
16:16:39 <andreasn_> xmas holidays are coming
16:16:52 <stefw> it's the sorta task that a new contributor could take on once they're up to speed and have done some other smaller contributions
16:17:11 <andreasn_> I think we also need to break it up in smaller pieces a bit, the search logic is a big beast in itself
16:17:18 <stefw> andreasn_, that would be good
16:17:21 <stefw> do you have time to do that?
16:17:35 <andreasn_> yeah, sure
16:17:49 <stefw> even several smaller tasks would be great
16:18:12 <stefw> #action andreasn will break down the journal design into smaller tasks
16:18:14 <andreasn_> yeah, I think there is one for the monospace font
16:18:30 <stefw> andreasn_, you can add them to a Checklist in the trello card
16:18:35 <andreasn_> and the moving around of date, error message and service is another one
16:18:38 <andreasn_> sure
16:18:41 <stefw> https://trello.com/c/if88ORZv/73-new-journal-look
16:19:00 <andreasn_> yeah, that's it for that one, please comment on the bug if you have any more comments
16:19:05 <andreasn_> next one?
16:19:10 <stefw> yup
16:19:14 <andreasn_> #topic merging metric channels
16:19:41 <stefw> mvollmer, Where do we stand on the metric channel work? Any chance of getting it in this week?
16:20:01 <mvollmer> depends on the scope of features
16:20:15 <mvollmer> so, I am now moving up to the dashboard plots
16:20:54 <mvollmer> i am quite confident that we can replace them with pcp metrics tomorrow or so.
16:21:05 <mvollmer> well, in my branch
16:21:12 <stefw> Cool. How is the testing looking?
16:21:19 <mvollmer> so missing: docs, test cases, and archives
16:21:23 <andreasn_> what new dependencies are we adding with the pcp work?
16:21:29 <mvollmer> I have a plan for tests
16:21:32 <stefw> There's one dependency on pcp-libs
16:21:35 <mvollmer> not sure how much work it will be
16:21:42 <stefw> Which is very minor
16:21:54 <stefw> mvollmer, and I have discussed a contingency plan if that dependency proves problematic
16:22:02 <stefw> in order to make it optional
16:22:07 <mvollmer> i'll import the "trivial" pmda example into our sources and then write a mock pmda based on that
16:22:20 <andreasn_> just wanted to check what I need to install in order to get cockpit to compile
16:22:20 <mvollmer> is that the avahi dep?
16:22:28 <stefw> well the pcp-libs dep
16:22:32 <stefw> which brings in avahi-libs
16:22:52 <mvollmer> ok, pcp-libs should be unproblematic by itself, I hope
16:22:57 <stefw> if one of both are problematic and present real adoption problems, then we need to consider our contingency, which is to move the pcp-libs dependent code out of process
16:23:07 <stefw> but that's out of scope for this initial work, and we shouldn't consider it a blocker
16:23:12 <mvollmer> so, if we scope out archives, I think I can get the metrics channel "done" this week.
16:23:19 <stefw> yes, lets scope out archives
16:23:48 <stefw> mvollmer, could you make a small note here: https://trello.com/c/lgdUviDQ/50-pcp-based-monitoring-and-metric-channels
16:23:58 <stefw> about the status and fix up that card to reflect reality?
16:24:31 <stefw> #infyo PCP archives are out of scope for initial merge
16:24:34 <stefw> #info PCP archives are out of scope for initial merge
16:25:25 <mvollmer> ok
16:25:45 <stefw> just wanted to say this is pretty cool stuff
16:25:46 <stefw> i tried it out today
16:26:00 <andreasn_> how urgent is designs for the historic graphs?
16:26:18 <stefw> andreasn_, it would be cool to work on that when you're done with the journal work
16:26:25 <stefw> so we can get the dashboard "done" and move on
16:26:29 <stefw> that's just my opinion though
16:26:36 <andreasn_> stefw: all right. I think I can start this week
16:26:49 <andreasn_> also working on finishing the download page for the website
16:27:04 <andreasn_> but that should be done today or tomorrow
16:27:51 <stefw> andreasn_, oh yes that would be cool to get done ... i forgot about that
16:28:01 <andreasn_> will post more info here https://github.com/cockpit-project/cockpit/wiki/historical-performance-data
16:28:28 <andreasn_> the website is close to done, but had a bit more programming than I first thought :)
16:29:09 <andreasn_> all right, anything more for PCP?
16:29:28 <stefw> sounds like we can move on
16:29:50 <andreasn_> #topic server roles
16:30:00 <stefw> is this sgallagh's topic?
16:30:06 <andreasn_> yeah
16:30:19 <andreasn_> we have the start of a wiki page here https://github.com/cockpit-project/cockpit/wiki/Roles
16:30:33 <andreasn_> it's a bit more urgent if we want to get it in for F22 than I first thought
16:30:38 * stefw posts this for reference: https://fedorahosted.org/rolekit/
16:30:42 <sgallagh> Right
16:30:46 <andreasn_> since the idea is to have a shorter release cycle for F22
16:30:54 <andreasn_> if I understood things correctly
16:31:06 <sgallagh> Right now we're talking about a late February/early March Alpha Freeze
16:31:09 <stefw> I would be happy to do a brain dump of where we are right now with sgallagh
16:31:18 <sgallagh> (That may change, but best not to assume it will)
16:31:24 <stefw> and that could help us decide what's in out of scope
16:32:26 <sgallagh> Sure
16:32:32 <sgallagh> /me listens intently
16:32:52 <stefw> but lets not do it here
16:33:12 <sgallagh> ah
16:33:16 <sgallagh> OK
16:33:18 <stefw> my main question is whether sgallagh will be able to help do some of the work?
16:33:29 <stefw> and we can contribute back and forth on it?
16:33:33 <sgallagh> I expect so
16:33:51 <sgallagh> I'll be working on the rolekit side of things at minimum
16:34:22 <stefw> ok i'll work out a time to discuss this in more depth
16:35:02 <andreasn_> cool
16:35:07 <sgallagh> OK, sometime this week would be best; after that, vacations start getting in the way
16:35:13 <andreasn_> yeah, for me too
16:35:16 <stefw> yup
16:36:10 <stefw> ok, next topic?
16:36:13 <andreasn_> yep
16:36:15 <andreasn_> #topic dashboard status
16:36:27 <stefw> Several branches have merged from the Dashboard work
16:36:38 <stefw> but there is a large amount of work that is sitting in my WIP branch
16:36:51 <stefw> and I need to work to lock down the scope of what gets merged initially
16:37:10 <stefw> I'm at the point where we're pulling machines, objects, and events from multiple sources
16:37:36 <stefw> but obviously we can't pull information from everywhere in the initial merge
16:38:40 <stefw> one of the main sources of information
16:38:49 <stefw> is the machines file, which the 'add server' dialog populates
16:39:20 <stefw> and at a very minimum the initial merge will need to just pull machines from there
16:39:24 <stefw> but then we're not adding any new features
16:39:30 <stefw> similar to mvollmer's work on the metrics channel
16:39:46 <stefw> are we ok with an initial merge that just refactors how the dashboard loads and lists machines?
16:39:50 <andreasn_> yeah
16:40:00 <stefw> i have proven the concept in my WIP branch
16:40:00 <mvollmer> yes
16:40:25 <stefw> ok, i'll do that
16:40:34 <stefw> that'll help make this more manageable as it is a very large change
16:40:57 <stefw> #action stefw will focus on refactoring the existing machines code as an initial dashboard merge
16:41:23 <stefw> fwiw, i have been pulling information from these sources
16:41:26 <stefw> in some cases minimal information:
16:41:35 <stefw> systemd, machined, rolekit, kubernetes
16:41:48 <stefw> and so i'll break each of these into a follow up commit
16:42:48 <andreasn_> sounds good
16:43:03 <andreasn_> next one?
16:43:57 <stefw> yup
16:44:28 <andreasn_> #topic problem reporting
16:45:40 <andreasn_> so aday mentioned earlier that he's working on ABRT error reporting for the desktop
16:45:59 <andreasn_> and that's something that would be nice to tackle for Cockpit at some point too
16:46:09 <andreasn_> he was going to share his notes
16:47:29 <andreasn_> we're going to discuss it more tomorrow
16:49:11 <andreasn_> #topic RHEL 7.0 build
16:49:49 <andreasn_> stefw: your topic?
16:50:41 <stefw> sorry
16:50:47 <stefw> had to step out for a moment
16:50:57 <stefw> Cockpit not builds on RHEL 7.0 by disabling cockpit-ws
16:51:13 <stefw> the libssh and glib dependencies are not new enough to successfully run cockpit-ws
16:51:19 <stefw> in the glib case it causes crashes
16:51:24 <stefw> and libssh is not available
16:51:31 <stefw> but the rest of cockpit builds and runs
16:51:43 <stefw> so you cannot connect to a RHEL 7.0 machine directly
16:52:05 <stefw> RHEL 7.1 beta was announced today
16:52:18 <stefw> and on RHEL 7.1 we have a newer glib dependency
16:52:34 <stefw> so i guess the question is whether we want to also add an openssh based alternative to libssh
16:52:45 <stefw> so that we can build cockpit-ws on systems that don't have libssh
16:53:13 <mvollmer> i think it is reasonable to require libssh
16:53:43 <stefw> i guess we could see about shipping it in the cockpit package on those systems that don't have it?
16:54:06 <stefw> or just leave cockpit-ws off of systems that don't have libssh?
16:54:23 <mvollmer> hmm, I would expect the distribution to import it as well, when importing cockpit
16:54:41 <stefw> if we build in something like EPEL we have to be careful about bringing in all sorts of dependencies
16:54:50 <stefw> if those dependencies could later be in the distro proper
16:54:56 <stefw> it causes lots of packaging issues
16:54:57 <mvollmer> yeah, but we are careful, no?
16:54:59 <mvollmer> :)
16:55:11 <stefw> yes perhaps
16:55:11 <mvollmer> libssh doesn't feel random to me.
16:55:51 <stefw> well we know the alternatives and we can make a decision when we get closer to the point where we actually want to do something like put cockpit in EPEL
16:56:17 <andreasn_> what's EPEL?
16:56:28 <stefw> it's Fedora curated add on repository for RHEL
16:56:34 <andreasn_> ah, ok
16:56:36 <stefw> so you can put RHEL addon packages there
16:56:48 <sgallagh> stefw: The other alternative would be to carry a "fork" of libssh that just changes the shared lib name
16:57:01 <sgallagh> Well, not "carry" but build and depend on
16:57:06 <stefw> sgallagh, yes right, that's what i was alluding to above
16:57:13 <sgallagh> ah ok
16:57:18 <stefw> and the question is whether that is simpler than just having an alternate transport that uses the ssh client
16:57:22 <stefw> i suspect the latter is simpler
16:57:35 <stefw> but i'll try to examine this further and document the options pros/cons clearly
16:57:43 <sgallagh> It's one fewer thing to maintain/catch bugs in
16:57:48 <stefw> indeed
16:58:00 <stefw> well actually you can say that as a pro/con of both options
16:59:20 <sgallagh> We can figure that out later.
16:59:24 <stefw> yup.
16:59:27 <stefw> ok, next topic?
16:59:42 <andreasn_> #topic Debian build and packaging
16:59:55 <stefw> we do routine builds on debian as part of our CI
16:59:58 <stefw> but we haven't actually tested the result
17:00:09 <stefw> today i tried to build and run on debian
17:00:14 <stefw> and it worked better than i expected
17:00:34 <stefw> i wonder if we should try to figure out how to get a debian packager, or look into being our own debian packager, or do an ubuntu PPA?
17:00:49 <stefw> i think doing this would bring in more contributors and make us more well rounded
17:01:07 <stefw> does anyone have opinions here?
17:01:29 <andreasn_> someone who's good at debian might be better
17:01:31 <mvollmer> i am in favour
17:01:37 <andreasn_> who would be able to maintain it there
17:01:41 <stefw> right
17:01:46 <mvollmer> me used to do debian packages in $previous_job
17:01:52 <stefw> oh awesome :D
17:02:02 <mvollmer> but I was never part of debian
17:02:05 <stefw> i wonder if we should just do a PPA?
17:02:09 <stefw> on ubuntu?
17:02:15 <andreasn_> could do at least for now
17:02:23 <stefw> and then put out a call for an interested bonafide debian packager to take over?
17:02:28 <andreasn_> sure
17:02:37 <mvollmer> stefw, what's missing?
17:02:48 <mvollmer> broadly?
17:02:56 <stefw> well the debian rules/control files
17:02:59 <stefw> all of that
17:03:09 <stefw> 2. choosing dependencies that we drag in
17:03:14 <mvollmer> no, I meant, in the cockpit ui.
17:03:21 <mvollmer> you said many pages are empty?
17:03:33 <stefw> yes, because i didn't have storaged installed, for instance
17:03:43 <mvollmer> ok, I see.
17:03:59 <mvollmer> no systemd, maybe?
17:04:04 <stefw> no i had systemd
17:04:09 <stefw> and that all worked
17:04:17 <mvollmer> cool
17:07:29 <stefw> mvollmer, so when you have spare cycles, perhaps we can get something going?
17:07:36 <stefw> likely after the new year, i imagine
17:07:42 <mvollmer> yes
17:08:01 <mvollmer> hmm, so much to do...
17:08:06 <stefw> yup
17:08:49 <subin> :)
17:09:47 <andreasn_> anything else, or should I close the meeting?
17:09:55 <stefw> that's it from me
17:10:10 <andreasn_> cool
17:10:13 <andreasn_> #endmeeting