13:02:04 <andreasn> #startmeeting
13:02:04 <zodbot> Meeting started Mon Sep 28 13:02:04 2015 UTC.  The chair is andreasn. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:02:09 <andreasn> .hello andreasn
13:02:10 <zodbot> andreasn: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
13:02:24 <mvollmer> .hello mvo
13:02:25 <zodbot> mvollmer: mvo 'Marius Vollmer' <marius.vollmer@gmail.com>
13:02:46 <dperpeet> .hello dperpeet
13:02:47 <zodbot> dperpeet: dperpeet 'Dominik Perpeet' <dperpeet@redhat.com>
13:03:51 <andreasn> #topic agenda
13:04:09 <mvollmer> * Fedora 23
13:04:18 <andreasn> was just about to type that :)
13:04:22 <andreasn> * iscsi
13:05:08 <andreasn> * selinux maybe
13:05:19 <stefw> * alerts/tasks dashboard
13:05:32 <stefw> * libvirt based tests
13:05:49 <stefw> * Continuous delivery update
13:06:47 <andreasn> anything else?
13:06:51 <andreasn> ok, lets start with f23
13:06:57 <andreasn> #topic Fedora 23
13:07:15 <mvollmer> we should get ready for F23
13:07:27 <stefw> part of that is the testing
13:07:31 <stefw> what are the blockers there?
13:07:41 <mvollmer> I am going to check next
13:07:43 <andreasn> https://fedoraproject.org/wiki/Releases/23/Schedule
13:07:49 <mvollmer> didn't get around to it today yet
13:07:58 <andreasn> final release is one month from now
13:07:59 <mvollmer> docker had trouble with pulling
13:08:18 <petervo> the bug listed as the last blocker in the ticket should be finx
13:08:22 <petervo> fixed*
13:08:36 <mvollmer> okay
13:08:38 <andreasn> what's the url to the ticket?
13:08:40 <petervo> in the latest docker release
13:09:11 <petervo> https://bugzilla.redhat.com/show_bug.cgi?id=1262796
13:09:19 <andreasn> #info https://bugzilla.redhat.com/show_bug.cgi?id=1262796
13:09:28 <mvollmer> the graphs need to be prettied up severely
13:09:56 <andreasn> could you file an issue about that?
13:09:59 <stefw> if i had time i would help move them to D3
13:10:01 <stefw> andreasn, i have
13:10:05 <stefw> let me find it
13:10:20 <dperpeet> the fedora 23 pull request conflicts with libvirt use
13:10:22 <stefw> https://github.com/cockpit-project/cockpit/issues/2775
13:10:24 <dperpeet> slightly
13:10:29 <andreasn> #info https://github.com/cockpit-project/cockpit/issues/2775
13:11:01 <dperpeet> I can rebase the #2543 and try it out later
13:11:03 <mvollmer> dperpeet, how?
13:11:11 <dperpeet> only the setup script, minor stuff that I can easily fix
13:11:18 <mvollmer> just merge conflict?
13:11:19 <mvollmer> okay
13:11:49 <dperpeet> let's discuss that later in the agenda
13:11:55 <mvollmer> okay
13:12:02 <andreasn> I did some mockups last weeks for graphs, based on the examples from patternfly
13:12:07 <dperpeet> #action dperpeet will either rebase #2543 or review it as it is
13:12:09 <mvollmer> so, prio item for me is then to get those tests running on f23.
13:12:09 <andreasn> I'll add them to the issue
13:12:25 <mvollmer> and fix the issues they find
13:12:50 <dperpeet> I believe we can merge the changes even if not all pass
13:12:57 <stefw> yup
13:13:00 <stefw> agree
13:13:06 <dperpeet> just to get a partial review and merge going
13:13:29 <dperpeet> as I said, I'll take the current #2543 later
13:13:47 <github> [cockpit] stefwalter pushed 1 new commit to master: http://git.io/vcIYC
13:13:47 <github> cockpit/master 30193e7 Marius Vollmer: bridge: Don't crash when unable to retrieve PCP instance names...
13:13:58 <mvollmer> dperpeet, what do you mean with "take"
13:14:06 <dperpeet> review and merge, if it runs f23
13:14:12 <dperpeet> even if not all tests pass
13:14:13 <mvollmer> okay
13:14:18 <dperpeet> rebase on libvirt if that gets merged
13:14:37 <dperpeet> #2759, to be discussed in a later agenda point
13:14:41 <mvollmer> okay, thanks!
13:15:40 <andreasn> mvollmer: do you think we should aim to get iscsi support in for fedora 23?
13:15:56 <mvollmer> i think so
13:16:06 <dperpeet> are we on the next topic now?
13:16:08 <mvollmer> it depends on our dependencies
13:16:10 <stefw> if so, we need to make a bugzilla bug
13:16:13 <stefw> and track it properly
13:16:14 <dperpeet> :)
13:16:15 <mvollmer> if they are ready, we are.
13:16:16 <stefw> because it's a bunch of dependencies
13:16:21 <andreasn> no, still on F23
13:16:40 <andreasn> but we can move ahead to next topic
13:16:44 <stefw> who will make a tracker bug for F23 iSCSI and track the issues against the various Fedora packages properly?
13:16:46 <dperpeet> do we still need new iscsi upstream changes?
13:16:57 <andreasn> #topic iscsi
13:17:35 <mvollmer> #action mvo file tracker bug for iscsi dependencies
13:18:02 <mvollmer> dperpeet, yes, in storaged and iscsi-initiator-utilities
13:18:16 <dperpeet> mvollmer, thanks!
13:18:45 <mvollmer> ok, about iscsi.
13:19:00 <mvollmer> andreasn and me had a ui review meeting
13:19:07 <mvollmer> andreasn, do you want to summarize?
13:19:17 <andreasn> yes
13:19:29 <andreasn> so there are a couple of issues we identified:
13:20:02 <andreasn> * there is a lot of buttons at the top of the right sidebar in Storage
13:20:10 <andreasn> (when iscsi is added)
13:20:38 <andreasn> * we need some kind of authentication for the case where discovery and add auth is different
13:20:54 <andreasn> * the error states we get from the API are kind of raw
13:21:27 <andreasn> * we need an elegant way of renaming the initiator name
13:21:52 <andreasn> I updated the mockups after the meeting, but it still lacks the renaming ui https://raw.githubusercontent.com/cockpit-project/cockpit-design/master/storage/iscsi-v2.png
13:22:29 <andreasn> I'm leaning towards having all the sections show as panels with add buttons on them, instead of separate buttons at the top
13:23:10 <andreasn> because the other option would be some kind of general "add storage" button with a dropdown of different types
13:23:23 <andreasn> but that doesn't cover the renaming iscsi case
13:23:44 <andreasn> so in that case the panels would work better
13:24:34 <mvollmer> yes, a empty panel isn't much worse than a button
13:24:56 <andreasn> we also spoke about that we should perhaps list all the block devices accosiated with a iscsi portal could be listed on a iscsi details page
13:25:17 <andreasn> but that would need support in the backend (if I recall correctly)
13:26:14 <mvollmer> correct
13:26:22 <andreasn> I think that was it on iscsi
13:27:08 <andreasn> next topic?
13:27:49 <andreasn> all right
13:27:52 <andreasn> #topic selinux
13:28:51 <andreasn> the current state of the mockups are here https://raw.githubusercontent.com/cockpit-project/cockpit-design/master/selinux-troubleshooting/selinux-v4.png
13:29:07 <andreasn> not super-elegant, but it's a start
13:29:51 <github> [cockpit] petervo opened pull request #2855: shell: Check source exists before running init (master...check-source) http://git.io/vcIGN
13:30:11 <dperpeet> andreasn, do we deviate from the standard journal layout for a reason?
13:30:26 <dperpeet> the "collapsed list" in the mockup
13:30:44 <dperpeet> I would have thought that the display should be pretty similar
13:31:11 <andreasn> it's a similar widget to what stefw have been using for kubernetes
13:31:14 <stefw> hmmm, i'd like to discuss this and the image scanning stuff
13:31:20 <stefw> but yes, the listing widget applies well
13:31:44 <dperpeet> then what is the scope of the list?
13:31:52 <stefw> one of teh agenda points next in the meeting is the
13:31:55 <stefw> tasks/alerts dashboard
13:32:18 <stefw> and i'd like to see if we can combine this with scap, image scanning and other things to have a sane interface
13:32:33 <andreasn> I see
13:32:38 <andreasn> good idea
13:32:48 <stefw> i've setup a discussion to brainstorm this
13:32:58 <stefw> because as you probably noticed
13:33:04 <stefw> having 'SELinux Access Control' in the sidebar seems strange
13:33:07 <stefw> especially for troubleshooting
13:33:10 <dperpeet> yeah
13:33:23 <stefw> i also thing this has a strong case for displaying stuff across multiple machines
13:33:28 <andreasn> right
13:33:32 <stefw> for troubleshooting tasks, that seems like a really good fit
13:33:43 <stefw> at least be able to identify where the problems are, and then perhaps zoom in?
13:34:37 <stefw> or rather "dive" in
13:34:39 <dperpeet> what about timestamps?
13:34:48 <stefw> yeah, good point
13:34:50 <andreasn> yes, timestamps are indeed missing
13:34:54 <stefw> when something happened is just as important as what happened
13:34:58 <andreasn> I wanted to add them, but did the basics first
13:35:05 <dperpeet> it should be pretty similar to the journal I think
13:35:13 <andreasn> with expander etc
13:35:16 * stefw notes that listing design is being fine tuned by the patternfly folks
13:35:18 <dperpeet> pick a date, have timestamps and "load more"
13:35:43 <stefw> i don't think this is about cataloging the troubleshooting though
13:35:46 <stefw> it's not a journal use case
13:36:01 <dperpeet> ok, but still: how do you scope the information?
13:36:10 <dperpeet> this list could potentially be pretty long
13:36:12 <andreasn> it's a database that selinux has
13:36:16 <dperpeet> or at least have a button "clear old events"
13:36:18 <stefw> we should order it
13:36:23 <stefw> and yes, ability to clear in bulk
13:36:25 <dperpeet> I could live with it if I could clear it
13:36:29 <stefw> but the idea is that you fix the problems
13:36:30 <stefw> as the admin
13:36:34 <andreasn> ok, I'll add a clear action
13:36:45 <dperpeet> timestamps + clear and I'm happy with how it is now
13:37:04 <dperpeet> future addon: filter the list
13:37:18 <dperpeet> or highlight search matches
13:37:37 <dperpeet> but that's beyond a first implementation
13:37:45 <github> [cockpit] stefwalter opened pull request #2856: test: Fix race in check-pages and check-multi-machine (master...test-frame-reload) http://git.io/vcIn9
13:37:45 <stefw> yes, the listing pattern has a strong filtering concept
13:38:51 <andreasn> so next up is alerts/tasks dashboard since we're kind of touching on that already
13:38:57 <andreasn> #topic alerts/tasks dashboard
13:39:09 <stefw> So the high level is, that i'd like to see if we can work on a third dashboard
13:39:20 <stefw> multi-machine ... where 'tasks' or 'alerts' percolate up from the machines
13:39:32 <stefw> so that's what selinux troubleshooting is ... for example
13:39:51 <stefw> and because not all alerts or tasks are so beautifuly asynchronously delivered ... there may need to be scan actions on that page as well
13:39:57 <stefw> for example scanning for image vulnerabilities
13:40:01 <stefw> in containercs
13:40:03 <stefw> or scap
13:40:11 <stefw> these are multi machine features inherently
13:40:21 <stefw> because trawling machines for problems or things to fix is not cool
13:40:28 <andreasn> right
13:40:35 <stefw> obviously there are some limitations on the implementation side we need to consider
13:40:51 <stefw> as well as design limitations, and configuration, machine heterogenity stuff etc.
13:41:04 <stefw> and i've set up a deeper discussion and brainstorm, if it works for you guys
13:41:17 <andreasn> yup
13:41:50 <stefw> that's all i had on that topic
13:41:51 <andreasn> would this touch upon getting error delivery via e-mail or whatever too? Like how broad would the initial scope be?
13:42:00 <github> [cockpit] mvollmer pushed 1 new commit to master: http://git.io/vcIc7
13:42:00 <github> cockpit/master c91b488 Stef Walter: test: Respect timeouts for 'reload' and 'expect-reload'...
13:42:26 <stefw> well the dashboard itself cannot do delivery by email
13:42:32 <stefw> but we may want to figure that out
13:42:36 <andreasn> ok
13:42:46 <stefw> or at least have an idea of how some part of the system could do that
13:42:53 <andreasn> yeah
13:43:11 <andreasn> all right, sounds like we have plenty to talk about in the deeper meeting then
13:43:15 <andreasn> interesting stuff
13:43:34 <andreasn> next topic?
13:43:37 <andreasn> #topic libvirt based tests
13:43:58 <dperpeet> apparently the new images were generating failures
13:44:02 <dperpeet> independent of the libvirt changes
13:44:29 <dperpeet> and to make network handling simpler, stefw added patches https://github.com/stefwalter/cockpit/tree/test_libvirt
13:44:38 <dperpeet> to use qemu monitor commands again
13:45:10 <dperpeet> there are still some issues with that
13:45:27 <dperpeet> but I have addressed the review comments in https://github.com/cockpit-project/cockpit/pull/2759
13:45:38 <dperpeet> and once we get the networking to work properly, I think we can merge
13:45:51 <dperpeet> I think that about covers it, stefw?
13:45:55 <stefw> yup
13:46:07 <stefw> once this lansd ... there will likely be yet another batch of races
13:46:09 <stefw> just because
13:46:16 <stefw> the races are there ... waiting to jump out
13:46:24 <stefw> when the way we run our tests changes
13:46:34 <stefw> but such is life
13:46:36 <dperpeet> and it seems we've accrued some technical debt with out older test images
13:47:16 <stefw> i suspect that the new image failures are related to new packages that have bugs
13:47:22 <stefw> probably NetworkManager or something like that
13:47:27 <dperpeet> probably
13:47:41 <stefw> you can check out the master tests if you want to be sure
13:49:53 <andreasn> anything else on that topic?
13:50:00 <dperpeet> not for now
13:50:10 <andreasn> #topic Continuous delivery update
13:50:28 <stefw> Work on continuous delively in progressing.
13:50:47 <stefw> We have credentials setup independent of any particular person.
13:51:06 <stefw> Cockpit accounts for Fedora, Github, Koji, Copr, Dockerhub, Bodhi
13:51:21 <dperpeet> good news!
13:51:23 <stefw> Fedora updates are now automatically generated by the release scripts
13:51:39 <stefw> they are generated in such a way that 3 people need to test them before they go into production
13:51:49 <stefw> ie: a karma of +3
13:52:04 <stefw> i'd be happy to tweak that if there's a good reason
13:52:15 <andreasn> do they still come out on Wednesdays?
13:52:18 <stefw> everyone jumped in and help test: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16557
13:52:35 <stefw> andreasn, the plan is that whenever we sign a tag in git, then the release process begins
13:52:42 <stefw> however for now, it's manually triggered, as we're working out the kinks
13:52:55 <stefw> My next task on CD is to make each bit of it idempotent
13:53:04 <stefw> so one can resume a broken release process and complete the tasks
13:53:10 <andreasn> cool
13:53:15 <stefw> or if a bot loses state of where it was, it'll pick up in the right place
13:53:32 <stefw> since i only get to test this once or twice a week, progress is slow
13:53:35 <stefw> but that's fine with me
13:53:47 <stefw> lastly
13:53:58 <stefw> i'm going to be working on a script which prepares a patch between two tarballs for use on stable branches
13:54:09 <stefw> last week we released a new cockpit build for Fedora 22
13:54:16 <stefw> and had to do manual patching
13:54:16 <stefw> https://bodhi.fedoraproject.org/updates/FEDORA-2015-5b605ec0cf
13:54:37 * stefw notes that this ^^ still needs more testing
13:54:46 <stefw> 2 more people
13:55:04 <stefw> that's it on that topic
13:55:32 <andreasn> all right
13:55:38 <andreasn> #topic Open Floor
13:55:48 * mvollmer has to leave
13:56:00 <stefw> i have other topics, but i'll hold onto them for next time
13:56:05 <stefw> if people have to leave
13:56:14 <stefw> or i'll just repeat them again
13:56:19 <stefw> Documentation is one
13:56:24 <andreasn> shoot
13:56:37 <stefw> there's now a 'Feature Internals' section in the documentation
13:56:38 <stefw> http://files.cockpit-project.org/guide/latest/features.html
13:56:49 <stefw> which describes how we interact with the system to make each of the features work
13:56:54 <stefw> what privileges are necessary
13:57:02 <stefw> and how to perform similar tasks from teh command line
13:57:11 <stefw> these are by no means complete
13:57:42 <stefw> as we add functionality to a feature in cockpit, during review, we should check if anything should be added here
13:57:58 <stefw> an example of something that's missing:
13:57:59 <stefw> http://files.cockpit-project.org/guide/latest/feature-pcp.html
13:58:05 <stefw> that page should include documentation about where the archives are put
13:58:14 <stefw> and which services are started when the PMlogger service is turned on
13:58:21 <stefw> that's the sorta thing we should be documenting there
13:58:55 <stefw> i also broke out the documentation for cockpit.js
13:58:55 <stefw> http://files.cockpit-project.org/guide/latest/api-base1.html
13:59:01 <stefw> so things are more easily accessible
13:59:12 <stefw> and gave a general facelift to the documentation
13:59:59 <andreasn> looks good
14:00:00 <stefw> anyway, just a heads up
14:01:23 <andreasn> anything else for the meeting?
14:01:27 <andreasn> we're at the hour mark
14:02:14 <andreasn> all right, thanks for attending everyone!
14:02:18 <andreasn> #endmeeting